Wifi Issues since Roon

I have a totally ethernet network for Roon but my wifi, which is connected to the router switch via cat 5, has had big problems since I started using Roon four days ago. Basically it stops working every time a Roon endpoint (i.e my laptop) is disconnected from the wired network and has to be power cycled to get it going again.

Any ideas? Thanks

Hi @AndyP ---- Thank you for the report and sharing your observations with us. The insight is appreciated!

Moving forward, my apologies for any confusion on my end (:innocent:) as it is a touch unclear to me as what exactly the issue is. My sense of the problem is the following:

Everything in your Roon setup is communicating with your network via a hardwired connection (i.e Cat5) and when the Cat5 is pulled from your laptop which is acting as an endpoint the WiFi ceases to work. Is this correct?

Besides providing some further feedback into the issue being experienced, may I also ask you to please describe your setup using this link as a guide. Having the details of your network configuration/topology would also be very helpful.


Hi Eric
Thanks for the reply. Further to the first post the wifi seems to stop without pulling an endpoint off of the network…it just seems randomly to stop, having never stopped before in 2 years.
I’ll fill out the link first though so that might help.

What router are you using?
A TPLINK TD 8840 T modem router with a TPLINK TLwWR08N wifi transmitter attached via cat5
When did you last update the firmware?
Is there any other networking hardware involved?
Yes Devolo DLAN Duo Network over mains power throughout the house.
Is everything wired, wireless, or is there a mix of wired and wireless gear?
All wired apart from internet browsing/email done on Macbooks wirelessly
Describe Your Media
(if the issue involves playback)
Playback is good

Hi @AndyP ---- Thank you for the follow up(s), very appreciated!

Moving forward, besides having the details of your network configuration, can you possible also provide the details of your Roon setup?

Furthermore, my sense is that the software should not be knocking your Wifi out on your network and as such I am curious. Have you ever observed this issue with your WiFi while the application is not active?


This issue coincides exactly with installation of Roon. Like I said…I have never had a single wifi issue before Roon. It is definitely Roon related!

My Roon setup as requested:
A 2009 MacMini as Core running Roon 1.4 on OSX 10.8.4 audio out on internal mini jack.
Endpoint: MacPro 2009 running OSX 10.12

Last night I booted up Roon for the first time in 2 days and the wifi packed in immediately.

Hi Eric
I’d really like to sort this as my demo is coming to an end and as it stands I cannot take up membership.

Hi @AndyP ---- Thank you for touching base with me and providing the requested feedback. Appreciated.

Moving forward, I have sent you a PM regarding the time remaining on your trial period with Roon. Secondly, I am going to be touching base with the team to get some more feedback on this issue you are experiencing with your Wifi.

In the meantime, I would like to recommend the following tests to see if we can trigger a change in behavior with your setup. Please see below.

Test# 1 - Does your Wifi drop with just the TPLINK TD 8840 T modem router in play with the mentioned Wifi transmitter and Devolo DLAN devices temporarily disabled?

Test# 2 - Does your Wifi drop with the TPLINK TD 8840 T and TPLINK TLwWR08N wifi transmitter in play with the Devolo DLAN devices temporarily disabled?


The first test isnt valid as there would be no wifi if I disconnected the wifi transmitter!

I have replaced the WR802N as when I tried to update the firmware it bricked. I therefore thought it was likely to be the culprit so purchased another wifi access point.

On installing it I got several hours thinking it had solved the problem until…it happened again! So better…but not solved. so I will try your suggestion of loosing the Devolo next.

OK test completed. Devolo taken out of circuit leaving Macmini Roon Core connected straight to the 8840T + WiFi Access Point and within 5 minutes the WiFi was taken down.



This support is going sloooow…

So I’ve got a new Wireless Access Point, I’ve gone into the ADSL Router and reset it completely. I’ve disconnected all the Devolo network points…and exactly the same problem persists.
I’ve spoken to my ISP who are good on networking support and they cannot suggest anything.

Come on Roon…this MUST have happened before…



No offense, but I read most of the stuff on the forum — I should probably get a life at some point — and I can’t remember seeing a report of this. What’s your bandwidth like on that ADSL setup?


Well at last I think I got to the bottom of it!

My wireless access point (which is separate from my Modem/Router) … wonderful support at my ISP suggested giving it a static ip address, and so far…so good.

Basically I have now given _everything_static ip addresses and all seems stable.

I am surprised this has never come up before however.

Glad you got this worked out @AndyP.

The network setup you’re running isn’t too exotic, but it’s not particularly common either, and Eric had brought this to me and our CTO late last week. I think you got caught in a little pre-holiday squeeze here, so we discussed and it took a little longer than normal to get back to you.

Any more issues, just let us know. Thanks!



1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.