Windows 8.1 : Blank (white screen) after maximising

Have just downloaded & installed the Windows build 21 version.

While Roon was scanning my (watched) folder, I kept it minimised on my desktop, went back to it a couple of times, and then the last time I just had a “blank” screen (white) with a border. No other options except for clicking the “close” x in the top right corner.

Re-started, all was well, music playing & scanning continued as before.
I’ve selected the “dark theme”, in case that’s important.

Have just had the same thing happen twice more.

Am running Windows 8.1 with all the latest drivers, on a 64bit 3.5GHz i7 with 16GB RAM.

Let me know if you need any more information.

Short answer…don’t minimize the app!!

There are still some issues with the graphics drivers when run in minimised mode

Roon guys say they are working on a fix…and may comment further once they read this

Update : it’s just done it again, but differently - in the sense that I didn’t minimise - but I| just let it run in the background behind my other windows.
Now that’s slightly annoying… I will try to see if it’s triggered (only) by using the taskbar button.

@rolski what graphics card are you using, if Nvidia or Amd have you set Roon to always use it rather than the built in graphics?

See this post


I don’t have another graphics card installed, and my drivers are up-to-date.

I haven’t had any problems with any other software, Roon runs fine on my Surface 3 Pro (so far), and I’ve been running some graphics-intensive programmes from time-to-time on my desktop PC.

Reasonably, this shouldn’t happen. Not sure where the problem is coming from…

So which graphics card do you have, Intel built in? If so which one?


Intel HD Graphics 4000.

I have a pc with that, I will test and see if I can replicate your problem…


The Intel 4000 is a problem in this respect, as are some later ones like 4600 I think. The latest driver does not fix it. Roon is the only thing on my laptop which does this. As far as I know, there is no fix at the moment and I am not sure who is supposed to come up with it.

@rolski Hi Roland, I believe you have the HD Graphics 4400 chip in your Surface Pro 3

@jobseeker Hi Paul, does the Roon Graphics issues affect you only after minimizing…or does it happen even during normal use of the Roon app…or when bringing the App from the Background to the Foreground of open apps??

@ronnie Hi there : slight misunderstanding - on my Surface 3 Pro there’s no problem at all (currently no idea what graphics chip it has) - but I do have a problem with my desktop PC running an i7 / HD4000.

@Ronnie - I have the problem only after minimising as far as I know. I haven’t updated to the new build yet.

My situation’s completely FUBAR now : after a lot of research I tried to update my drivers, following the Intel instructions, which seemed the most comprehensive, sensible, and most quoted.
Rolled-back to the most basic driver as instructed, but now can’t install anything at all - just have the “Video Controller (VGA Compatible)” driver - and now Roon won’t run as it’s asking me to update to OpenGL, which of course I can’t.
Any attempt to install graphics drivers now results in an “incorrect driver” message, or “an error occurred during install”.
This means that my desktop PC works, but I can’t use any of the graphics features on my CPU, and of course Roon won’t run - on day ~2 of my trial.
Have downloaded drivers & checking programmes from Microsoft, ASUS (have updated my BIOS just in case), and Intel. Not amused…

@rolski Do you have a cloned image you could restore?


Nope. Am scuppered. Spent 4 hours last night trying to recover the situation, and another 2 hours this evening already.
Seems like a weird permissions problem, or something similar, but no amount of scanning / repairing / downloading / updating has any effect at all.
Am totally out of ideas & all this because of the Roon “white border” problem.

scratch that - I did have a restore-point after all (thanks Russ for motivating me to go & check again) and it’s worked - have rolled back a week and all is well again.

Right, on with the show - and back to the script - who’s going to fix this blank / white screen problem ?! :grinning:

Now Roon - after a fresh install (uninstalled, downloaded a fresh version from the server, re-installed as Admin) - isn’t starting. Windows 8.1. Apart from the white screen, Roon was working fine yesterday.

So, I have my graphics back, but not Roon. Next steps @brian @danny ?

I’m concerned that installing as admin may have caused some permissions issues. The files in Users/USER/AppData/Local/Roon, need to be be owned, readable, and writable by your user account, and installing as Administrator might leave some of them in a different ownership state.

I would start by manually changing the permissions for that entire folder, its subfolders, and files, to be owned by your user account and to allow full access.

If that doesn’t help, @mike can help you extract some logs so we can get more information on why it’s not coming up.

I’m not a good authority on the white screen issues, @danny ?

@brian @mike @danny
Installation is fixed now & working again : I de-installed Roon, searched for & cleared all other remaining files, repaired my registry, checked for any more updates, performed a couple of reboots & a general tidy-up, and then re-installed.

However, I did flick to another window to find the path for my watched (NAS) folder, went back to Roon - and guess what - blank screen…

A restart got me back to where I was, but it seems that literally every single time I move away from the Application, or minimise / maximise, Roon goes blank.


Any resolution here?,I have the exact same thing. Blank screen after minimise.
Unable to get image back until app restart.

Windows 8.1 64bit
Bootcamp Drivers
Intel HD4000 Display

Apple Mac Mini

1 Like

Any update on this?