Yet another Qobuz problem

Core Machine (Operating system/System info/Roon build number)

i5 NUC running V1.7 under WIN10 connected via Ethernet

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

—Ethernet—> RPi 4 w/DietPi ----USB—> Mutec MC-3+ —XLR—> iFI Pro DAC -------etc.

Description of Issue

I have the same problem as others with Qobuz, i.e. tracks not playing all the way thru.
I have noticed the following additional problem.

Track is playing, as indicated by the movement of the scrub bar, but there is no music for the first 1-2 seconds.

It isn’t the case that the first 1-2 seconds of a track are supposed to be silence. I am familiar with the tracks being played that this occurs with and the first 4-5 notes are missing.

E.g. in a playlist with 20 tracks this error will occur multiple times and once it starts it usually continues until playlist is done.

This would seem to be a buffer issue, especially since the following was in the V1.7 release notes -

" ## Streaming Optimizations

For music playing from TIDAL and Qobuz, Roon now buffers data in a less disruptive way, and there are optimizations which reduce disk activity, CPU usage, and memory traffic. This means that streaming content starts faster and slower internet connections (or lower-powered cores) may also benefit when streaming high-resolution content. "

This problem and the track skipping problems make Roon w/Qobuz unlistenable.

I just put a PrimaLuna Evo 400 pre-amp :sunglasses: in my chain and these problems really harsh my mood.:rage:

@support?

2 Likes

Hi @Slim_Fishguttz,

Apologies for the trouble here!

Does the same behavior still occur if you play to System Output of the Core machine with no DSP?

Greetings, brother.

I will try this later (have to rake some leaves now).

As a partial answer see my post here where I have tried that trouble shooting approach -

https://community.roonlabs.com/t/tracks-skip-when-streaming-from-tidal-or-qobuz-since-roon-1-7/84778/56?u=slim_fishguttz

1 Like

Welcome back Slim…

1 Like

I am adding a post in this thread because I have the same problem and can recreate it at will although my tracks play for a while before the problem occurs…

It occurs on many tracks, but always occurs in Qobuz on tracks 1 & 2, usually in movements 2 or 3, here -

I have tried playing this album on my normal chain and on a PC speaker thru WASAPI, on my Core machine. The same problem occurs in both cases.

If I play the same tracks, to my PC speaker, thru the Qobuz app there is no problem.

I reported an additional problem here (with a description of my usual chain). I don’t know if others in this thread have this additional problem and haven’t noticed it or if it’s (as of now) unique to me. -

I’ve tried the usual things, i.e. rebooting Core, logging out/in to Qobuz, and setting Qobuz res to be only CD quality. Nothing makes a difference.

@support?

1 Like

2 posts were merged into an existing topic: Roon 1.7 Feedback Thread

@dylan -

This thread has become a little confusing since my post in another thread that dealt with a different manifestation of a Qubuz streaming problem was, for some reason, merged with this thread.

To be clear, this thread post addresses the seconds of silence at the start of most tracks.

I took the same approach I did with the skipping problem and played tracks to a speaker on my Core machine. The problem occurs. I didn’t try, as above, playing the Qobuz app.

The missing beginning of tracks might be caused by having the tracks from multiple different albums shuffled and queued up. In the way a queue would be populated by queuing a playlist, e.g…

Dunno, can’t be sure, but it looks like the problem occurs when switching from a track on one album to a track on a different album. Interestingly, this problem doesn’t (as yet) seem to occur when switching to different albums’ tracks queued up in Roon radio.

You asked about DSP. I don’t use DSP. Simpler is better.
image

In any event, I suggest putting this on the back burner until the more wide ranging and egregious, but possibly related, track skipping problem is (hopefully soon) resolved.

After that resolution, if this missing note problem is still occurring, I’ll bump this thread.

Hey @Slim_Fishguttz,

Welcome back to the forum :slight_smile:

I noticed you are not playing to System Output in the above screenshot, but rather you mentioned you are playing to a WASAPI zone for your internal speakers.

To remove more variables from the equation, please try starting playback to the laptop’s speakers (I know they might not sound the best :upside_down_face: ) but this will tell us more than another WASAPI zone.

Feel free to let me know now… or whenever you deem appropriate.

Greetings @noris -

I am experimenting with various theories, now.

Let’s revisit this problem when the dust settles on the track skipping problem that others have reported.

Peace.

1 Like

I had opened an incident with Qobuz about the track skipping.

I got a reply from Sébastien stating that -

Thanks for your follow up email. We are working to address this issue with Roon ASAP.”

FWIW

1 Like

Hey @Slim_Fishguttz,

Just wanted to let you know that we recently released build 505 which contains some buffering improvements:

If you haven’t given it a try yet I would see how this build works out on your end, just wanted to let you know.

@noris -

Thanks for the heads up. I left a note this morning in reply to @mike.

The jury’s still out on whether it solved my other problem talked about in this post.

For now, let’s say it’s all good. :sunglasses:

1 Like

@noris - I hope this sounds familiar to you.:slightly_smiling_face:

At least, someone else is having the problem.

Hi @Slim_Fishguttz,

I moved your post over here, it does seem similar but too early to say if it is the same issue.

I’m not a huge classical fan, but I did take a listen to the tracks and I am not hearing any silence in the first few seconds of Piano Concerto No.1/No.2 Tracks 1-3, I can even hear the breathing of the musicians in the background so I believe all the proper track notes are played.

Just to confirm, you’ve been using the Qobuz 48kHz/24-bit version correct? That’s the one I gathered you used from your screenshot and the one I’ve been testing on.

@noris -

As long as nobody else had the problem, I was going to let it ride. Now, that someone else has reported something similar, I suspect other people have this problem and for some reason just haven’t noticed it.

Later today, I am going to write up a complete description of when and where the problem occurs for me.
Right now, I have to throw some snow off the driveway.

If you’re referring to the tracks that show up in my post about my signal path, tht just happened to be what was displayed when I took the screen shot.

This happens at all resolutions above CD quality, but more about that later.

I can recreate the problem at will, if you want diags.

E.g. Queue up ‘Fortress’ on Queens of the Stone Age’s ‘Villians’ and follow it by ‘Spider Web’ on Joan Osbourne’s ‘Relish’. When ‘Spider Web’ starts the problem always manifests.

@noris -

I occurred to me that although I only have ‘Fortress’ streamed, I do have ‘Spider Web’ local. I tested a playlist with the local ‘Spider Web’ following a streamed ‘Fortress’ and had the same problem as when streaming both. FWIW

OK @noris, here are my tests and conclusions.

First, I said up above that problem occurred at all Qobuz streaming res. I confused this problem with the track ending abruptly problem. If I stream at CD quality, there is no late start of audio. Anything greater than CD quality causes the problem to occur. I corrected it in the above post.
image

After unplugging and replugging devices, I found that tthe presence or absence of any particular device has no effect. Unlike @Anita_Borst, I have no Bluesound devices. For a complete description of my Roon environment see this link -

For completeness sake, a list of what I unplugged/replugged -

  1. Mutec MC-3
  2. Replaced a new Pangea USB cable with the AQ cable I was previously using.
  3. Replaced my new RPi 4 with the old RPi 3.
  4. Replaced my iFi Pro DSD with an iFi DAC2
  5. Took my PrimaLuna pre-amp out of the chain (may the gods forbid that should be implicated)
  6. Replaced some new balanced star quad (Canare L-4E6S) cables, that run from my pre-amp to my monoblocks, with the old balanced (Belden 1800F) cables.

Nothing made a difference; the problem persisted.

This problem happens when -

  1. There is a mix of albums in the queue and play switches from a track on one album to a track on a different album.
  2. If ‘Play Now’ is selected from the album screen, then the first track of the album has the problem. Succeeding tracks start OK.

This problem doesn’t happen when -

  1. Roon Radio is choosing the next track.
  2. If ‘Queue’ is selected from the album screen and then play is initiated from the queue screen.

All of the above are true (with the exception of Roon Radio which is N/A) whether tracks are streamed or are local.

Some puzzlements -

  1. Why is streaming from Roon Radio seemingly immune?
  2. Why does the res (CD quality vs. higher res) of a track effect the next track when the next track is local?

I can’t state categorically that this began with V1.7, but since I noticed it immediately with the release of V1.7 it seems to be a cause.

Try streaming from Qobuz the two tracks I mention above. ‘Spider Web’ should start ‘I dreamed about’, but instead starts ‘dreamed about’.

Stay in touch. :slightly_smiling_face:’.

BTW - This may seem like a minor complaint, but you would be surprised how jarring the problem is.

Hi @Slim_Fishguttz,

Thank you for providing that additional information.

I tried this on my end, with all 3 versions of Relish on Qobuz and I am not able to reproduce on my end.

I wonder if perhaps a device in the chain is triggering this behavior, would it be possible to temporarily bypass the Mutec MC-3 as part of the chain?

I have taken out all devices one at a time, including the Mutec. Nothing makes difference in that regard.

Tomorrow, I will recheck everything I did up above, just to be on the safe side.

So far, the only thing that has made a difference is setting Qobuz to CD quality.

1 Like

Hello @Slim_Fishguttz,

I hooked up our iFi Pro iDSD to a Raspberry Pi 4 and tried replicating the behavior you are seeing and was unsuccessful in doing so. I tried the following:

A) Connected iFi Pro iDSD to Raspberry Pi 4 running Ropieee XL via USB.
B) On a ROCK core, I created a playlist containing:

  1. Fortress - Queens of the Stone Age (Qobuz 24/96)
  2. Spider Web - Joan Osborne (Qobuz 24/44.1)

C) Started playback of the QOTSA track to the iFi Pro iDSD zone.

In this scenario, I did not note any dropouts or “cut offs” in the audio. I recorded the playback session and uploaded a clip of the track transition here. In the recording, the “I dreamed about” lyric is fully audible.

I see you mentioned you pulled out the Mutec MC3+ from the signal chain, that would have been my first instinctual pick for the culprit here. The Mutec can sometimes drop the beginning of an audio stream when changing sample rates.

-John

@john -

Thanks for your test. I’ve been meaning to redo my experiments to make sure I can replicate the effects. I’ve been embroiled in other things, so I haven’t got around to the full set of tests.

In the mean time a couple of points -

  1. I’ve had the Mutec since this summer and only noticed the problem with V1.7 I noticed the problem on day one of my v1.7 install, so it isn’t anything subtle that I might have missed in V1.6. In fact, for another reason I haven’t had the Mutec in my chain since the above series of tests and the problem still persists.
  2. It only happens if Qobuz streaming is set to greater than CD quality.
  3. Last night I played an album (by itself) that has a res of 192k. The gap was longer than when playing album of 96k, e.g.
  4. As far as I remember during my tests, the effect occurred without a change in res, but I’ll reconfirm that.

As I’ve said, I can create this problem at will, if you want diags or logs.

What was the resolution to the @Anita_Borst problem? I feel it is related.

I’ll be in touch.

The album at 192k. -