1.6 Crashing On Windows 10


(Noris) #7

Hello @John_Gallup / @Eduardo_Cabral,

Can you please let me know the name of the computer that you’re experiencing this behavior on? You can find this information by right-clicking your start menu -> System -> Device Name

I’d like to enable diagnostics mode for that machine, so in addition to the device name, I kindly ask you to reproduce this issue once more and then note the exact local time in your country (ex. 2:37PM) that you notice this crash.

Once you provide the above info and diagnostics are in I will confirm the trace is present and create a case for you with QA.

Thanks,
Noris


(John Gallup) #10

Device name is “JohnsDell”

Just crashed at 12:29 PM PST


(John Gallup) #11

More device info:
image Screen image when crash occurs


(John Gallup) #12

The other Win 10 computer (DESKTOP-21H2LO2) that had been running Roon 106 successfully now will not; Roon starts but flashes to the red x and then closes. I’m left with only an Android phone to access my Roon library and am hoping for some support.


(Ged) #13

John is this two machines now showing this problem on the same network?
If that is the case and I was given this as a symptom when I worked in support I would be thinking malware.


(Eduardo Cabral) #14

@ged_hickman1 malware may not be the case… as far as my work, with @Danny and @Mike, on the issue goes there is a bug that, at the presence of some special characters (such as “]”, for example) in the name of the file selected to be played, makes the Windows new app crush.


(Ged) #15

The dreaded ] has been a culprit before. Good to hear that, it’s better than you having a viral attack.


(Peter Hanson) #16

I have the same issue on a Surface Book 2 running Win 10. It appears to be limited to when I try to play a radio station (Audiophile Baroque). Playing Tidal or my library seems to work fine. The stream I have is http://8.38.78.173:2199/tunein/baroque.pls


#17

It isn’t just ], of course.

I think Roon has a problem with special characters because Roon’s library is platform agnostic.

Unlike JShiver, which requires a differently formatted library for each flavor of OS.


(Dino Magaletto) #18

I have the same issue on my Win 7 and Win 10 machines. There seems to be an issue when I try to connect to a node that is a “Hi-Fi Berry” (Raspberry Pi) device. If you are trying to access one of these, disconnect it from the network and Roon fires up after that (still need this issue fixed though).


(Eduardo Cabral) #19

@Slim_Fishguttz… yep… it is not the only… it seems 1.6 has a bug triggered by a few special characters…

I transcribe a previous post of mine (from another thread) about a workaround in case somone steps on the same issue…

@ Danny @ Mike…
I think I found a work around.

I accessed the Core from other Controller (android phone) and started to play a song from my library, in order to avoid strange characters and untangle the situation… now Roon starts normally in the Windows PC

I shall keep you posted about this…


(John Gallup) #20

I do have a Raspberry Pi endpoint and disabled it; still have the problem.

Also tried accessing the Core from an Android cell, but often can’t run Roon on the Win 10 machines.

Not aware of any special characters in the files or streams I access.

Sure hope to see a solution to this soon. It’s no fun browsing albums on a cell phone.


(Noris) #21

Hello @John_Gallup,

You mentioned that this issue is happening for your Windows 10 machines, but the Core is working as expected now? If this issue is only occurring on your Roon Remotes you can try reinstalling the Roon app to see if that helps. I would also physically unplug and re-plug in your audio endpoints to see if that helps.

Thanks,
Noris


(John Gallup) #22

Noris,

Thanks. Roon Core is running fine on a Windows 10 machine. An Android phone and an endpoint machine running Windows Server 2012 r2 have also continued to work fine on 1.6.

I have powered off and reinstalled Roon on the Win 10 machines that have had the problem (neither is an end point).


#23

I just hit this on Windows 7 while playing “Magical Arif [Remix]” via Internet Radio. Same blank white screen with a red X, then crash.


(Eduardo Cabral) #24

That problem seems to be trigered by some special characters in the title of song being played.
The “[ ]” are among them.
Until the bug is fixed the work around would be to access Roon from an Android or Linux Controller and play some other song with no special characters in the title.
That should set the Windows app back to work.


(Noris) #25

Hello All,

We have just released Roon v1.6 build 401 which addresses this issue:

Roon 1.6 (Build 401) Is Live! Software Release Notes

Hi everyone! A new maintenance release is now rolling out for all platforms, with bug fixes, performance improvements, and updated designs for some of the UI changes in Roon 1.6. Today’s release includes a number of refinements for the footer and the Now Playing screen. We’ve heard a lot of great feedback on the changes in Roon 1.6, and we think the changes made over the last few weeks are big improvement. We hope you agree and we’re looking forward to hearing from everyone! We’ve added the m…

Please give the update a try and let me know how it goes!

Thanks,
Noris


(Eduardo Cabral) #26

@noris the new release seems to have fixed de “]” “[” issue… thank you…


(John Gallup) #27

Works for me.

What was crashing the software reliably for me was the site known as “Audiophile Classical” at the URL http://stream.psychomed.gr Seems okay now. Thanks for the support.


(system) closed #28

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.