1.6 Crashing On Windows 10

1.6 keeps crashing on PCs running Windows 10. I’ve reinstalled but still have the same problem: It starts, then displays a red x, then shuts down.

A generalization that isn’t generally true. Runs fine on my WIN10 i5 NUC and I assume on others.

Not trying to start a fight. Just saying it’s probably something in your particular system and that’s how it should be investigated.

Video drivers, perhaps? Dunno.

1 Like

I have no problems running Roon 1.6 on a Win 10 PC.
I suggest you contact support.

Hey @John_Gallup – can you give us some more details?

1 Like

Yes. 1.6 is running fine on another Win 10 machine. The one where it keeps crashing is a plain-vanilla Dell laptop which has worked fine until now. I just updated Windows and reinstalled Roon and the problem persists.

7 posts were split to a new topic: Red X Crashing on Windows 10

Hello @John_Gallup / @Eduardo_Cabral,

Can you please let me know the name of the computer that you’re experiencing this behavior on? You can find this information by right-clicking your start menu -> System -> Device Name

I’d like to enable diagnostics mode for that machine, so in addition to the device name, I kindly ask you to reproduce this issue once more and then note the exact local time in your country (ex. 2:37PM) that you notice this crash.

Once you provide the above info and diagnostics are in I will confirm the trace is present and create a case for you with QA.


1 Like

Device name is “JohnsDell”

Just crashed at 12:29 PM PST

More device info:
image Screen image when crash occurs

The other Win 10 computer (DESKTOP-21H2LO2) that had been running Roon 106 successfully now will not; Roon starts but flashes to the red x and then closes. I’m left with only an Android phone to access my Roon library and am hoping for some support.

John is this two machines now showing this problem on the same network?
If that is the case and I was given this as a symptom when I worked in support I would be thinking malware.

@ged_hickman1 malware may not be the case… as far as my work, with @Danny and @Mike, on the issue goes there is a bug that, at the presence of some special characters (such as “]”, for example) in the name of the file selected to be played, makes the Windows new app crush.

1 Like

The dreaded ] has been a culprit before. Good to hear that, it’s better than you having a viral attack.

1 Like

I have the same issue on a Surface Book 2 running Win 10. It appears to be limited to when I try to play a radio station (Audiophile Baroque). Playing Tidal or my library seems to work fine. The stream I have is

It isn’t just ], of course.

I think Roon has a problem with special characters because Roon’s library is platform agnostic.

Unlike JShiver, which requires a differently formatted library for each flavor of OS.

I have the same issue on my Win 7 and Win 10 machines. There seems to be an issue when I try to connect to a node that is a “Hi-Fi Berry” (Raspberry Pi) device. If you are trying to access one of these, disconnect it from the network and Roon fires up after that (still need this issue fixed though).

@xxx… yep… it is not the only… it seems 1.6 has a bug triggered by a few special characters…

I transcribe a previous post of mine (from another thread) about a workaround in case somone steps on the same issue…

@ Danny @ Mike…
I think I found a work around.

I accessed the Core from other Controller (android phone) and started to play a song from my library, in order to avoid strange characters and untangle the situation… now Roon starts normally in the Windows PC

I shall keep you posted about this…

I do have a Raspberry Pi endpoint and disabled it; still have the problem.

Also tried accessing the Core from an Android cell, but often can’t run Roon on the Win 10 machines.

Not aware of any special characters in the files or streams I access.

Sure hope to see a solution to this soon. It’s no fun browsing albums on a cell phone.

Hello @John_Gallup,

You mentioned that this issue is happening for your Windows 10 machines, but the Core is working as expected now? If this issue is only occurring on your Roon Remotes you can try reinstalling the Roon app to see if that helps. I would also physically unplug and re-plug in your audio endpoints to see if that helps.



Thanks. Roon Core is running fine on a Windows 10 machine. An Android phone and an endpoint machine running Windows Server 2012 r2 have also continued to work fine on 1.6.

I have powered off and reinstalled Roon on the Win 10 machines that have had the problem (neither is an end point).