Accessing iTunes folder on Windows PC from a Nucleus+ server

I’ve recently installed a new Nucleus+, migrating my roon core from my laptop to the Nucleus server.

While I use Tidal and files on connected SSD, I also have lots of content on iTunes after years of use of iTunes. Those music files are stored by Apple iTunes’ application in the Music folder on the local Windows laptop where iTunes is installed and where I used to have my core until yesterday and point it easily as an additional folder in storage settings.

But now, with the roon core migrated to a Nucleus (which is remotely located and accessible through ethernet on local network), I can’t point the roon core to that iTunes folder on the laptop where iTunes is installed and running, and so I lost access to that music.

I have created network sharing permission on my laptop for the Music folder (with “everyone”), but in trying to add the folder “\[My computer name]\Music” to in roon settings’s storage, it fails to connect.

What is the best work around for that? iTunes will continue to store its content locally on that windows machine where it’s installed. I’d hate to think that upgrading to a separate core means that I will have to lose access to some of my music that I could access with a more basic roon setup.

thanks for any advice for a newbie…

Thanks @wizardofoz I’ve tried that before and it doesn’t work. So the path I got after sharing is \xps\Music (XPS being my computer name, and Music is the windows folder where I defaulted the iTunes folder as usual).

When I put “\XPS\Music” in the Roon add folder network location, the Nucleus core isn’t able to find it.

Is SMB enabled on the Windows PC? It is not by default.

I humbly admit I don’t know how to check that @tripleCrotchet ?

It is typical you will need a user name and password too

@wizardofoz I haven’t set user/password requirement in sharing I set is as accessible to everyone on network without credentials? so not sure what user/password I should use

“everyone” in Windows parlance means all the users (with their passwords) that you have defined in Windows on that particular PC. It doesn’t mean everyone in the known universe outside of the Windows PC…

“Everyone” is not the same as “anyone”

Thanks @Geoff_Coupe

I still don’t know how to make this folder on my windows PC available for the Nucleus to access though - so now the problem is clear, what is the way to solve this?

thanks so much

Try one of these methods…

In the magnifying glass left hand bottom type “control panel”.

In control panel:

Programs and Features -> Turn Windows features on or off -> Make sure SMB is “ticked”

1 Like

Everyone in Windows sharing is a group so any user that is the everyone group. normally just use your local windows user name and password…or as Geoff suggested setup a user specifically and I would suggest only read only access unless you trust yourself explicitly to not delete anything :wink:

@wizardofoz @tripleCrotchet @Geoff_Coupe – thank you all for your great replies, deeply appreciated.

I have

  • Enabled SMB
  • Shared folder with “everyone”
  • Tried using network address \[computer][folder] and smb://[computer]/[folder]
  • Tried with and without credentials
  • Used both my local user name and Microsoft email user name + Microsoft account password

I still can’t connect…

what am I missing or doing wrong?

If you are trying to connect using your local user name (and password) to the shared folder, then I would explicitly add these user credentials with read/write permissions to the shared folder in Windows.

In Roon, since you are trying to connect to a Windows device, use the form \\ComputerName\SharedFolderName as the Network address.

1 Like

@Geoff_Coupe thank you

I have indeed been trying to use this path \ComputerName\SharedFolderName

As far as local user name I tried both with and without, and with and without my Microsoft account password.

Is there a way you are suggest I should create specific credentials for this folder sharing? I don’t see anywhere to do that. Or pls lmk if there is something I am doing otherwise incorrectly?

thanks for your patience…

just confirming your windows firewall is off.

1 Like

@wizardofoz - the windows firewall was on, and I took it off

the result is:

(1) Performance - issues solved! everything now seems instantaneous. I’ll keep monitoring and hope this holds, I’ll report if not. so, thanks!! but… running a computer with firewall off is bad practice and dangerous long run. Surely there should be a better way to handle that issue that is sustainable? I can’t imagine all roon subscribers with nucleus having a spec requirement of running without a firewall as the recommended configuration?

(2) iTune issues isn’t solved - actually, before the roon process was “thinking” so I had to wait 5-10 seconds for a rejection reply. Now it’s instant error message. I did also change the DNS setting as recommended in the other thread so I have both my router DNS (as primary) and Google’s DNS 8.8.8.8 (as secondary) set up. But it’s obvious the connection isn’t made now. Same network path as before

What do I next?

You could copy the iTunes library to the nucleus too just a thought?

If you look in knowledge base you should be able to find info on enabling roon and raat in the firewall

I might have to do that - but that won’t let me continue to see iTunes seamlessly to add things and sync it with Roon, which I did have when I had my core on the same computer – it seems ironic to invest in a new Nucleus device and end up with inferior functionality

Must be something in the network settings to the windows share that you still have out of whack. Many of us here use a share on windows from a roon server (nucleus/rock)