Adding Music To Library - Wheel Keeps Spinning (0 Identified)

Hi @support, Roon sees I have added music to my library, but seems to get stuck on the first file: it has been identifying the first of many tracks for weeks now (still zero files identified). It also seems to significantly slow down the entire Roon performance. What to do?

Hello @Grump, could you please send me a screenshot of where the scan is stuck?

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Hi @nuwriy, my setup is as follows:

Roon Core: Roon Server on Mac mini 2012, 2.3 GHz Quad-Core Intel Core i7, 16GB RAM, 500GB SSD
Roon Remote: iPad Pro 11” (2018)
Network: ethernet, all wired
Audio Devices: Meridian MS200 > Meridian DSP5200.2
Library on four WD My Book external HDD’s, connected to the Mac mini

Here’s a screenshot:

Hello @Grump,

I’d like to enable some diagnostics on your account so we can take a look at what you’re experiencing here. Before I do this, may I ask that you please do the following and make a note of the time you do each:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

Hi @nuwriy, a question just to be sure I provide the correct information: in step 2 and 4, do you mean the time I start up Roon Remote on my iPad? Or Roon Server on the Mac (which starts up automatically when the Mac has started up)?

Hello @Grump, since you’re just using the iPad as a remote timestamps from there will work fine.

Hi @nuwriy. I followed your steps, resulting in the following:

  1. Reboot your Core machine >>> Wednesday 7 October, 17.57hr (5.57 PM) CEST, UTC/GMT +2 hours, I rebooted my Mac mini Core machine.

  2. Start up Roon and let the spinner go for ~5 minutes >>> 18.16hr (6.16 PM), I started the iPad Remote app. (It takes that long for Roon to start up. Note: I tried starting it up on my iPad Remote multiple times, to no avail. Maybe the diagnostics show this.) When I switched to the Notes app to make notes and switched back to Roon, all it showed was a “Disconnected” message. I restarted the iPad Remote app at 18.18hr (6.18 PM). This time, I didn’t leave the app and let the spinner go for about five minutes.

  3. Reboot your Core machine once more >>> 18.25hr (6.25 PM), I rebooted my Core machine once more.

  4. Start up Roon and let the spinner go for another ~5 minutes >>> 18.38hr (6.38 PM), I started the iPad Remote app and let it spin for ~5 minutes.

  5. At 18.44 (6.44 PM), I rebooted my Core machine once more, because of my mistake to switch between apps on the iPad the first time. It kept on hanging, so I rebooted again at 19.32 (7.32 PM). Since then, it seems to be stuck. I hear the Mac and the external HDD’s processing. They still are now (23.51hr / 11.51 PM).

@support: Thursday, 12.18 PM. For the first time since yesterday, Roon goes beyond the startup screen and shows the Album view in the iPad Remote app. I let it spin for ~5 minutes and close the iPad app at 12.24 PM. The spinning wheel still shows 0 of the 4461 tracks identified.

Thanks for the update @Grump, I’ve enabled diagnostics for your account and will send a report over to our QA team. Could you please send me another screenshot of the scan so I can add it to the report?

Hi @nuwriy, Of course. Here’s the screenshot:

To be complete: since this (the past few months), Roon has become notoriously unreliable and mostly often refuses to play at all. Much to my own surprise, it does play now. But chances are, when I skip a song or switch to another album, it just stops playing and doesn’t start anything else, no matter what format it is in.

Over the past few months, it got so bad I just stopped using Roon (for the first time) and used Spotify. But this sounds so terribly bad, it sucked all the life out of the music and the pleasure out of me. And the few instances Roon does play, I immediately enjoy the difference in sound. Hope we can determinate the cause of the issue and ideally solve it!

Hi @support, any news from the diagnostics?

Hello @Grump, I just checked in on that too. It looks like your core was having issues reaching our servers but I just requested logs again and they came in so I’ve attached them to the report with our team. I’ll be back as soon as I hear from them.

Hi @nuwriy, I think it’s unlikely to be the only problem, because I don’t stream. I only play local files, and since a few weeks am hardly able to play any. Metadata-related issues therefore cannot the only problem, I suspect. Curious to find out more from your reports!

By the way, I too sometimes get the notification “Metadata Improver: Halted. Roon needs a software update.” Don’t know why and what this means, but perhaps useful to take into account.

Hello @Grump, if you reboot does metadata improver go away? Also, do you have VOIP installed anywhere on your network?

Hi @nuwriy, the metadata improver notification did go away indeed. And I don’t have any VOIP installed, nor do I have PoE or anything like it. Plus my Core is wired over ethernet, no wifi besides the iPad Remote.

Hi @nuwriy, any news from the diagnostics?

Meanwhile, I think there has been a maintenance update from Roon. What I notice for a while now, is that my Remotes and Bridges are easily updated to the last version, but my Core often reports “There was an error checking for an update”. A few minutes ago, the Core also reported “updated to the last version” in one instance, but now, it just keeps reporting the “error checking for an update” again.

Is this in any way relevant to my problems? And is it related to the notification “Metadata Improver: Halted. Roon needs a software update”?

Hello @Grump, while we are still investigating the metadata improver issue, both of those items could definitely be related to issues connecting to our servers. Have you tried disabling your firewall?

Hi @nuwriy, I have my firewall disabled by default.