After latest update - music file is loading slowly [Resolved - Flow Control Enabled On Managed Switch]

After the latest Roon update today all my files (Tidal and local music files) will only play 2 seconds then Roon shows the message “a music file is loading slowly”. Then Roon skips to the next track which also only plays 2 seconds and so on. Everything worked fine before the update. Roon is indicating a network problem - but the network itself works without problems.

My chain is Silent PC with Win 10 + AO and Roon in Shell mode, “bridged” > Aqvox switch > MicroRendu >Iso Regen > Chord Dave.

Can there be a conflict after the update with “bridged mode” see CA, AO or something else?


There has been two updates in short succession this week … can you confirm what version of Roon is now running and what was the previous version?

I run automatic update with Roon. When starting Roon today it installed 2 updates in short order (now build 234). I think the problems started already after the first update. I run the latest 2.3 version on MicroRendu.

Hi @yellowblue ----- Thank you for the report and sharing your observations with us after the update. The insight is very appreciated!

Moving forward, may I kindly ask you to confirm where you musical collection is being stored/how it is being accessed. Furthermore, I’d be curious to see how things behave with the bridged networking disengaged. Perhaps during your troubleshooting you’ve tried this? If so, what was the result?


All music files - via Tidal, stored on the hard disc and on a SD-card on my SD-card reader behave in the same way. I will try and disengage the bridged mode when I get the time. Wanted to hear first if there can be other reasons for those problems.

1 Like

I did a clean install of Roon. And everything works fine again. But when I then updated to the latest Roon 234 build the problems occured again. I currently run the 2.3 version for MicroRendu. I ordered the new 2.5 software for the MicroRendu on SD card. Will see if that works with Roon 234 build. Until that I will run the older Roon build.
Is there someone else here with Roon and MicroRendu who experienced the same problems?

Am having similar problems since the last update, between Rock and my Android tablet (using tablet output).

Very annoying!

I have two systems. My Schiit Yggy via RedNet AOIP is working flawlessly. I also have an Ifi IDSD Black Label used with MicroRendu (f/w 2.5) and am getting “music file loading slowly” and “network issue” messages like many others. These messages only have occured with latest 234 build. Prior releases no issues.

My Roon core has not worked since updating to Build 234. Every time I try to play something it fails in the first ten seconds and complains that a file is opening very slowly. There’s nothing wrong with my file server or network as I can play music through JRiver from the same source without any problems. Is anyone else experiencing any issues?

Hi have you tried rebooting the machine that the Roon Core is running on?

If that does not work, can you give a brief but detailed description, see RKB Reporting an Issue of your Roon setup.

I’ve managed to narrow down the problem a little bit. My system is set up as follows:

I have a Synology DS1511 NAS that stores all my music. I run Roon on a Windows 10 PC and everything in my setup is connected by Ethernet cable to a switch which is connected to my router.

I have two devices in my network; a MicroRendu running on my main system and an Auralic Aries connected to an Ayre Codex DAC/Headphone amp. The main system with the MicroRendu is working fine but the Aries/Codex system stopped working a few days ago. I’ve tried to do a little bit of troubleshooting to refine the issue.

First I tried using a different DAC connected to the Aries. Same problem. Then I connected my Codex to a PC running JRiver and it worked fine. The problem is not with the Codex.

I also tried connecting my Codex directly to the PC running the Roon core with a USB cable but I haven’t been able to get this to work. I’ve never tried to use Roon this way before. Can you explain how to setup Roon with a DAC connected directly to the core? If I can get this to work I think I can eliminate Roon as the source of the problem.

I suspect the problem is related to the Aries but I powered everything down and ran the Aries setup routine again. It should be working but the problem persists.

You can see in this thread that more people are reporting the same problem. I solved the problem by doing a fresh install of Roon - and not updating to the latest 234 build (the problem came back after updating). With other words the problems must be related to the 234 build. I am waiting with the update until Roon has fixed the problem.

That’s interesting. I’m getting exactly the same behaviour as you but here’s the strange thing. As I mentioned in my previous post, I run two devices. A MicroRendu on my main system and an Auralic Aries connected to an Ayre Codex. The Aries/Codex combination is the one I’ve been having problems with but my MicroRendu on my main system is working fine. One difference between our MicroRendus is that I updated to the new 2.5 firmware last week.

Other than that I went through more or less the same actions as you did. Uninstalled Roon, downloaded and reinstalled. Even rebuilt the database rather than restore a backup. The problems persist.

Hi @yellowblue ---- Thank you for updating the thread with your work around, the feedback is appreciated and always welcomed.

By chance did you have a chance to test with bridge mode disengaged, prior to the reinstall? I am curious what the outcome was, if you had.


@anon49565150 / @scott_mathews / @Stephen_Graham – Thank you all for your feedback and my sincere apologies for the troubles here.

If you haven’t provided the details of your setup already, may I very kindly ask you to please do so and furthermore, can you verify if you making use of the MicroRendu running in bridge mode?


I did but it was on a different thread so I’ll repeat it here. I run Roon core on a Windows 10 PC and my music is stored on a Synology DS1511 NAS. I have two Roon endpoint devices. Everything is connected by Ethernet to a switch which is connected to my router. On my main system I’m using a MicroRendu (just updated last week to the new 2.5 firmware). The MR is working fine. My second endpoint is an Auralic Aries which feeds an Ayre Codex DAC/Headphone amp. This is the one I’m having problems with since the Build 234 update.

Router/Switch > Windows 10 PC as Roon Core in bridged mode > Aqvox switch > MicroRendu with 2.3 software > Iso Regen > Chord Dave. Only problems with 234 build

Hey @yellowblue – we can take a look at this, but my understanding is that the microRendu does not support bridged mode on Windows. As far as I know, running with a network set up this way isn’t something we test (or recommend) as part of our internal QA process.

It’s possible something isn’t working as expected here, which is why I’m going to discuss further with our QA team, but we should determine whether the issue is in fact that bridged mode isn’t working properly with the microRendu.

Have you you tried connecting the microRendu directly to the router switch? I think that’s probably the next step for troubleshooting this particular configuration.

The microRendu worked without problems in bridged mode on Windows until upgrading to 234 build. All those other users reporting the same problems - do they all use their units in bridged mode? I want to wait with the next step in troubleshooting until this point is clear.

Hi @Stephen_Graham ---- Thank you for following up with me and providing the requested feedback.

Just so I understand, ONLY when you are playing back to Aries + CodeX end point you are receiving this “music file is loading slowly” message in Roon, correct?

If you haven’t already, I would consider trying the following:

  1. Great first step here:

“I also tried connecting my Codex directly to the PC running the Roon core with a USB cable but I haven’t been able to get this to work. I’ve never tried to use Roon this way before. Can you explain how to setup Roon with a DAC connected directly to the core?”

If you are running headless, you should try setting up the Codex device from a Roon remote. You will want to navigate to the “audio” tab and then under the “connected to core” field you should see the device listed. If you are not running headless, the same procedure should work from the core machine, the only difference is that the information should be found under the “connected to this XXX” field.

  1. Can you try (temporarily of course) bypassing the switch and connecting the Aries directly to the router?

  2. Do you make the same observation (file loading slowly) when accessing locally stored content as opposed to media being pulled off the NAS?