After latest update - music file is loading slowly [Resolved - Flow Control Enabled On Managed Switch]

Just so I understand, ONLY when you are playing back to Aries + CodeX end point you are receiving this “music file is loading slowly” message in Roon, correct?

That’s correct.

If you haven’t already, I would consider trying the following:

1) Great first step here:

_ “I also tried connecting my Codex directly to the PC running the Roon core with a USB cable but I haven’t been able to get this to work. I’ve never tried to use Roon this way before. Can you explain how to setup Roon with a DAC connected directly to the core?”_

If you are running headless, you should try setting up the Codex device from a Roon remote. You will want to navigate to the “audio” tab and then under the “connected to core” field you should see the device listed. If you are not running headless, the same procedure should work from the core machine, the only difference is that the information should be found under the “connected to this XXX” field.

I did get this working. The issue was a driver that was required on the Roon Core PC for the Codex. Once I got that installed properly I could play using the USB cable direct from the Roon core PC without any issues.

  1. Can you try (temporarily of course) bypassing the switch and connecting the Aries directly to the router?

  2. Do you make the same observation (file loading slowly) when accessing locally stored content as opposed to media being pulled off the NAS?

Now I’m really confused. When I connect the Aries directly to the router it works properly. That makes absolutely no sense. The MicroRendu is connected to the same switch and works fine. I’ve also run diagnostics on the switch, tried a different port and even rebooted the switch. There’s nothing wrong with it but when I connect the Aries back to the switch it doesn’t work.

Hi @Stephen_Graham ---- Thank you for giving the proposed test a shot and sharing the observations you made during your testing.

Can you verify the make/model of the switch you are implementing in your setup?


It’s a D-Link DGS-1210-20. I checked yesterday and it has the latest firmware installed.

I got a suggestion at CA:
Like several others, I tried the suggested workaround of adding a wi-fi adapter to the bridge. This adapter needs to be “enabled” in Windows, but not connected to the network in any way. just its presence seems to fix some issue with Windows.

I myself have not the time to try this just now. But maybe some other will try this?

Hi @Stephen_Graham ---- Thank you for the follow up and verifying that information for me.

If I am not mistaken the D-Link DGS-1210-20 is a managed switch and we have seen a few issues crop up with these devices in the past ( Example: #1, #2, #3). I would recommend enabling flow control on the switch, as we have seen it help other users in the past.


I’ll try it but I don’t believe the switch is the problem. I’ve had this switch for all of time that I’ve used Roon and until last week I’ve never had a problem.

Maybe so, but it may not be coincidence that the latest build of Roon is now using TCP instead of UDP over the network. This change to the network protocol used in RAAT may have caused an issue with your switch.

I seem to have solved it for me (keeping fingers crossed that it holds)

After 234 update I too had the ‘slow file loading’ issue. uRendu was visible to Roon, but it did not play music, it starts plays for 1-2 seconds then skips to next track. I disabled all DSP and there is no upsampling. CPU load remains below 5%. I disabled the firewall and it made no difference. If I remove the Bridge, everything is back to normal and it plays fine. The error looked similar to the one below. I use windows 10 running core and my setup is a shown below.


My setup:

With some help from Roon team and also some search on CA forum, I had to do a couple of things:

  1. Add the wireless adapter of my laptop to the bridge (though it is not connected to the network)
  2. Manually set the MAC address of the Microsoft bridge adapter. I had to do this as I realized, the MAC address for the bridge kept changing after restarts and it was hard for me to make my router assign a static IP.

Once I set the MAC address, I dial it into my Router’s DHCP settings and force it to assign the IP I had entered in my network properties.

I had the same problem with two different laptops and on both everything worked fine if I rolled back to previous version of Roon core. As counterintutive as it is, based on the things I tried, I still feel the underlying reason is likely how Windows implements bridging rather than anything to do with Roon.

My network setting:

Changing the MAC address:
Make sure it is different from other stuff on your LAN.

I am no networking Guru, I just use Google Foo.

1 Like

Fair enough. I didn’t realize there was a change in protocol in this build. Anyway, I made the change on the switch to enable flow control and you were absolutely right. It works now. Thanks very much for your suggestion and all the help along the way.