.AIFF/OSX Bug - Roon fails to recognize certain .aiff files

Here is how to reproduce this bug.

  1. Insert a CD into your Computer (OS X 10.10.x), the OS/iTunes may
    grab the track titles and album names upon insertion. For the
    purposes of this, no issues if the album is listed as Audio CD.
  2. Drag and drop .aiff files from the CD to your desktop.
  3. After the files are copied, move the .aiff files you just copied to the Roon watched or Roon
    Watched and Organized folder.

Do the album/tracks appear?

( iTunes or other ripping software do not appear to replicate this issue, but I would like to know what is causing this bug this way. Further, what other problems could be related to this.)

Admin note: I uploaded an album to the Roon dev server. @kevin @mike @danny

Ref: AIFF files not showing up in Roon


I download the trial software about 1 week ago. I have the same issue. The software will only detect the very very few MP3 files that I have. ROON refused to detect all my .AIFF files. I have 1 TB of music on one drive and of that, ROON detects roughly 849 artists/songs. I do not know what I can do to make the software work and it is impractical to manually file by file to change the file name extensions or convert the files.


Hey guys, thanks for letting us know about this issue. We’ve heard about this from a few users, and we have an idea of what’s preventing these files from being imported. A few users (including @o0OBillO0o) have provided media, we’re able to reproduce the issue, and it’s logged in our bug tracker.

We’re hoping the issue will be closed really soon, but I don’t have a firm timeline yet. When the issue is fixed, I will mention it in the release notes, so hang tight and look for a fix soon.

@Golucid – if the vast majority of your collection is not importing right now, can you send me a PM? I want to make sure you actually get the full 14 days to try out the app once we’ve resolved this issue.

Sorry again for the trouble here guys. We’re on it.

1 Like

Hi Mike, how do I send you a PM? And yes. At least 90+ % is all AIFF file format… if not 95%.

David - looks like @mike is giving some outstanding support!

I also have most of my library in .AIFF format - why change the media from it’s delivery format? It’s dead simple and super flexible. Terabytes are inexpensive. Further, I’ve gotten suckered into buying some HDTracks, 24bit .AIFF files, to see if I can really hear the difference. Plus I am fanatic for Pearl Jam’s Music.

So far, the Pearl Jam .AIFF files from HDTracks appear to work in Roon - I am just not sure if the are any better sounding than the CD - LOL!

I’ll keep my eye out for the release notes and most likely post back here when I think all the .AIFF files are working.

Thanks Team Roon!


Mike, I have tried to PM you by clicking on your profile. Perhaps PM is not an option given my basic user access.

Seen this?

you know what is more frustrating?
that is some tracks are detected while some are not in an album.
Anyway, I am faced with the same issue. Reported 1 month ago. I just hope this could be solved soon…

I wonder if it’s the Big Endian vs Little Endian types of AIFF files (see wiki article), where Roon needs to tweak how it reacts to all types of AIFF files. I think by default Windows does one and OS X does the other, it’s just something to be aware of.

@B_Sherhee_Tsang, that is not good. We have three options wait for a product update; batch convert files to the "Roon recognizable .AIFF/lossless format, which will be a risk and a time consuming process; or not use Roon at all.

Hopefully we are patient enough to hold out for the few months it will take to get the bug “ticket” through their process.

It’s now November and I’m still having this same issue as everyone else on this thread. Anyone figure out a way around it that doesn’t involve re-ripping everything into WAV or some other format? I did a brief search for a bug tracker but was sadly unable to locate one (to see what bugs are open/closed/being worked on/etc.)…does this exist in a format available to the public?

@mike…any updates?

Hey @myjonboy – we track bugs on an internal system, but I just took a look and I think the AIFF issues we’re aware of were closed out a little while back.

If you have AIFF files that are failing to import or play back, we’d love to have a look. Can you upload one or two affected files to Dropbox (or similar) and PM me a link, along with the Setup info described here?

If you don’t have anywhere to upload them, just PM me and I can give you some instructions for uploading them directly to our server. Sorry for the trouble here!

Thanks for sending over some media @myjonboy – I can reproduce the issue and I’m going to open a bug report to get this looked at.


Good work all.

3 posts were split to a new topic: Trouble with import of AIFF files