Albums appearing in library although folder and files do not exist [Solved]

Hello @Vassilis_Papaeconomo,

Thank you for contacting support, the feedback is appreciated! I also want to give a quick thank you to the other users who commented on your post giving suggestions about cleaning up the Library as that would have been my initial suggestion as well.

I would like to see if we can trigger a change in behavior here by asking you to please “disable” (not “remove”) the watched folder that had previously contained the media temporarily. After it has been “disabled”, please relaunch the application, re-enable, and try deleting the mentioned “ghost tracks”.

Looking forward to hearing your observations!
-Noris

@noris many thanks for your input. I tried out what you told me and actually things got worse: Roon created a duplicate of the albums that have this problem. So I now have 8 albums with exactly the same problem instead of 4. 4 of them are duplicates.

Getting frustrated…

Did you “remove” the folder?

No, I disabled it, following the instructions from noris

Hello @Vassilis_Papaeconomo,

Thank you for the follow up and sharing the observations made after having tried the suggestion in my previous post. Sorry to hear of the continued troubles.

I would like to enable diagnostics on your account so our technical staff can get some more insight into what’s going on here. What this action will do is the next time the application is active on your core device a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers. I will be sure to update this thread once the report has been received so you know we have it.

In the meantime, may I ask you to please provide me with the following:

  • Please provide the name of the albums that are exhibiting this behavior?

  • Please provide a screenshot of the “file info” window for a single track in one the mentioned “ghost albums” above. You can obtain this information by navigating to the album in Roon -> clicking the 3-dot menu to the right of the track > selecting “file info”. It should look something like this:

Thanks,
Noris

@noris, thanks a lot! Appreciate your great support on this.
To answer your questions:

  1. The albums identified (so far) with this issue:
  • Vulture Culture from Alan Parsons
  • Flying Colours from Chris de Burgh
  • Lucille from BB King
  • The Opera Album - Aria from Andrea Bocelli
    Please bear in mind these albums appear twice in my library
  1. Unfortunately file info gives me the following error: No Info - Track not in your library

Regarding the diagnostics:
Do I need to shut down the Roon Core server? I actually never shut down normally this machine, so please let me know in case I do need to reboot it.

Thanks
Vassilis

@noris , just a short update: I restarted the machine and guess what: duplicate albums diasappeared, and I can view the file info of individual track in these albums. I did absolutely nothing apart from rebooting. I can even listed to some tracks (not tested all of them)!

I will not do anything (apart from listen to music) until you collect the information you need and tell me all is OK.

Vassilis

Hi @Vassilis_Papaeconomo,

Thank you for the continued feedback! I am pleased to hear that the duplicates are no longer present after the core had been rebooted.

Continuing forward, I can confirm that the mentioned diagnostics report has been received and is in our tech team’s queue for evaluation. Once the team has updated your ticket I will be sure to share their thoughts/findings with you in a timely manner. Your patience during this process is very appreciated!

Thanks,
Noris

@noris just to update you: Unfortunately it seems that the problem persists. I discovered at least one additional alub with the same issue and also the four albums I listed in my previous message still do have some tracks that are non-existent in my folder and cannot delete them, becaure ROon gives me the error that the file does not exist.

Hi @Vassilis_Papaeconomo ----- Thank you again for your continued feedback and more importantly, thank you for your patience here. Both have been very appreciated!

I wanted to follow up with you because I just checked in on the status of your ticket and the our tech team has asked if you would kindly please provide a brief but accurate description of your current setup using this link as a guide. The team wants to have a better sense as what gear you are working with.

Many thanks!
-Eric

@eric thank you for getting back to me. Here below some more details about my setup:

  • Currently running Roon Version 1.5 (build 32), 64bit
  • Roon is running on QNAP TS251PLUS NAS with 8GB RAM
  • I control Roon from my PC, iPhone and iPad
  • Music folder is on a shared drive on another NAS (QNAP TS-459).
  • There are two main subfolders in this music folder in which the music is stored
  • In one subfolder is the music as exported from Sooloos
  • The other subfolder has the structure <Artist name - Album name> ->
  • Local network is through a Cisco switch
  • Network is wired
  • Media format is mostly FLAC and some MP3

Hope this is the information you needed. Let me know if you need any further details.

Thanks!

Vassilis

  • Approximate number of tracks (according to Roon) is 70.000

@eric another hint that may help: I have the impression that issues with tracks relate for some reason with my Sooloos export folder (one of the two subfolder mentioned in the previous post). Just tried to delete another album from this subfolder, and I got the same problem (tracks in Roon that apparently do not exist in the folder).

@eric some additional observation that this will help to troubleshoot: I have discovered that roon get confused when I try to edit multiple tracks. When I edit or delete them one by one there is no problem. But when I try to delete multiple tracks (eg when deleting an album) the system gets really confused: some are deleted and the other become non-accessible. In these one I cannot view the file info.

After restarting the Roon server everything works again and I can delete the tracks one by one that I could not bulk delete previously.

Hope that give some indication of what could be wrong.

Hello again @Vassilis_Papaeconomo,

Thanks for your patience here while our team reviews your logs. Our team noticed that the QNAP TS251PLUS NAS you’re using for your Roon Core falls short of our recommended specs.

Because this device uses an Intel® Celeron® 2.41GHz you may experience performance issues, particularly with larger libraries or DSP, or if you don’t use an SSD for your Roon database.
Can I kindly ask you to verify how your system performs when the Roon Core is hosted on another computer that meets our required processing power and we can continue from there?

Thanks,
Noris

@noris thanks for getting back to me. I have equiped my NAS with SSD drives and the CPU usually works at 10% and maximum 50% if other applications are running.

Nonehteless I have switched now to a ROCK I have setup up before I migrated to the QNAP NAS. I will watch it closely and let you know if I experience any similar issues. From a first glance though I can tell you that I do not see any similar issues as before. I will need about a week to be sure.

This is very strange and my best guess (if everything gets back to normal again) that the issue has something to do with the QNAP app, I cannot see any performance contraints on the QNAP.

Thanks so much for your continued support. I hope this will help other users, as I have seen some of them are actually using the same NAS (read some posts before purchasing it).

Vassilis

Hello @Vassilis_Papaeconomo,

Have you been able to verify what your experience is like with the ROCK setup? Is everything working properly now? Please let me know when possible.

Thanks,
Noris

@noris, everything is working as expected since I switched to ROCK. I have found though something that was possibly causing the issue: The music folders are stored on a shared folder on a QNAP NAS. I realized that when Roon was deleting tracks they were moved to the Network Recycle Bin on the this folder. I discovered that Roon was scanning for some reason the Recycle Bin as well, so when tracks were deleted, they were later on again imported automatically into Roon and it seems that this was causing a lot of confusion.

Been testing ROCK with the Recycle Bin disabled now and everything is working fine. Need to do a final test and switch back to the QNAP instance of Roon with the Recyle Bin disabled and see what behaviour I am getting there. It could be just that or a combination of things. I will get back to you in a few days and will let you know what the outcome is. I think it would be helpful for other users in the community.

Vassilis

@noris an update: I switched to Roon on QNAP and tested extensively. Everything seemed to be working fine until I had to delete a complete album and then I saw the same issue I reported before. I immediately took a back and switched to ROCK and I could delete the same album without any problem.

It seems that Roon on QNAP has some issue when deleting more than one tracks at a time. I wil will keep ROCK for now to be on the safe side. Hope this will help other community members.

Thanks so much for your support!

Hello @Vassilis_Papaeconomo,

Thanks for your reply and testing, I’m glad that you have been able to get this issue sorted out by using ROCK instead of the QNAP. As I previously mentioned, this could be a performance issue regarding the NAS since it is under our minimum required specs. Although it may work just fine if the library has a small amount of tracks or if you are performing simple functions, the performance issues can become more visible as the library grows into a larger size or you attempt to perform multiple operations on several files at a time (such as deleting entire albums). I am marking this thread as [Solved] and hope that your ROCK setup is still running properly but if you run into any issues, please feel free to start a new thread and let us know.

Thanks,
Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.