Albums missing that are on disk

I’ve got a weird case where some albums that are definitely present on disk are not showing up in the Roon interface. Specifically, I’ve got a number of U2 albums that I noticed were not there - Deluxe editions that replaced older versions (that are still there).

For example, here’s the on-disk structure for Boy:

[iMac:iTunes Music Folder/Music/U2] dnanian% ls Boy*
01 I Will Follow.mp3 06 The Ocean.mp3
02 Twilight.mp3 07 A Day Without Me.mp3
03 An Cat Dubh_Into The Heart.mp3 08 Another Time, Another Place.mp3
04 Out Of Control.mp3 09 The Electric Co…mp3
05 Stories For Boys.mp3 10 Shadows And Tall Trees.mp3

Boy_ Deluxe Edition [Disc 1]:
1-01 I Will Follow.m4a 1-07 The Ocean.m4a
1-02 Twilight.m4a 1-08 A Day Without Me.m4a
1-03 An Cat Dubh.m4a 1-09 Another Time, Another Place.m4a
1-04 Into The Heart.m4a 1-10 The Electric Co…m4a
1-05 Out Of Control.m4a 1-11 Shadows And Tall Trees.m4a
1-06 Stories For Boys.m4a 1-12 [Untitled].m4a

Boy_ Deluxe Edition [Disc 2]:
2-01 I Will Follow [Previously Unreleased Mix].m4a
2-02 11 O’Clock Tick Tock.m4a
2-03 Touch.m4a
2-04 Speed Of Life.m4a
2-05 Saturday Night.m4a
2-06 Things To Make And Do.m4a
2-07 Out Of Control.m4a
2-08 Boy-Girl [Version From Three].m4a
2-09 Stories For Boys [Version From Three].m4a
2-10 Another Day.m4a
2-11 Twilight [Demo].m4a
2-12 Boy-Girl [Live At The Marquee, London].m4a
2-13 11 O’Clock Tick Tock [Live At The Marquee, London].m4a
2-14 Cartoon World [Live At National Stadium, Dublin].m4a
[iMac:iTunes Music Folder/Music/U2] dnanian%

The only thing showing up in Roon is the MP3 version of Boy. What’s going on?

Do you have the Show Hidden Albums option turned off? I assume in the tag, the album data is correct?

I have the same issue as you with some albums. For some reason Roon does not recognize it. However, if I make a copy of the missing album and move it another level in my music directory Roon sees it. Perhaps you can try this experiment?

I checked with hidden albums on and off, and checked in the “Other Versions” section. I also had the album tagged as “Boy: Deluxe Version [Disc n]”, and changed that to “Boy [Deluxe Version]” relying on the disc tagging, that was present, and that didn’t matter either… it still won’t show up.

Since the album is in a copy of my iTunes Library, I can’t really “move it” - but it’s right there next to content that does show up fine, so I don’t understand why it’s not there. I guess I could rename it to something like “Troy” to see if that shows…but of course then it’s totally not going to match :slight_smile:

Note I also tried forcing a rescan, which didn’t do anything either. :frowning:

Sounds like you have the same issue I have. I’ve tried renaming the file, renaming the folder, editing the tags, forced rescan. Nothing worked. The only way Roon would recognize the album was when I copied it to a location one level up from where it was in my music library.

The original path was:
//nas_1/music/music/various artists

The new path

This is right alongside other albums that are recognized fine, including an older version of Boy (the MP3 one listed in my original message). While moving it might work, it would also be incompatible with the way I’ve got the music synced and organized already (and all these are in an artist folder – “U2” – so, well…moving it just isn’t an option. (I mean, I could probably make it a “compilation”, which would be senseless, but would move it to the Compilations folder…)

Yup same issue for me exactly! I have hundreds of other albums in the “various artists” folder which are imported correctly by Roon. You will probably have to submit some logs to Roon support.

They should already have logs from when this import happened - but we’ll see what they ask for.

Can you give us the details of this setup @David_Nanian, especially with regards to your storage setup?


It’s exactly as before: an iTunes-structured library, stored locally on a Synology. (It’s actually rsync’ed from the “real” copy.)

The server is running on the Synology as well.

Is there anything else you need? (The logs I’ve sent in previously would include the indexing information, so hopefully that helps too…)

Can you give us some more details about how you’re using iTunes with your Core running on the Synology? Have you modified the paths in your iTunes XML?

Ah. You’re assuming a base level of complexity that I tried to eliminate.

I haven’t set up Roon as an “iTunes” setup. Rather, I pointed it at the “Music” folder of the copied data, as “Watched Folders”. As such, it never sees the XML or any of that complexity: it’s just a series of folders and files. No playlists, etc, etc…just content, which came from iTunes (again, it’s rsync’ed from the original and kept up to date when needed), but is an entire separate copy, just files and folders, with nothing tricky about them.

I was wondering how you got that working :slight_smile:

Before we dig into your logs (which I believe we already have), have you read this over already? Just want to rule out the most obvious causes.

Yes. I’ve seen that. As I showed above, which is a straight up “ls” of the files involved, none of that applies.

Hi @David_Nanian ---- Thank you for your continued feedback and input. Both are very appreciated. We still have a copy of your logs (thank you for those) and will be taking out a ticket to re-analyze them to see if we can find any trace of something specifically going on with this album.

In the mean time I’d like you to perform a small test for to see if we can trigger a change in behavior. I understand that this is not long term solution because you are actively syncing itunes and roon, but as a test could please try the following:

  1. Move the content out of the watch folder, then rescan.

  2. Move the content back to the root of the watch folder, then rescan again.


But…it’s not in the root of the watch folder. It’s down quite a few levels.

The idea is to move them out of the watched folder completely, then see if anything changes one they’re moved back into the watched folder at the root.

OK, as opposed to the forced rescan, which should have done the entire tree?

I’m just trying to figure out what to do here. The folders are all at the same level in “U2”, and the “plain” Boy one works. Now, you want me to move the other two out of the watched folder complete (I’d basically just delete them), then… wait? Then, move them to… the root of U2, the real root of the folder? Just trying to do what you want…