Android can't find Roon Core

Anyone else have problems with Roon on android not being able to find the Roon core? I would say that about 80% of the time mine fails to find the core.
My Roon core sits on dedicated Mac mini connected to the network via powerline wired ethernet. My other Mac connects wirelessly with the network as does an iPad mini and neither have issues finding the core. However, my Google pixel phone and android tablet seem to have real problems despite being on the same wireless access point as the Apple equipment. Am I the only Android user suffering or are there others out there?

1 Like

Seems to be a common thing. I had it too for absolutely ages until I got rid of the powerline stuff, now i get a connection every time.
roon seems to stress/be reliant on/ work weirdly with/affect wireless networks differently to other products. If I have any problems with roon 99% of the time it is due to the wireless network (apart from my windows roon core buggering up on updates)

Glad it’s not just me. However I would like to know how Apple products can see through the wireless haze but not android.

I’m running mines with play store side loaded on a Fire 10 HD with no issues at all. Finds the core on my QNAP without a hitch. Was running on IOS iPad mini 2 previous to that and was a bit concerned about whether android would be a step backwards but it’s been rock steady up till now.

I think a lot of problems are more about the router/modem you use and how they handle a large amount of wireless connections to the Roon interface be it IOS or android.

A lot of speculation around it being a multicast problem. So either Roon isn’t calling the Android API to join a multicast group correctly, or the API itself has bugs and isn’t working correctly.

However, it will also fail to connect when you input the IP address of the Roon server directly, which in theory should skip the multicast discovery process entirely, so there is perhaps some other problem going on and it’s not related to multicast at all.

Hello, here are tips that have helped me.

Make sure that the Roon app is on the list of apps not to be put in sleep mode.

How to do(Samsung):

Go to settings
Go to device maintanance
Select battery
Go to unmonitored apps (at the bottom of the page), and make sure Roon is on the list of apps that not will go in sleep mode.
If not, add Roon to the list
BR
Per Morten

1 Like

Sometimes my iPad throws a hissy too. To be ecumenical.

I have the latest Samsung Chromebook and my Roon app cannot find my Roon Rock even if I enter the IP address. Tried uninstall and reinstall…no luck.
Any other suggestions?

Welcome to the party. My Pixelbook was working until it got a Chrome OS update this week. Went and picked up a Surface Pro 6 Saturday night and not a single problem.

Had a long term issue with an android galaxy tab losing connection to core. Had core on iMac with ethernet connection to router and tablet was on wireless connection from same router. Eventually decided to disconnect core from ethernet (i know, should not be done !) and make set up entirely wireless (courtesy of google wifi mesh setup). Not a single issue since. Mixed protocol network definitely had some effect here…

For the umpteenth time my Android phone would not connect, so I went into help and instead of of putting the IP address of my Core I put 255.255.255.255 and it found it immediately.

4 Likes

The 255.255.255.255 trick worked! How bizarre! Thanks a million!

1 Like

I am glad that it worked for others as well. Maybe Roon can pre-populate that field?

1 Like

This trick even works when my Pixel 3 is connected to Google Fi VPN. Thanks a million.

I had the same problem recently (couldn’t connect at all with my Pixel 3, but have no problem with my Fire 10), and the “trick” with IP address also worked.

Great! it Works
When a Patch from Roon?

Hi @TerryD/@Milton_Krueger/@darqman/@sm31/@Andrea_Maioli,

I ran across this post and I spoke to the team about it. We would like to get some more information here as to why exactly this resolved the issue for you. Can you please let me know the following?

  • What is the model/manufacturer of all your networking gear including router, switches, range extenders, ect?

  • What type of Core are you using, Windows/OSX/Linux?

  • What version of Android do you have and what is the model/manufacturer of the device?

  • Has the new build of Roon (build 416) changed anything when trying to connect without this IP address?

  • Has this workaround not worked for anyone who has tried this?

Thanks,
Noris

Actually, @Noris my Pixelbook connects to the core now without having to use this trick.

1 Like

Draytek router, Zyxel network switch, Draytek AP.
Windows NUC
Android 9 - Motorola G6 plus
Haven’t checked - I have now, it seems to connect as it should now.

1 Like
  • ROUTER ASUS RT-AC87U, no extender, no switches

  • Windows 10 (core) on NUC

  • Android 9 on ASUS Zenfone 5

  • Build 416 not tested yet, i’ll let you know

  • N/A

Bye now

Andrea

1 Like