Android can't find Roon Core

The problem, for me, has been solved.
No more problem to reach the core from my Android Smartphone

1 Like

Thank you for the feedback here everyone, it is appreciated.
It looks like our last update resolved the need for this workaround which is a great data point to have.

– Noris

1 Like

Just had the same problem. Windows 10 core, Android tablet (Galaxy tab S4) couldn’t connect until I used as the ip. Entering the actual core IP didn’t work. My other devices, galaxy s7 phone, windows 10 machines etc were all connecting fine both wired and wirelessy.


This is the current quick fix! This works every time for me!

Hi, fairly new to Roon here – where is the 255.255… IP address to be entered?

My old phone Samsung S7 Edge connects all the time, but my new one, LG G7 One, only abour 20% of the time. Both are on Android 9.

Core is on Win 10 64 machine used solely for Roon.

Hi @B_Clarke,

You should be able to click on the “Help” that appears after a few minutes on the Android App and input the IP address of the Core there or the IP there. Do note, if you are unable to connect to your Core without performing this workaround, this usually means that there are some multicast issues on your network. We can take a look over in the #support category but you must fill out a ticket regarding your setup there:

Thanks! The 255… worked, actually. Should I still fill out a ticket then (is the multicast issue likely to be an issue that should still be resolved anyhow, despite the workaround, er, working?)

Hi @B_Clarke,

If you’re only able to connect with the workaround but not without it, there still may be some network issues at play. Roon relies on multicast quite heavily so if you notice other issues such as endpoints not appearing or issues connecting to them, do feel free to open a support ticket. Also, our Networking Best Practices gives a great starting point for network configuration options.

Thanks again! I will do that when I have a breather from work :slight_smile:

This worked for me also. Thank you!

This odd trick did it for me! Thanks a bunch!

It also worked for me.
@support: Please add a bugfix to the android app.

Well, here it is February 2020 and I’ve just had my LG 40 phone (Android 9) “fail to find the core”. Putting in the correct IP address did not work but the workaround above did. This is a new install of Roon (I’m still in the 14 day trial period) so all components are freshly downloaded. So it seems not much progress in resolving this Android problem.

The notes on the thread state that there is more than likely an underlying network issue with multicast traffic causing the error. No application fix would work here.

it worked!!!

Im having this issue also. i bought a FireHD 10 tablet just for ROON remote i have done all the ROON troublshooting with my router Enabled multicasting exc even my Android phone wont connect it finds the Core ok but just says failed to connect

Have you tried the workaround?

No not tried that how do you do the work around

The link I shared tells you what to do, I don’t know anything more than that.

On my side:
Tried with Dlink switch then TP Link TL-SG105E / TL-SG108E with/without IGMP proxy.
Wifi Mesh Deco M5
Running in Docker with Debian base image.

As soon as it is not working restarting the server allow me to connect on Android but always with some delay compared to iPhone…
iOS using the same WIFI without issue.
I dont see how a network issue can have impact only iOS…
As I’m on trial I dont know if i will keep using it with that issue. Too bad as I’m happy with it but seeing that issue for so long on the community is not engaging.