Apple TV no audio

Got past the Airplay code step and grabbed the Roon Essentials Remote from the App Store as well hoping that would help. The Roon Essentials Remote app is responding wonderfully, shows what’s playing with time increment progressing, yet, still no audio heard. (Yes, I checked volume :slight_smile:

I do have a pair of HomePods (1st gen) as default speaker for the Apple TV. And these work great when playing from Amy source other than Roon.

Any thoughts?

The Roon Essentials Remote app is for use with Elac’s Roon Essentials Discovery server. Is that what you are using as your Roon Core?

Hi Geoff. Thank you for your reply. No, I wasn’t sure what the app was for… just stabbing in the dark looking for something to help smooth the process of getting the AppleTV working. I think we can ignore that app in troubleshooting.
The AppleTV is Model A1842 running tvOS 16.3.2
Roon Core is 2.0 (build 1211)
I have not “Enabled” the HomePods (Gen 1 running 16.3.2) within the Roon Core, only Enabled the AppleTV to which they are connected and set as default speakers for it. Intuitively that seemed to make sense to just let the AppleTV deal with sending the audio to the HomePods.

Btw, iPhone 11Pro (iOS 16.3.1) → Roon ARC (1.0.32 build 145) → AppleTV (tvOS 16.3.2)-> Stereo HomePods (16.3.2) work without issue (via AirPlay of course).

i’m not sure if this is even possible; tried it myself a long time ago and it didn’t work, most probably because of the mixed Airplay versions:

  • aTV to HomePod pair is using Airplay 2 protocol
  • Roon to aTV is using Airplay 1

If you enable the HomePods in Roon and group them together, you will be able to use them as a Roon endpoint & they will even be stereo with newest iOS version.

There is no official Remote app for Apple TV (at least not yet; hope Roon will consider it in the future). If you want to use your aTV as a remote display to see what’s playing & co, have a look at “TV: Remote” app - Apple TV Extension - Roon TV Remote

Thank you yo3fxy. Interesting that the HomePods will now work as a stereo pair as you described. When grouping in Roon, do you know if/ how this setup configures right vs left?

for me it honored HomePod’s right-left settings i configured in for them (confirmed with a right-left test track), so i assume that’s the default

if you have different results, you can use Roon’s Procedural-EQ DSP Filter to force stereo behavior (AirPlay 2 Support in Roon for Paired HomePods - #23 by Craig_Colthorp); that’s how i had mine configured until i found out (form a forum post here that i can’t find yet) that the DSP trick is no longer required with recent iOS updates