ARC connection issues -intermittent

I’m still in a Roon trial, so trying out all the features but far from expert user at this point.

MacBook Air

Networking Gear & Setup Details

My Core is running on an older MacBook Air, it’s connected wirelessly to our home router and bypassing our Orbi mesh network due to the two NAT problem. That connection to our ISP router was a temporary work around for our out of town trip described below, because we hadn’t done further research into the two NAT issue yet. But this approach works as seen below.

Connected Audio Devices

For ARC, I’m using both an iPhone SE and an iPad Air.

Number of Tracks in Library

13000 tracks

Description of Issue

I just returned from 5 days away which allowed me to try ARC fully outside my home. I was only able to get ARC to connect to my core 2x in those days, both times when I was on WiFi. Even on WiFi, it mostly didn’t connect but would frequently say “Core last seen 2 hours ago” or 1 day ago etc. I know it was working because once it said 48 minutes ago but as I was trying to reconnect it increased to 51 minutes ago. So it was actively updating the time lapsed. Usually the message was this, but a few times it said Poor Connection even though I was on WiFi. It never worked wirelessly. As soon as I got home, and on WiFi, it connected with no problem. It seems so random. Any ideas? Is ARC just not ready fir prime time yet? I’m debating getting a Nucleus but having it all work outside my home network is important to me.

Bumping to see if anyone else experienced this intermittent type issue?

Also noticed above I said it never worked “wirelessly” but I meant never worked with cellular.

Hey @Victoria_Carlin,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, there are a few things that could factor into this. The first being your core - you mention its on a MacBook Air. Was your MBA online and active during the full 5 days? There is a chance your core could have gone to sleep/become inactive on your network, thus causing connection issues to Arc.

In your Roon Core settings> Roon Arc, do any error codes pop up when clicking the arrow drop down? Or, does it say you are connected and active?

With this, I’m also seeing a fair amount of network timeouts when looking into your iOS connection.

We’ll need more information around your ISP and network setup. Please fill out the info below:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I’ll be monitoring this thread for your reply :+1:

Hi Ben, thanks.
We have a Verizon FIOS gateway G3100 furnished by them and an Orbi mesh network downstream of that. I live in the US, mid- Atlantic region. Upon my arrival back at home, we reverted to attaching the Core on the MacBook Air back to our mesh network (Orbi) because that’s where our Sonos speakers are connected. Immediately had the multiple NAT problem again with the ArC unsurprisingly. I did some more research. Could not get our ISP modem/router into bridge mode that I could figure out. As a next attempt, I turned off WiFi on the ISP router in its settings. It looks like it worked but the light on the router was supposed to turn green and it didn’t. The settings still show that WiFi is off but I’m skeptical. And I still have the multiple nat message when trying to connect to ARC.

As for the original issue questions, my MacBook should have stayed on while we were gone, only the screen was off. I even added an app to my phone to wake it up remotely in case that happened while we were gone and used it a few times just in case and it reported that the wake command was sent so it appeared to be working. Right this minute, I am no longer connected to the ARC through my FIOS router so I can’t report on any messages from the setting.

My goal is just to get rid of the 2 Nat problem and have the Core on the Orbi network. I did try some port forwarding instructions that I found online last week but that was a bit over my head and I gave up! It’s been a week since I tried anything so it’s getting fuzzier by the day.

Edited to add current ARC connection message for you. This is ARC on my iPad trying to connect to Core on MBA. All devices are on my Orbi network.
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 100.aaa.bbb.ccc:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“100.aaa.bbb.ccc”,“router_external_ip”:“null”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_upnp”:true}
}

Hey @Victoria_Carlin,

Thank you for the detailed follow up! Lets focus on the double-nat situation. I don’t see any mention of a modem in your network setup. Do you have a specific modem model you can share? Or, is the FIOS G3100 acting as a modem/router combo?

Typically, with mesh setups, you have to create two port forwarding rules. One for the modem/router (G3100) to route to other router (Orbi), and another from the other router (Orbi) to the core.

And to confirm, when you bypass the Orbi mesh network and hardwire your core directly to your G3100, Arc functions properly? If so, this sets us up nicely for troubleshooting the Orbi.

For setting up port forwarding on the Obri, please give the below steps a try:

  1. Find the local IP address of the server on your network that provides the service (IP of your core device). The server must always have the same IP address. To specify this setting, use the reserved IP address feature.
  2. Launch a web browser from a computer or mobile device that is connected to the network.
  3. Enter orbilogin.com. The login window opens.
  4. Enter the router username and password. The user name is admin. The default password is password. The username and password are case-sensitive.
    The BASIC Home page displays.
  5. Select ADVANCED > Advanced Setup > Port Forwarding/Port Triggering.
  6. Leave the Port Forwarding radio button selected as the service type.
  7. In the Service Name list, select the service name.
    If the service that you want to add is not in the list, create a custom service.
  8. In the Server IP Address field, enter the IP address of the computer that provides the service.
  9. Click the Add button.
    The service displays in the list.

Let me know if the above makes sense :+1:

Your answer makes sense but it’s a little beyond my expertise. I can try it but a few questions, do you have the same type of instructions for port forwarding on the Verizon G3100 (which is the modem and router which you asked). And what is “the service” piece I am looking for, I didn’t understand that.

I assume I need to:
Turn WiFi back on my G3100 (because I turned it off)
Set up port forwarding in the G3100 settings
set up port forwarding in the Orbi settings as you explained

Thanks.

Couldn’t resist trying things out on my own. I didn’t make it better but the ARC connection message changed. This was after I tried to set up port forwarding on both the Verizon G3100 and the Orbi. Clearly I did something wrong. Can you identify the current issue based on this?

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 100.aaa.bbb.ccc:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“100.aaa.bbb.ccc”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Hey @Victoria_Carlin,

Thank you for the information. After researching the Verizon G3100, it doesn’t look like setting it into bridge mode is an option, which would be the best next step in regards to bypassing the double nat situation.

That said, we can look to setting up port forwarding for Roon on the G3100. Here is a copy of the manual for the G3100 with a link that will direct straight to the port forwarding instructions: https://manuals.plus/verizon/verizon-fios-g3100-router-user-manual#port_forwarding:~:text=Access%20Control%20table.-,Port,-Forwarding

Let me know if the above helps :+1: