Attention Salt. Users in Switzerland: CG-NAT Blocks Port Forwarding, Workarounds Required (See Staff Post)

I have the same problem and I get a similar message …

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxx.xx.xxx.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

I just wasted an hour trying to find out how to fix in my router settings … I’m with Salt Box in Switzerland and there seems to be a general problem with adding / forwarding ports, though

Bad news:

Salt support meant though, that in the nearer future, this should be possible (but no guarantee)

Alternative: You must be able to enter a port-forwarding rule into your salt-box. That will do the magic.

Else, I might wonder how you can use the tons of game consoles et al with salt-fiber, who need this feature;-)

1 Like

Yes, I would think so too … not improbable also that the Salt Support guy didn’t understand anything about it.

there is this screen here, in the settings …:

Not really sure what to enter here though, or didn’t have any success so far with the information from Roon.

Also might be that I need to change some settings with the Firewall?

Select from any source (internet) via port 55000 to your Roon Core IP-Adress using also port 55000.

Just make sure Roon Core has the same port 55000 configured. Done.

1 Like

How to select from any source? Maybe I don’t quite get it what you mean … I entered now the following, but it still is not ready for ARC

Select UDP and TCP

done, I still get the following reply:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxx.xx.xxx.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Thanks for helping, Stefan … I’m a bit lost here, but I can imagine, others will be too.

FYI. Roon ARC only uses TCP. Including UDP won’t make any difference whatsoever.

1 Like

Try to reboot the salt-box

Funny how ARC works with my Salt box even without port forwarding. Problem, it only works for about 15 minutes and then I can’t connect anymore if I don’t restart roon and the arc app.

had no effect, unfortunately

Check, if the firewall has created such a rule (sorry, I’m not familiar with Salt HW/SW) and don’t know if they make this transparent to the user. If not, I’m nvolve the Salt call center

Salt is IPv6 oriented. I had a Salt Fiber when I was an expat in Basel for 4 years.
I received a private IPv4 address (10.12.x.x) on the public interface of the router. If that’s still the case , it will never work. There are two solutions I can think of: either you pay approx 10 CHF/month to Salt for a publicly accessible IPv4, or you define an IPv6 VPN solution that translates to IPV4 on the core and client.

What port is configured in Roon Settings → Roon ARC? The ports need to match exactly. And the IP you enter here needs to be your Core IP, which may change if you did not do an Address Reservation on it.

Also, the protocol should be TCP.

I changed it to TCP and added the information from the Roon > ARC Settings page. Although I’m not sure, what value I should enter really for each of the two port entries … 4 x the same number?

However, it still does not work

I checked again with customer support from Salt, and I got the following reply:

So - it really seems not to be supported with the current version of Salt box

I then asked about the publicly accessible IPv4 or VPN solution @Georgethesixth mentioned and he recommended to book an IPv4 … but I’m not sure if I want to pay another 10.- monthly just to use ARC. Also there’s no guarantee that it will work …

it seems at the moment, this is the way to go for Salt customers:

1 Like

Hi everyone,

Unfortunately, as @Tobias_Imbach and several other users have already realized, Salt. Mobile SA has widely implemented IPv6 addresses for their residential accounts and uses CG-NAT for that tier. It does not appear that they have a DS-Lite IPv4 tunneling option or PCP support that will allow for Salt. users to either automatically or manually configure port forwarding. So, ARC is limited to home network use and playback of offline downloaded content at this time. Note that the team is actively researching workarounds to IPv4 port forwarding that will potentially allow for our users dead-ended with CG-NAT to access ARC on-the-go as designed. However, we don’t have a timeline or a guarantee of success for these potential future Roon-supported workarounds.

To summarize, there are three current workarounds Salt. users can take to access ARC, although they do fall within the realm of our #tinkering solutions:

1). Contact Salt. support to request a static IPv4 WAN IP address for a monthly fee. Note that, depending on the age of your Salt account, you may be able to grandfather into a static IPv4 if you originally had one reserved.

  1. You can try out TailScale, a workaround explored in our #roon and #tinkering section (see above)

  2. You can try out various third-party VPNs, as discussed here, for example.

Thank you for your patience, and we’ll post here if we find any additional helpful information.