Audio devices disappear after machine resumes from sleep

Roon Core Machine

Dell OptiPlex 7040 - i7-6700 - Windows 10
Version 20H2
OS build 19042.746

Networking Gear & Setup Details

Netgear GS208 unmanaged switch

Connected Audio Devices

Window Roon Core to HQP Embedded on another PC which in turn sends audio flux to NAA device USB connected to DAC.

Library Size

1000 albums, 100,000 tracks, 30% of which are Qobuz.

Description of Issue

I’m hoping to save power by allowing Windows to go to sleep when not playing music. Windows is dedicated to hosting Roon Core and goes to sleep without issue but upon sending wake-on-lan packet to wake up machine, Roon displays no Audio Devices.

I’ve read about the Realtek HDMI audio driver issue and have tried updating, disabling Realtek audio device and uninstalling driver. No change.

If I remote to the typically headless Windows machine or with a monitor and keyboard attached and access the machine audio devices reappear as normal.

How can I get audio devices to appear after resuming from sleep?

Hello @Larry_Post,

Thanks for getting in touch about this :nerd_face:

Could you please try not only disabling your Realtek drivers, but using the Windows generic High Definition Audio instead?

Please, let me know if that helps :pray:

Hi @rebeka

Sadly, I get the same behavior with the Windows HDMI driver installed but disabled. I also tried disabling the Intel display audio driver.

I reboot after each disablement with sleep set to 3 mins. I wake with WOL utility. Once I access the server console via VNC, the audio devices ‘wake’ and resume as normal. Of course, I’d like it to no require accessing via VNC or other Remote Desktop utility.

Hello @Larry_Post,

I appreciate your help and effort so much. Thanks for trying :pray:

Since it looke like the WOL from sleep is not properly enabling the Roon audio devices, could you please check “Energy Efficient Ethernet” settings to see if that helps or “Fast Startup” in Power Options?

Also, this might provide some context:

https://www.dell.com/community/Desktops-General-Read-Only/USB-ports-stop-working-after-waking-from-sleep-mode/td-p/4238085

Please, let us know :nerd_face:

Thank you for the ideas,

I’ve tried EEE on and off, no change. My Windows machine doesn’t appear to have the option to select Fast Startup enabled or disabled, the option simply doesn’t appear where the link refers. The setting is missing because I’ve disabled hibernation as I don’t wish to have the system hibernate.

WOL works fine to wake Windows, I don’t have a USB device connected, only Ethernet and power.

Any other ideas?

Hey @Larry_Post,

I appreciate you trying :pray:

The next idea I have is to get our technical team to chime in. I have looped them on this thread. You should hear back from them here :nerd_face:

Please, bear with us for a bit :pray:

Thanks, much appreciated.

1 Like

I’d just like to add that this issue has been bugging me for ages.

My PC wakes from sleep via a scheduled remote signal from Logitech harmony hub to USB flirc device connected to PC (so is detected as a keyboard wake event I believe). Roon client connects fine but no audio devices are detected. The moment I connect to the PC via VNC, the audio device(a raspberry pi endpoint) appears.