Audio devices missing after machine resumes from sleep

Roon Core Machine

Windows 11 (up to date) Geekom Mini IT11 CPU: i7-1195G7, RAM: 16 GB Ram,

Networking Gear & Setup Details

Core and endpoints wired over LAN

Connected Audio Devices

Bluesound Node 130, Bluesound Flex (gen 1)

Number of Tracks in Library

Description of Issue

When the core returns from sleep (initiated by a roon remote on iPad or Android) there are no audio devices present on iPad or Android Roon remotes. If I try the Roon remote on the core computer the audio devices return.

I have read the posts below who seems to share similar problems and tried the suggested fixes described. But none of them seems to work for me.

I notice that the screen connected to my core does not come alive (get a signal from the core computer) after the core returns from sleep, until I hit a key on the connected keyboard. I don´t know if that could be related.

I recently got a new core computer. I never had this problem on my old gen 5 NUC with Windows 10. Please let me know if you need more info - Thanks.

1 Like


I still have this issue and I tried a lot of different settings for network and power. But noting seems to work. I also tried a fresh install of Windows 11 (pro) but the no audio devices problem is still there.

The other threads on this does not mention any solutions. Do you have an idea about what causes the problem. Can I change anything on my end?

The picture is from a windows remote on another machine. When I press any key on the core computer the audio devices return instantly.

Hi @TreeZorro,

As you’ve very likely already considered, the two pieces of evidence quoted below suggest that the BIOS may be reducing power to the port to which you’ve connected your screen. It’s possible that the power adjustment settings are similarly curbing Roon’s ability to access the network, dropping the connection to the Bluesound outputs (and any audio outputs detected by the OS, as well).

Looking through recent account diagnostics from your Core, there’s evidence that the machine is blocking all of Roon’s requests when it’s asleep. Connectivity to the Bluesound disrupts, causing an eventual deactivation of the Zone, and basic account authentication and time update requests fail to reach our servers from the Core.

Unfortunately, this would suggest you need to take a look at the power settings of the Core machine.

Are you seeing any evidence of other network disruptions when the Core is awake and online? For instance, do your Remotes sometimes lose connection or load slowly, or do you experience audio dropouts to your endpoints? This might point to an underlying network issue either unrelated or influenced by the sleep/online status of the Windows Core. In any case, we’ll learn more.

In the meantime, if you haven’t already, try refreshing RAATServer after creating a backup to refresh connectivity to your Zones. You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

We’ll keep an eye out for the log report and your response. Thank you for your patience!

Thank you for your detailed reply. I tried to refresh the RAATServer like you described but it didn’t solve the problem. I’m not sure it’s endpoints getting disconnected but more a power issue like you suggest (if it is’t a Roon problem).

I turn off my core at night (and most of the time when at work) and I have also disabled wake timers which I think explains why authentication and time updates fail to reach your servers. I have not noticed any networks disruptions. But I can’t rule it out as a course. I tried to connect my old core computer, a gen 5 NUC to the same location and with same static ip adress. It did find my audio endpoints after waking from sleep but interestingly started out saying no audio endponts found. After 1-2 seconds it updated and found all endpoints. So the old NUC is doing someting the new Geekom core isn’t.

I have tried every power setting in Windows and nothing seems to fix it. I have also updated drivers and tried older drivers without succes. I have made a couple of other oberservations:

If I hibernate instead of sleep it works.

If I put the computer to sleep right after booting and wake it up by WOL it works most of the time. Mayby because Roon is still scanning the collection. But if I try after Roon finishes the initial scan it fails again to find any audio device.

When the Geekom machine wakes from sleep (by WOL). There are no audio devices present but the rest of the interface works. I can browse the Tidal and Qobuz through Roon and find local albums so some network activity is present.

I have gone into the BIOS but it’s crazy many choices on the Geekom and I not sure what I¨m looking for. I think I ruled out that its a CPU core power issue because I disabled C states and it still didn¨t find audio deviced with all cores on full power.

From the other cases I mentioned in the first post (that looks a lot like my case) do you have any idea what I should potentially be looking for in the BIOS?

One more thing to try is to simplify the setup and just have system output and internet cable directly into the core bypassing the ASUS router. I will try that and let you know how it goes.

1 Like

I tried this and got very far before I realized that bypassing the router meant that there was no remote on the same network as the core and noting to wake the core over LAN - D’oh!

I’ve wasted enough time and energy on this and I will try to return the Geekom computer.

I’ve found a cheap used NUC Gen 10 and will try this instead.
The solution is: Just get NUC :slightly_smiling_face:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.