Audio devices missing after resume from sleep

Roon Core Machine

Fresh install of Windows 11 pro (up to date) NUC 10i7FNK, RAM: 32 GB Ram, Samsung EVO Plus NVMe

Networking Gear & Setup Details

Router ASUS RT-AC68U

Core and endpoints wired over LAN with static IPs.

Connected Audio Devices

Bluesound Node 130, Bluesound Flex (gen 1)

Number of Tracks in Library

Description of Issue

I had this problem 2 weeks ago with no audio devices showing up after my core resumes from sleep when waking from LAN. Now it’s back.

I thought it was related to a Geekom computer I had recently purchased as my core. I then got a NUC 10i7FNK instead but I have the same problem now: The Roon remotes on both android, iPad and Windows shows a completely blank audio screen. The audio devices appear instantly if I hit any key on the keyboard connected to the core. The screen connected to the core does not come on when waking from LAN (I have tried the various HDMI CEC settings in the bios).

What I have tried since last time is a factory reset of my ASUS RT-AC68U. Then only setting up manual IP addresses for the core and the endpoints and a port forward rule for ARC. DNS is Cloudflare.

I have left all other settings on default. Then I tried resuming from sleep over LAN with only the core and the Bluesound Node wired to the router. It was the same problem with no audio devices showing. I have a feeling this is not a network problem but somehow relates to power/standby settings on the NUC.

I can access and play from ARC over the LAN while the Roon remotes still shows no audio devices. It happens whether I wake the computer over LAN or WAN and whether it is Roon remote, ARC or a third party WOL app that wakes the core.

Could this be related to modern standby vs legacy S3? Which sleep mode is recommended for Roon?

Is there a monitor attached or is it headless?

A post was split to a new topic: Issues after resume from sleep MacOS

I have a monitor and keyboard attached.

Hi @TreeZorro ,

To get them back, are you also able to connect to the computer via Teamviewer or a remote connection tool, or do you have to press the keyboard?

Does turning the screen off/on trigger any change in behavior? I wonder if this could be related to Roon detecting a video output.

Thanks for getting back to me. This have been driving me crazy :slightly_smiling_face: I have been reinstalling Windows several times in both Modern Standby mode and Legacy S3 mode (NUC bios setting).

Right now I’m in Legacy S3 mode. If I connect via Teamviewer to the core computer after waking from LAN the endpoints return in Roon along with the signal to the screen.

Turning the screen on or off does not affect the behavior.

After reading about modern standby it seems that wake on LAN is not supposed to wake the display so this seems like expected behavior. But it also happens in Legacy S3 mode.

I tried waking from LAN without the HDMI cable plugged into the NUC. It still starts Roon without any audio endpoints.

One more thing that happens when waking from LAN. The NUC returns to sleep after about 2 minutes if I haven’t pressed any key on the attached keyboard (or connected via Teamviewer). The core will also return to sleep while playing from ARC if its woken from LAN. This is with Windows set to never go to sleep in power settings.

Digging some more I found that Windows has a wake timer for unattended access (WOL) that is set to 2 minutes by default. This explains the core going back to sleep soon after waking by LAN. I can change that vis the registry - so one less problem to worry about.

@noris I have now tested this missing audio device issue in the simplest set-up I can make. I connected my ASUS RT-AC68U router directly to the wan port of my ISP modem (modem is in bridge mode and with a static external IP). Then I connected the NUC 10i7FNK by cable to the ASUS router. The router is factory reset and NUC bios has optimal defaults loaded. Windows 11 pro is recently installed. Only HDMI cable, LAN cable, power cable and a Logitech Unifying Receiver connected to the NUC. The issue with missing audio devices is still there when waking form LAN.

I can’t really think of anything more to test on my end. You wrote in November that there had been some improvements in sleep behavior. Audio devices disappear after machine resumes from sleep - #11
Do you have any idea what causes this?

It seems that many of the reports of this issue are on Windows pro/enterprise installations. Could that be a factor?

I’m fully aware that Roon recommends an always on core. But I would really like to know what’s going on to understand the issue when it works on my previous NUC 4 core and not on my present NUC 10 core.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.