"Audio File Loading Slowly" with 2012 Mac MIni [Resolved]

Just yesterday I started getting the same error messages about an “Audio File is Loading Slowly” but here’s the rub, I’m loading all my files locally, not over the network. These issues have arisen when playing DSD 64 and 128 files which can be sizable (large).

I am running ROON on my late 2012 model Mac MIni with 16GB or RAM. My hard drives are connected locally via USB and not matter which I try, the problem persists. Thinking this could be a USB issue, i copied the files from the USB externally connected drives to the internal hard drive of the Mac Mini and the issues remain with the error messages, the files stuttering and ROON moving from one file to the next in a futile attempt to play the files.

Perplexed no end by this, because I could not recall this being an issue until yesterday, I launched Audirvana Plus (various versions) and played the files flawlessly: no stuttering, no hiccoughs. The files played as they should.

Looking forward to your feedback on this.

Bootcamp not loaded. This is happening constantly with large DSD files DSD64, DSD128 and DSD256. What is bothersome and troubling is that i can open and play these files in Audirvana Plus on my late 2012 Mac Mini running Sierra OSX with 16GB RAM. I copies a selection of folder off of my USB external drives to the internal drive of the Mac Mini and the same problem occurs. At this point I cannot play ANY of these files on ROON.

At first I thought ti could be the formats and the files themselves, so I made it a point to play files which I got directly from DSD labels and recording engineers, those too if they load at all, stutter, hiccough and then unceremoniously shut down.


Slim, you are correct, not what I WANT to hear BUT, how is it possible that there is no problem with the files running Audirvana Plus? running on Mac OS. Am presently playing and listening to Keith Jarrett’s KOLN CONCERT DSD files.

Hopefully others will chime in. I find this bothersome because this has only happened recently. This started within the last 48 hours that I have noticed.

Mac mini (Roon Core) [late 2012 Mac Mini] > Mytek Brooklyn DAC > Parasound Halo 2.1 > Audio Physic Speakers.

16 GB RAM and have tried this with nothing running apart from ROON. Also have my exaSound e22 at the ready.

Am NOT using any DSP whatsoever, nor am I upsampling.

About the only change was swapping out the exaSound which runs with its drivers for the Mytek Brooklyn, but that was weeks ago and this issue only started in the last few days.

Is it possible to play a DSD64 track and take a screen shot of your signal path while it’s playing?

Do you have similar playback problems with the e22? (This may not be very meaningful with respect to the Brooklyn if you’re using exa’s ASIO driver with the e22.)

Also, if @support gets involved, they’re probably going to want details of your setup, as described in this link:

i do not recall similar problems with the e22 at all
i will get back to this re: signal path

Her is the Signal Path

let me know what if anything needs to be changed/altered

For testing purposes, I would try turning off crossfeed and PEQ. If that gets rid of the issues, then you can try adding back the DSP (!) features one at a time and see how it goes.

Also, if you’re currently running full-on Roon, you might consider running Roon Server instead, as that will free up some resources on the mini.

The Roon support folks may have some additional pointers.

Hey @David_Blumenstein – the processing speed indicator here is showing that the performance of your system is right on the edge – 1x means you’ve got just enough CPU power to run your current DSP settings. There’s more info about what that number means here, but 1x means that any increase in the overall performance of the Mac could cause a dropout.

Like @orgel said, I would play around with your DSP settings – in particular I’d see if that processing speed number changes when you disable Native DSD Processing.

1 Like

Mike and Orgel

i shut off all DSP and so far so good, am going to test and play more files, larger ones and see/hear where this goes. Doiing so increases the processing speed indicator to 1.5 and files are playing as they should. As I don’t particularly lust after the DSP features, all is good. Back in busienss… Thanks Mike and Orgel.

1 Like

Great, let us know how it’s going David!

1 Like

Shutting off DSP has done the business. If this problem comes up for anyone in the future have them do so and this should solve the issues. Apparently NOT platform/OS specific.

Also for anyone reading this who is into experimental electronic music Adi Newton’s Clock DVA latest is an album entitled Neoteric (2016) played at high volumes, the hairs one one’s neck are sure to subside.


This topic was automatically closed after 26 hours. New replies are no longer allowed.