Audiolense Convolution Filters in Roon [Resolved - Build 298]


I generated Audiolense filters. I know they work because I looped back through jriver and captured the measurements in REW. Audiolense uses stereo .wav files.

I followed Roon’s rules and edited the cfg files to only include relative file paths. I also created a directory with a zip folder. The folder loads in the convolver without error but the sound stutters and plays at a fast speed (sounds like chipmunks). I turned off any upsampling and tried different speaker configurations since I’m using four channels.

I use Windows 10 and my computer is an i7 with plenty of power.

Here’s the zip folder I created. What am I doing wrong?

Stuttering may indicate that your Roon core machine does not possess sufficient horsepower to run convolution, particularly for greater than two channels. Double check your signal path processing speed.


Additional factors to check include filter length (taps) and audio sample rate(s). Some combinations can be more CPU intensive than others.


That’s not the problem.

Would someone please help me out here?

I suspect Roon Convolver may not handle the channel routing. The setup is a four channel output with 2 channel input. 2 of the four channels get both inputs and the other 2 channels each get one input. This is a 2.2 stereo routing where each subwoofer gets both R/L inputs. IOW, it’s a 2 channel stereo with 2 mono subs setup.
I generate cfg and wav impulse using Audiolense. I followed the rules; relative file paths, zip file etc. I get no error message. I posted a drop box link in the thread so you can test for yourself to confirm there’s a problem with convolver.

@Michael_Lowe ---- Confirming that I have seen your post(s) and your PM. Thank you for the reports.

Moving forward, I have downloaded the supplied filter from your initial post and will be coordinating with our tech team to setup testing with the materials in our QA lab. In the mean time, I would like to make sure I have all the details of your setup for my report and would kindly like to ask you for the following information:

  • An brief but accurate description of your current setup using this link as a guide.

  • A screenshot of your signal path leaving Roon when you make this observation (i.e stuttering/speed of playback).


Thanks Eric. Here is the screenshot you requested.

windows 10 64 bit
Roon 1.3 build 276 64 bit
i7 MSI laptop
628gb of music stored on local D: drive

The DAC is a Merging NADAC MC-8 and uses Ravenna ASIO over network switch. The faulty playback only happens when convolver is enabled. I’ve used the exact same cfg and filters in Jriver and they work perfectly.

I just installed version 1.4 build 294; Same faulty playback.

Thanks for the update @Michael_Lowe!

To bring you up to speed, I have placed a “testing ticket” with our tech team and once the ticket has been updated with their findings I will be sure to provide you with an update as soon as possible. Your continued patience is very appreciated.


Hi, @Michael_Lowe, I was able to reproduce this issue and put a ticket for our developers.

Thanks for your patience!


1 Like

Thanks @Ivan @Eric Just FYI, I set up a different dac. I loaded new filters, different channels but the exact same routing scheme. I get the same faulty playback. Its a Lynx Hilo:

Hi, @Michael_Lowe!

There were actually two issues here. One is a bug in Roon–this is what causes the stuttering sound, and it will be fixed in our next release. Thanks for the report!

The other problem relates to the way these filters are defined. Roon is seeing a convolution config that goes from 2.0 -> 4.0.

In other words, the output of the filter is being interpreted as 4.0 data: Left,Right,Center,Rear-Center. And then that is being mapped onto the 7.1 layout configured at the audio device, which actually doesn’t have a Rear-Center channel, so you end up losing one of the subwoofer channels in the final mapping.

Instead of getting 4.0 involved, I suggest a slight alteration to your .cfg files so that they produce 7.1 in the same order as the connections on the back of the device. This will disable the channel mapping entirely. Then inside of the .cfg, you can treat the layout as a flat list of 8 channels. Roon is “smart” about not sending empty channels over the network or spending effort processing them, so this change should not produce extra cost/work in the system.

At the top of each of the config files, try changing this:

44100 2 4 0
    0 0
    0 0 0 0

To this:

44100 2 8 0
    0 0
    0 0 0 0 0 0 0 0

There are 2 changes in each file: a 4 is changed into an 8 on the first line, and on the third line, add four extra zeroes. The remainder of the file remains as-is, as do the .wav files.



1 Like

Thank you for responding. Sorry I didn’t respond to this sooner. I changed my configuration again. So I’d like to try the Roon convolver again. Has it been fixed so it doesn’t make the nasty noise? Which version of Roon will work?

Hi @Michael_Lowe ---- Thanks for getting back to us! Give the most recent build (i.e Build 298) a go and let us know what the experience is like with the filters.

Looking forward to your feedback!

It’s a beautiful thing! Everything works. I’m using a 3 way crossover for right and left. It works great. I’m glad I don’t need to use HQplayer or Jriver. Thank you!

1 Like