Backup failed / Backup directory not available

No idea what’s happened here, but I opened the ROON app on my iPad today and got a message that my scheduled backup had failed. It said the backup directory is not available. I rebooted the Nucleus and tried a manual backup, but same result. I do my backups to a thumb drive in the Nucleus and have done so for more than 6 months with no issues. Here’s a screenshot I just made:


I’m going to check what memory is left on the USB stick over the network first…

Hi @Woo,

If you navigate to your Nucleus’ Database Location/Storage folder, do you still see the Sandisk drive appearing there? If you try temporarily connecting this USB drive to another PC, does it show up as expected?

Yes, the SanDisk drive is visible just like normal.

I’m able to see the SandDisk drive over the network on a laptop and can see it has plenty of storage left. I’ve not unplugged it from the Nucleus though.

Hi @Woo,

If you try a manual backup (by clicking “Backup Now”), does that work?

As mentioned in my OP, I tried a manual backup but it didn’t work.

Hi @Woo,

Can you please try another manual backup and note the exact local time + date you try starting it? I’d like to then enable diagnostics mode for your account and take a look for further clues in that direction.

Also, have you confirmed that music is not playing when trying to perform the backup? Having music playing on any of your zones will prevent a backup from taking place.

Will do. And to confirm, I’ve not had music running during any of the backup attempts.

…At 21:53:23 I attempted a manual backup, which instantly failed.

Hi @Woo,

Thanks for letting me know that timestamp. I have activated diagnostics mode and what this action does is automatically upload a log-set to our servers for analysis.

I do see the backup error and I’m seeing that the error listed is that the drive is in read-only mode. Does this drive by any chance have physical switch on it which enables writing to the drive?

Hi thanks for looking into this for me. The drive has no switch as far as I know of. Either way, I’ve not touched it for months. That’s odd that it’s in a read only mode. Not something I know anything about. I’ll ask my partner to help in case we can solve it quickly at home.

1 Like

Hello @Woo,

Sounds like a plan. Another thing I would check is to see if the Nucleus can perform backups to another location (such as to another PC on the Network/NAS/other USB) and if the Nucleus can perform the backup, then we have proven that the issue is localized just to this current USB drive.

2 posts were split to a new topic: Nucleus Backup to USB Stick Issue

A post was split to a new topic: Backups to USB or Network Share fails