Bluesound problems

Final set of experiments with very interesting results:

Experiment 1: Roon Core on MacBook Pro 13, wireless connection to router. Various placements around the flat. Music sent to Bluesound Flex 2i also wireless (excellent signal indication in diagnostics).
Result: Almost flawless operation. I can skip, fast forward a lot with no problems. Instant playback. If I skip a lot in succession I may get 3-4 seconds before playback initiates. No big issue there and it happens only rarely.

Experiment 2: Roon Core on Windows PC with ethernet cable connection to the router. Sending music to the same Bluesound Flex 2i.
Result: Perhaps a small improvement compared to using the PC wirelessly. Skipping 2-3 times in succession results in a delay of 9-15 seconds before audio is heard. A small improvement in responsiveness compared to a wireless connection but overall the same issues remain.

I also tried completely uninstalling Roon from the Windows PC, removing all instances from the windows firewall and then reinstalling.

There is definitely something going on with the Windows PC when it hosts the Roon Core. Curiously there are no problems at all when sending music to the Allo Digi One.

There is no problem in operation when the Roon Core is located on the MacBook Pro.

Hi @Yiannis_Kouropalatis,

You mentioned that you have reinstalled the Roon Core on the Windows PC, but have you also set your old database aside? It would be best to perform a clean version of this test, please use these instructions to set the old database aside:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Verify if the same behavior occurs on the Windows PC

Great idea @noris

I am traveling with work at the moment but I will try out what you recommend as soon as I am back on Sunday. Will report back then.

1 Like

Hi @noris,

Just wanted to update that I followed your recommendations and renamed the Roon folder. I subsequently reinstalled Roon and that generated a new Roon folder as you indicated. I confirmed this as I could now see the ‘Roon_old’ under the new ‘Roon’ folder. Should I restore the database after I do this or should I try to create a new one in order to perform the test?

Many thanks

Hi @Yiannis_Kouropalatis,

I would try using the fresh database for a day or two and verify how it performs. Afterwards you confirm if things are operational with no database, you can restore the database from the backup. The Roon_old folder is your old database and is a fail-safe in case you have issues restoring the backup, so I would leave the Roon_old folder in place for a week or two until things have stabilized in the new install.

Many thanks @noris,

I have just completed the test and the result is very interesting:
Partial improvement but problems persist when using my Roon Core on the windows 10 PC. The improvement is that the playback delay is marginally reduced to 5-11 seconds (from 7 - 15 seconds). In addition successive skips and fast forwarding do not lead to the system hanging completely. playback delay will occur 70% of the times that I skip or fast forward. There is a playback delay but the music will eventually start on the Bluesound Flex 2i. (when using the full database the playback delay is more frequent and the audio will occasionally fail to start altogether)

The above test is carried out with Roon core freshly installed and with a completely new database. I have just copied 4 tracks in a temporary folder and pointed Roon to that.

Switching the Roon core to my mabook pro 13 (with the full database) results in drastic improvement and responsiveness. No problems at all no matter how much I skip and fast forward tracks. Playback begins almost instantly (1 second delay) and there is no issue at all.

I also used a new Mac mini (2018 model) from work and the behaviour is exactly as in the MacBook Pro. No problems at all.

Can we conclude there is something going on in the Win10 installation?

Cheers

Hi @Yiannis_Kouropalatis,

Thanks for sharing your findings, the results are interesting indeed. It’s also very curious that the Allo does not display any of these issues. I would like to take a look at logs next to see if there is any additional info contained in them. Can I please ask you to:

  1. Reproduce this issue and note the exact local time + date when this behavior occurs (using the Windows Core)

  2. Let me know this info and then manually send me the logs from your Core by using these instructions? The best way to get them over to me would be via Dropbox / Google Drive / Send.firefox.com

  3. Also attach a copy of your bluesound logs to this diagnostics report. You can get these logs by navigating to Bluesound’s IP Address in a web browser -> Diagnostics -> More -> Copy+ paste the text into a text editor and send it as a shared Dropbox/Google Drive/Firefox Send link as well.

Thanks!

Hi @noris

Logs are ready :slight_smile:

Roon logs are accessible here (dropbox):

Corresponding Bluesound (Flex 2i) logs are accessible here:

I hope you can access the above without issue but if not please let me know and I will find another way to send them over.

The experiment was quite easy to carry out as the issues appeared almost immediately. This is is with Roon Core on the Windows 10 PC, sending audio to a single end point: Bluesound Flex 2i.
The Roon Core is operating with a new / fresh database as per your guidance. Only 4-5 tracks imported to the new database.

The time stamps / experiment times are as follows:
08:10 (UK local time): initiated playback. there was a delay of 3-4 seconds but music then started fine. I allowed the track to play for 5-10 seconds and dragged the slider forward to a bout 2/3 of the track. There as a delay of 5-10 seconds for playback to start again.
08:11 (local time): Skipped to the next track and then again to the one after that. Delay of 10+ seconds before audio started.
08:11 to 08:12: As the track was playing, I moved the slider forward to about 2/3 of the track. There was a delay of 10 seconds after which Roon the playback seemed to start but there was no audio at all. Roon was showing the track playing but there was no audio at all no matter how long I waited. I had to stop playback and rewind to a different track before audio was reestablished.

Interestingly the Bluesound logs show timestamps that are one hour before the above timestamps. Not sure why and I tried rebooting the speaker but this persisted.

After the above experiments I switched the core back to the MacBook Pro and all was fine with no delays, no audio loss. Very snappy problem free operation.

Very puzzling results right?

Cheers

Hello @Yiannis_Kouropalatis,

Thanks for sharing those logs, I have forwarded them to the technical team for closer inspection. It may take a bit of time to review them but I was wondering if you could also let me know the following information as I believe it may be helpful:

  1. If you run a speedtest from both machines by using speedtest.net or fast.com, can you let me know the reported speeds?

  2. When the delay occurs, does the play bar appear to move at all or does the play bar get stuck on 0:00 until the 5-15 second delay has completed?

I had sync problems with my Bluesound devices in the past, but recently they seem to have gone away. Have you updated every device to the latest BS firmware/software? I’ve also found that grouping BS devices from within the BS application (not in Roon) seems to help.

Hi @noris

Completely understand it may take some time and no problem at all :slight_smile:

Regarding the additional info:

  1. Speedtest
  • Windows 10 PC: 54 Mbps download, 3.8 Mbps upload, 20ms ping
  • MacBook Pro 13 (roughly at the same position): 40Mbps download, 2.9Mbps upload, 15ms ping.
    So overall the MacBook Pro presents lower speeds but a bit faster ping.
  1. delay types
    I experience 3 types of delay, sometimes occurring one after the other.
  • Delay type A: play bar starts to move and there is no sound. Usually it takes 5 seconds before the music starts. The first 5 seconds of the track are therefore lost.
  • Delay type B: The bar does not move and there is no sound. Usually it takes 8-9 seconds before the bar begins to move.
  • Delay type C (the most rare): This is technically not a delay as the bar begins to move but there is no sound no matter how long I wait. I need to skip a track in order for the sound to begin again. I thought I should mention it as I encountered it in the test that I reported (with the logs provided).

When I start sliding the bar forward I initially experience type A delay only. If I skip again and then again I begin to experience type B immediately followed by type A delay. When this happens (after dragging the slider forward to about 2/3 of the track), the bar initially does not move at all for about 8 seconds (type B delay). It will then start moving but still there is no audio coming through. This takes 5 seconds (type A delay) and the audio comes back. This Type B + A delay occurs if I skip / slide forward a few times in quick succession (usually 3+). This delay also happened in my brief experiment I reported and hopefully the logs captured it.

Lastly, delay type C is quite rare but it did occur in my brief test. It happens if I skip tracks in succession and also slide the bar forward to fast forward. 5 - 6 skips can trigger it but not always. It will usually be Type B and then Type C in succession. This did happen in the brief test I ran.

All these issues indeed only occur when I send music to the Bluesound Flex 2i. No problems at all when I send music to the Allo Digi One as long as the latter is not grouped with the Bluesound. Once grouped, the problems occur the same way as when I am sending music to the Bluesound alone.

These problems of course go away completely when the MacBook Pro / Mac mini is used for the Roon Core.

Lastly (maybe useful), I also notice a delay on the Roon iOS app when the core is running on the Windows 10 PC. Launching the Roon app on my iPhone (frequently) takes 2-3 seconds before the connection to the Roon core is established. The app appears to be trying to connect for a few seconds.
Again, if the core is running on either the Mac mini or the MacBook Pro, the iOS connection is instant and snappy. This delay with the Roon Core on Windows 10, occurs regardless of Bluesound devices being used or not.

Quite interesting results. I am thankfully able to run the core on the Mac so my Roon experience is fine but I would love some insight regarding the combination of Windows 10 PC Roon Core and Bluesound devices.

All my problems with blue sound in the past year have been experienced with the Roon Core running on the Windows 10 PC so I am wondering whether there is something that stems from that combination alone.

Lets see what we find in due time.

Many thanks
Yiannis

Hi Tom and many thanks for the heads up regarding firmware. I know the sync issues you refer to and they were thankfully fixed a few months ago (took a while before they were addressed though). In my case, I have indeed double checked and the Bluesound speaker runs the latest firmware. If I group my Bluesound Flex 2i with my Allo Digi One (main hifi), I have perfect sync. The issues I am encountering are these strange delays in playback after skipping or fast forwarding. Occasionally I will lose the audio completely that way. These problems only seem to occur when the Roon Core runs on my Windows 10 PC in combination with Bluesound devices. No problems at all when using the Roon core on Mac.

Cheers

Hi @noris

A further update with not so good news unfortunately. I have attempted to introduce a second Bluesound device alongside my Flex 2i and this seems to exacerbate the situation.

Despite the reported problems when my Roon Core was on the Windows 10 pc, all was working well when I was using the Mac book pro instead. This was the case while I was using a single Bluesound speaker (Flex 2i). I just introduced a Bluesound Soundbar 2i and things deteriorated.

Using my MacBook Pro 13 to run my Roon core, I can see the two Bluesound speakers but the playback delay problems are back with a vengeance. When the two are grouped (Flex 2i + Soundbar 2i) a lot of issues occur:

  • Playback takes 10+ seconds to initiate.
  • Fast forward or skipping results in the Flex 2i starting first (after 5 seconds of delay) with the Soundbar taking an additional 5-10 seconds before audio starts.
  • A second / third track skip results in no audio. The playbar shows the track is playing (seconds count as normal) but there is no audio. I have to stop playback and skip to another track in order to get audio back.
  • Sometimes playback just hangs right at the end of a track. ‘Play’ is still active but the playbar is just not moving.

I tried the usual things: Ensure Bluesound units are running the latest firmware, Roon core quit and restart. The Soundbar is located 15ft away from the router (signal shows as good to excellent).

Outside Roon everything works well: Spotify, airplay2 and Bluesound internet radio all work fine and without delays (both on individual speakers but also when they are grouped either via airplay or via Bluesound app)

From my perspective and experience, while things work really well when RPi endpoints are used, it appears that Bluesound devices remain problematic when used with Roon (especially when grouped in multiroom playback).

I will of course monitor the situation to see if anything changes. My current living situation (very small apartment) means I have to stick to the ‘space saving’ Bluesound speakers so unfortunately I will have to pause using Roon for a while and revert to the more stable Airplay 2 / Spotify etc. At least for a while.

Sorry for the multitude of emails, I hope the input can be helpful for Roon going forward.

Best
Yiannis

Hi @Yiannis_Kouropalatis,

Thank you for the update here and for clarifying the different delay types and for testing the additional Soundbar 2i. I have updated your internal ticket with this information and have passed this ticket over to the technical team for closer inspection. I will be sure to let you know once I have any further information to share. I appreciate your patience in the meantime, thanks!

Hi Noris, I wanted to provide an update on the situation I reported a while back. I am still using the bluesound Flex 2i (Wireless, excellent signal strength) and the Bluesound Soundbar 2i (ethernet adapter wired). I initially reported some significant problems when running the Roon Core on my Windows 10 PC. We tried a few things as per your suggestinons but we could not find a cause. I subsequently moved the Roon Core to my macbook pro 13 and the situation improved. I still got the truncation problem Bluesound Playback Truncation Problem but the situation was greatly improved.
I will soon have to move the macbook pro to a different location so I tried migrating the Roon Core back to the windows PC. Unfortuantely the problems returned and some new issues also appeared. The delays, freezes etc are back as initially reported. In addition to these I am also now encountering the problem where playback becomes ‘stuck’ at the end of tracks as reported here: What causes a track to get "stuck" at the end? and here: Roon Radio hangs at last second of a track. In my case this happens almost once every 3 or 4 tracks.
In addition to that, I find that I occasionally initiate playback with the Flex 2i and the soundbar 2i as a grouped zone. While roon shows playback has started, I only hear sound from the soundbar. I have to stop and start playback once or twice in order to get both to play music.

As in the original tests, the PC is located at the same spot as the macbook pro and they both have excellent wireless connection (speedtest confirmed) to the router 10 ft away.

Returning the core to the macbook pro partially improves the situation (although some problems remain as reported above) but unfortunately I will soon have to move the macbook pro elsewhere. Roon is unfortunately effectively unusable with the Windows 10 PC.

I fully appreciate this is a difficult set of issues to diagnose and rectify. Probably too many variables at play, especially with the super buggy bluesound devices in the picture. I am realistic and I do not anticipate a resolution but I still wanted to provide an update that may perhaps be helpful to Roon in the long term.

All the best
yiannis

1 Like

Not sure if you use the computer for other tasks, but, there maybe some weird software interaction happening with Roon and another softawre or driver. For example, Realtek drivers can cause issues. I always remove them and us the basic MS HD Audio driver if I need to on a PC.

1 Like

That may indeed play a role in the issues I encounter. I have also been using the macbook pro for other tasks (stats analysis, excel, email, etc) alongside the Roon Core without issues. Both machines are loaded with multiple work apps, multimedia apps etc. This does not say much though other than raising the suspicion of Windows 10 being bad :stuck_out_tongue:

It is very interesting that the Win 10 PC (with Roon Core on it) works perfectly with my Allo Digi streamers. All problems happen when the Bluesound devices are introduced.

Hi @Yiannis_Kouropalatis,

Thanks for the update here!

Looks like we were able to reproduce this and the report has been send to Bluesound.

Can you let me know the exact local time + date + track this behavior occurs next on? After, can you please send the Roon logs + Bluesound logs after you have done before? I’d like to add these to the investigation ticket.

Timestamps + Roon logs + Bluesound logs are appreciated for this issue as well, and I can forward them to the hardware team for closer inspection.

Thanks!

Hi Noris
Thank you very much for getting back to me. I know you are looking into this and communicating with Bluesound as things progress. I am currently travelling with work and will be away for a while so I am able to take advantage of the Macbook pro as the home for my Roon Core :-). It may be a while before I get back to my PC but I will update then. In the meantime I am enjoying hassle free operation with Roon Core residing on the Mac :slight_smile:
Cheers

1 Like

Hi @Yiannis_Kouropalatis,

No worries. Whenever you are ready to pick this up again please just let me know the information I requested above. Thanks!