Build 165: No sound using DoP [Fix in progress]

I just updated roon to build 165 from 161 on Win10 64bit. When playing DSD64 and DSD128 using DoP, I get no sound and both my DACs. They are reporting sample rates of 176.4 kHz and 352.8 kHz for DSD64 and DSD128, respectively. When rolling back to 161, everything works as expected!

I am having the same problem. In addition, Roon to HQ player is not playing any music.

I am having the same issue with my Benchmark DAC2 HGC and DoP drivers. The only way to play DSD albums is to convert to PCM 176.4. I also verified that the DSD files play perfect in JRivers at DSD resolution. This occurred as soon as the system updated to Build 165. What the heck?

This is a pretty huge issue, so hoping that Roon jumps on this right away. I have over 100 DSD albums that only play being converted to PCM at this point. I am hoping for an update quickly :slight_smile:. I really prefer to not have to resort to using JRiver again… love my Roon…

We’re looking into it guys, stand by.

Thank you very much! If I can give any feedback or test anything for you please let me know.

I’m not having any issues here, playing via HQP or direct using DoP. I’m testing with DSD64 content on Windows.

Can you guys give me full details of your setup, along with the audio settings screenshots at the end of that post?

Sure, I have Benchmark DAC2 HGC as my pre-amplifier/DAC/Headphone amp. A SST Son Of Ampzilla II amplifier, Marantz SA8005 spinner, McIntosh MR85 tuner, MC RL21 speakers, REL Sub, Sennheiser HD800 S headphones, Wyred 4 Sound Recovery on the USB path, Wyred 4 Sound Remedy on the Coax path, an assortment of decent cabling, Wireworld, Audioquest, Tributaries, Richard Gray, Kimber Kable, etc., Furman power Conditioner. PS Audio Noise Harvesters.

The Music Server is a modified Falcon Northwest Tiki. I removed the video cards, removed all unused services, etc. I use it as a Roon headless server and use my Laptop to remote desktop in for any type of maintenance, upgrades, etc. I use a Microsoft Surface Pro 3 as the Roon controller. I also have JRiver installed on the server for testing purposes (like this one). All machines are running Windows 10 Professional 64 bit, latest patch and upgrades.

The Tiki is an i7 CPU, with 16 GB RAM, A Crucial 512 GB SSD, Gold Standard Power Supply, Close Loop Liquid Cooled, mounted on a granite base… I have hooked it up with both USB 2.0 and USB 3.0 ports, which make no difference.

The Benchmark drivers state they are native PCM and Native DSD through DoP. Up until the 165 build was installed yesterday all files played fine, both PCM (16 bit/44.1 thru 24 bit 192KHz) and DSD64. After yesterday’s upgrade ran DSD produced no sound but the LEDs on the front of the Benchmark indicated 176.4 KHz… but no bit depth LED lite up. If I changed to either Volume leveling or Convert to PCM the DSD albums played but at 176.4 KHz. The light on the Roon interface displays green, and when I click on it for details it indicates convert from DSD to PCM 352.8 KHz to PCM 176.4 KHz… Normal PCM play fine and display purple, unless I have volume leveling on and then they display green for the volume leveling.

Is this what you wanted to know?

BTW- I tried re-downloading and re-installing the Benchmark drivers and also reinstalled both Roon Server and Roon Controller software on their respective machines.

I tried again this morning and even tried using my Laptop as the Roon controller besides the Surface. Same things, DSD does not play through Roon DoP, but does play perfect through JRiver, using the same Benchmark DoP drivers.

I tried again and now everything is working fine. I had no luck yesterday, but now all seems good.

I still experience the same problems as yesterday. My setup is a win10 64bit computer, which is used for output, control, and storage of the music library on a RAID 0 of SSD:s. It is connected to an Exogal Comet DAC through a Paul Pang Audio v2 USB card and the DAC’s ASIO driver.

As described earlier, I get no sound when playing DSD files using DoP (converting to PCM works fine). Roon still displays a purple light, but the DAC driver shows 176.4 kHz sampling frequency when playing DSD64 and 352.8 kHz when playing DSD128. As before, Jriver MC 20 plays the same files without any problems.

@Randy_Myers @Fredrik_Rosenlind – could you provide us screenshots of your audio output settings, like the ones at the end of this post.


I currently have the DSD Playback Strategy set to Convert to PCM instead of DoP because it is the only way I can play a DSD file now. I even completely uninstalled Roon Server and Controller trying to load an older version but it updated to 165 before giving me control… soooo…

Just set it back to DoP so you can see the screenies… no sound from DSD files set as DoP like this. The drivers on the server display 176.4 KHz also just like Fredrik’s. Also the LED’s on the front of the Benchmark display have 44 and 4X on, but no bitrate on, and of course no sound. This definitely started with build 165. Played perfect as DSD with all prior builds.

I am certainly willing to give them some time to resolve, but honestly this type of thing makes me second guess my purchase of a lifetime sub. I mean, an update is supposed to improve things not completely eliminate a very important segment of capacity.

Frustrating, but willing to give the Roon team a chance to resolve the issue.

Our home setup is experiencing multiple ASIO conflicts. On one setup I use the Benchmark DAC 2 USB ASIO driver and I’m experiencing the same exact problem – no audio out during DSD64 only. The DAC does not sync to the DOP signal. I switched from the Benchmark ASIO to the WASAPI output and it fixed the problem.

On the other set up I use a RME RayDAT PCIe ASIO – after the update the RME ASIO experienced no sound output for all PCM file resolutions (No DSD hardware on this setup). Each one of my computers is set up as a zone. On the RME setup I switched from zone to system output and it worked – I switched back to the zone output and now all is good.

In my office I use an older Benchmark DAC1pre, which uses standard Windows WASAPI and this setup worked perfectly.

I have re-installed the Benchmark and RME drivers and rebooted each pc – the ASIO problem still exists.

I believe that WASAPI only does PCM, correct? Through the Benchmark drivers PCM is fine, however DSD64 does not play any sound and the Benchmark drivers see 176.4 PCM even though Roon is reporting that it is outputting DSD over DoP… hence no sound. This is an issue with build 165.

Which is another huge issue; no build roll back capability in case issues like this occur. Even re-installing does not work since the install automatically upgrades itself to build 165 before turning over control.

I am sorry, but Roon needs to address this immediately… it is an issue in their new build… and honestly, I am sorry that this is an issue over a holiday, however they released a new build right before a holiday weekend, soooo…

WASAPI can handle DSD over DoP with no problems. The Benchmark ASIO driver does not see the DSD64 signal - PCM via ASIO works fine on the Benchmark DAC 2.

I have 3 different ASIO set up’s and each are experiencing different issues. On the Benchmark set up the problem has to do with DSD64 playback. On the RME set up the mixer see can see the PCM signal, but the signal doesn’t make it to the PCIe card. I have another set up in the studio which uses Antelope Audio Pure2 ASIO driver which is also experiencing no PCM signal at the DAC via USB. WASAPI on each set up works fine.

Hmmm, I must be setting up WASAPI incorrect then. I do not seem to have that option. Let me experiment some more. If you would any chance of giving directions or maybe a screen shot of the setup please?

I did some experimenting and it looks to me like WASAPI on my system does only PCM, further more it appears as if it does not send the signal through the USB connection. Maybe it is because I am using Roon headless server and do not have the Roon client installed on the machine. I control Roon from either my Surface or my laptop. I just don’t see any option that works but the Benchmark ASIO drivers, which is honestly what I expect.

I assume that you downloaded the Benchmark DAC2 driver and installed on your computer. With that said, I also assume that you turned on the USB Class 2 setting by holding the USB button down on your remote for a few seconds until it switched over.

Now go into Roon settings > Audio > Here you should see a Benchmark WASAPI and a Benchmark ASIO output. Enable Benchmark WASAPI and go into the settings. Use standard buffer and disable everything. Now select DSD over DoP and save. Don’t forget to name the WASAPI output.

Next, at the bottom right of the screen switch the current zone to the new WASAPI zone, and that should do it.