Build 218: Transport: Failed to select Roon as the current source [Krell Vanguard Digital]

I have a Krell Vanguard Digital. Until last week worked excellent with Roon. Today I connect the unit and tried to use it as normal. Roon updated and after that is impossible to use it. First the Zone icon changed (now is drawing of Krell unit) but when I try to play music the system answer “Transport: Failed to select Roon as the current source,” Krell Unit is network connected to a Mac Mini that works as the core.

@support tagged support for you on this…just to get picked up. And a Subject edit :smiley:

1 Like

Hi @Roberto_Montanelli ---- Thank you for the report and sharing your feedback with us. To help me better evaluate this behavior you are experiencing, may I kindly ask you to please provide me with the following:

  1. A brief but accurate description of your current setup as seen here.

  2. Please describe your network configuration/topology as well as providing insight into any networking hardware you may be implementing. I want to have a clear understanding as to how your devices are communicating and what tools you are using to make those connections possible.


Eric, thank you very much for your answer:
Roon version 1.3 (build 218) stable (64bit)
Software Serial: FA779C0C-C0D3-4D2D-8EF9-CA6DCDB4FF39
Operating System: Mac OS Sierra 10.12.4
Mac Mini (Late 2014) working as Roon Core
Processor 2,8 GHz Intel Core i5
Memory 8 GB 1600 MHz DDR3
Graphics Intel Iris 1536 MB
Music storage in the internal 2 TB flash hard-drive. All music in the same folder “Music”
Number of tracks: 8000
Using Tidal
Krell connected via net work to an Airport Extreme, the same that the Mac Mini.

Yesterday after sending the topic I tried to restart the mac and continue to fail. Then I shat down until nos, and after booting all the system started to work well, as always did. I think there was a problem during the installation of the new release. If something wrong appear again I will contact you immediately

Best regards


This Krell product does not support convenience switching (automatic switching of the input at the start of playback).

It’s necessary to switch the source to “network” manually using the IR remote or front panel. If you try to start playback from Roon while any other source is selected, that error message is displayed.

We did add the artwork in a recent release, but there were no other changes on our side that could have caused this problem–I suspect that the difference between the two times that you tested is that in the second test “network” was selected.

1 Like

Today I have the same problem. I started both Krell and Mac Mini and it’s impossible to play back. The same message appear. Before starting de Mac I put Krell in Network source. This did’t happen in the past. Something wrong is happing since I updated the software to build 218 version. Please I need to solve this!!!

Thanks in advance!!!


As far as I know, there weren’t any changes in 218 that should’ve affected this. But, we’re going to check :slight_smile:

We’ll do some testing on the Digital Vanguard we have and let you know if we do find an issue here.

In the meantime, have you discussed this issue with Krell at all? They may have some insight into whether others have reported any issues, or if there are any configuration changes or firmware updates needed. Please let us know what the have to say about this issue and we’ll let you know what we find in our testing soon.


Hey @Roberto_Montanelli,

We plugged in the Vanguard, paired it with a Mac running build 218, and everything appears to be working. We tried doing what you suggested: putting it to NET/USB before starting Roon on a Mac, and also some other re-orderings of things in case something about startup order made a difference. Nothing really came up.

The message you’re seeing means that Roon requested that the device switch inputs and the device said “no”. There’s really no way for that message to result from a problem in Roon, since it’s a direct reflection of the device’s response.

In all of our testing, that message was shown when the device had any input selected other than “NET/USB”, but if “NET/USB” was selected, playback always succeeded.

Just to make sure we’re looking at the same thing, can you make sure that your Digital Vanguard is fully up to date?

We are seeing version V 1.17 Mar 7 2017 as the latest.

(You can access the software version by pressing the topmost Menu button on the remote until it displays “Software Version” then pressing the Enter button on the remote.)

Since the nature of the failure points towards an issue inside of the device, our role in handling this issue is to help make a stronger issue report to Krell’s engineering team and to assist them with testing/validating anything they do to fix the issue–but we cannot do that with confidence if the issue isn’t happening for us here.

Do you have any idea what else we might need to do to see this fail on our unit here?

1 Like

A post was split to a new topic: Krell Vanguard - No selecting Roon as the source