Build 943 crashes when accessing the settings menu [Solved: Update to Build 970]

Hi @Randy_Myers,

Thank you for reporting this issue, and I’m sorry you’re experiencing a crash as well. The tech support team is investigating, and I’ll report back with next steps as soon as we have more information. I appreciate your patience in the meantime.


@connor, I got home, fired up the remote on my Macbook and the crash went away on its own :slight_smile:

Fingers crossed it stays this way.


Is there a roll back option?

Unfortunately no, there is no rollback option.

Also experiencing a similar issue using my Amazon Fire tablet as a remote.

Since Build 943 the roon app, on my Amazon Fire HD 10 tablet, freezes whenever I attempt to access “Settings” from the drop-down menu. Have to perform a forced restart of the tablet in order to regain control over it.

1 Like

That is too bad, because issues like this do occasionally occur. Roon techs are usually on top of it, but it would be nice to be able to roll back until the issue is actually resolved.

Hi @jb76,

Thank you for reporting this as well. I appreciate your patience as we pin down the problem, and we should have more information shortly.

1 Like

Same for me. Crash when I click on the settings only on the machine where the core is running (on windows 10 enterprise LTSC version 1809). On the other endpoints (android and win10 home all updated to 943) I can enter the settings normally

So far this seems to be working. Thanks.

1 Like

Unfortunately, that suggestion did not fix my issue with the settings menu button.

same problem here … Any update when the issue will be fixed?

I upgraded ROCK today and the client on my old MacBook Pro (2013 I think) running Big Sur. Trying to access Settings just closed the app with no error message. Tried it a few times then rebooted the Mac, but this made no difference.
Tried it again a few hours later and the problem seems to have disappeared.

I needed to access Setting because updating one of my RoPieee endpoints caused it to disappear from Roon. It needed reenabling to be visible. Not looking forward to doing the other five tomorrow.

That’s exactly my experience. Except that in my case the 2013 MacBook Pro running Big Sur didn’t show the problem, but the 2012 iMac running Catalina. And yes, if Roon app keeps running for 10-15 minutes, the problem goes away. I experienced the same problem for a second time yesterday, after a power outage which took both my Roon Core server and the iMac off the grid without proper shutdown. When recovering from the outage and turning back on the apps, Roon on the iMac crashed once again on trying to access the ‘Settings’ menu. And once again the problem went away after 10-15 minutes…

But if I simply close Roon app on the running iMac and then open the app again, the problem doesn’t manifest itself. Weird…

Edit: If closing Roon app on the affected Mac for a long period (over night), the problem returns when opening the app again next morning. But, as before, after some time it goes away.

BTW, I am looking forward not only to a fix for this problem, but rather an explanation of what was at fault… out of sheer curiosity…

For a solution approach, one more observation:

Under Manjaro, my Wine GUI also crashes under certain conditions.

  1. i use a large database
  2. the Linux server is in autostart.
  3. the Wine GUI is started before the server has read and completed everything.

After 10 or 15 minutes, the problem no longer occurs.

During the startup phase, something seems to overlap and interfere with each other. Of course, this is only noticed by every customer who also always restarts.

If I start the Wine GUI before the server, the crash problem does not occur either.

1 Like

It crashes when clicking on settings here also after the update? :frowning: .My controller is a Microsoft Surface running Windows 11.
It was all fine before this update.

I have the same issue. Clicking settings on the core machine (via remote desktop as that machine is tucked away with just a power cord and ethernet cable) crashes Roon.

If i click settings on my iPad the app crashes but not the core server.

It doesn’t crash on my iPhone or using the client app on my Windows 10 workstation.

A bit busy with work at the moment but if the problem persists I can dig into logs later on.

I’m lucky enough to have plenty of hardware to acess Roon but if I’d been limited to just the core and my iPad it would have been a huge issue.

I see others have mentioned Ropieee in this thread and I just added two of those having none before. No idea if it’s related just thought I’d add it as a data point for the devs looking into this,

1 Like

Hi everyone,

Thank you for your patience so far on this issue. While we don’t have a comprehensive resolution, I’m writing to update that we’re working diligently with QA to isolate the problem and we will provide more information in this thread as it becomes available.

If you are continuing to experience a fatal crash on accessing Settings, a troubleshooting step you can try in the meantime is to clear your GMS files. The crash appears to be related to graphical elements, so this will reset the interface portion of Roon. Please follow the steps below:

  • Exit out of Roon\RoonServer on the affected device
  • Navigate to your Database Location\Database\Registry\Client folder path
  • Locate and delete any file that starts with GMS
  • Start Roon again and let us know if the issue is resolved

Clearing GMS has resolved the issue for many users. If it doesn’t change the behavior on your device, please stay tuned for now, and we will provide another update shortly.

1 Like

Deleting the files starting with GMS doesn’t fix the issue on my iPad Pro.

Same here on WIN10 server with parallel full app install, no matter if deleting GMS*.* in Roon and/or RoonServer folders.

Does not help… this issue has gone on too long. Either resolve it or rollback. I had no issues prior to this update.