Can’t get tidal to work

I get the error transport has too many failures and stop playback.i use a Mirus signature pro dac running fire ware 7. I have tried a device options to usb ASIO to no avail. I usb usb to dac. I can see tidal music albums but get brief message album not on tidal no matter what I select
All help appricated telephone support to [phone number removed by moderator] would fix problem quickly
Jd cantrell

Hi JD,

I’ve removed your number for privacy. @support will be by shortly to help.

Cheers, Greg

Hello @anon50788512,

Thanks for contacting support regarding this issue. We do not do telephone support so I kindly ask for you to work with us on the issue on our Community site here.

Can you please provide some more information regarding your setup using this thread as a guide?

Specifically, please let me know:

  • What Core you are using
  • Have you tried rebooting both the Core and the DAC yet?
  • If this issue only affects the Mirus zone (as in does “System Output” play as expected)?
  • Have you tired another USB cable for the connection?
  • Does this issue only affect TIDAL content or is Local Content displaying this issue as well?

Please let me know your reply to my questions when possible and we can continue from there.


Most recent software and. I have rebooted many times I have tried all device setup options with reboot after each change.roon and dac work perfectly with local content. Usb cable just fine.

Thanks for letting me know @anon50788512,

A few other follow up questions:

  • Can you please confirm what Core you have (OSX/Windows/Linux)?
  • How is your Core connected to the network?
  • What is your router model/manufacturer? Sometimes specific types of routers require special settings applied as per our Networking Best Practices Guide.
  • Is the Core connected directly to the Router or is it using WiFi?
  • Do you know how to access your router’s configuration page?

Please let me know this info when possible.


Running windows 10

Roon remote on iPad works just fine.i have a Sonos boster on network

In my experience, poor WiFi signal (whether intermittent or chronic) can cause this.

I have learned how to get into my rounter
Douglas all connection are cat five except iPad

Hello @anon50788512,

Thank you for providing that information. We have seen users have a better TIDAL experience in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps? Also, can you please confirm the exact model/manufacturer of your router and modem?


A post was merged into an existing topic: Roon starts but struck at logo screen