Cannot connect to Tidal subscription anymore, please help

Roon Core Machine

ROCK, latest update.

Networking Gear & Setup Details

Wired ethernet, Ubiquity switch.

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I cannot conect to my Tidal subscription anymore.

When, via Settings > Services, I press the login button and the browser opens for the login of Tidal. After succesful login the system does not go back to Roon. When manually going back to Roon it is still not logged in to Tidal.

Please help.
Jan R. Smit

Have you done basic troubleshooting like rebooting everything from the network outward?

Hi, yes. Rebooted rock. No avail. Reinstalled rock os, no avail.
Do not know how to reinstall Roon , but it is latest version, version 1.8 (build 988) stable.
Tried from different clients( W10, W11,Android), no avail.
Double checked firewall no messages related.
Network wise all fine.
When i do successful login in Tidal in browser it tries to go to the Roon client, as the Roon client goes gray, but stops there.

Two days ago it worked fine.

Saw a warning in the windows client that Roon was unable to connect to the Roon servers for metadata updates.
But when updating the rock os it connected to Roon servers apparently.

Is there a log file in Rock i can access somehow?

Have you rebooted everything including the network?

Yes including the network firewall. I will reboot the switch , just in case.

The reboot of the switch did not resolve the issue.

Yes there is - the TIDAL cache in Roon.

Instructions on how to clear the cache here.

Hope this helps.

The info in the link does not match the folder structure in my rock. Nevertheless I found a log file and there is the process to feed the tidal login to Roon that does not work somehow . It gets a time out.
Will upload the log file when i am back behind a windows pc.

From the messages in the browser and from the roonserver log it appears to be something with “” as it times out. So the feedback into /oon of the successfull login into Tidal fails.

(apparently i cannot upload the logfile, so i made a screencopy of a part)
My knowledge of unix is very rusty, so this is as far as i can get on this. So please help .

Going deeper into the logfile i found this:

looking in the raatserver log i find this:

If a cache needs to be cleared, which cache?
The roonserver cache?

I uploaded the log files of both raat and roonserver of the last 2 days(July 12, 13) , using the upload link provided, name: JAN-R-SMIT-roon-logs
Note that for the roonserver logs there is one of July-11, which to me appears to show a correct functioning.
Hope this helps to solve the problem, want to listen to music again :wink:

Hi @Jan_R_Smit ,

It looks like you are getting timeouts when connecting to our account servers as well as the TIDAL errors. What is your ISP provider, do you by any chance have Xfinity or another ISP that has modem-based filtering? If you try to temporarily host Roon Core on another PC, do you see issues with logging in there?

The ISP is Ziggo(UPC).
Normally they do not filter.
My firewall is an OpnSense business edition, with real time inline packet checking.

But i do not find any relevant data in logs about blocking. Nor is a change done between 11 and 12 July as far as i can see.
I did an update of the firewall on July 12 afternoon. Did not give a solution.

Is there a particular item to check on? A function name or something i can use to search with?

How do i get Roon core active temporarily?
No problem to use a W10 computer as tested.

to temporarely install roon server on another computer i created an Roon account with different name and email address. To create a trial subscription i need also te enter payment details.
Whilsth in this process, my wife said she could not get into roon anymore. I tried to get her Roon remote to connect to our regular roon. Weirdly it ask to log in, so i use the login of regular account. After a minute it comes with message “cannot connect please check network”. So for some unclear reason my regular roon server (Rock) cannot be used at all.
This is getting very weird!!!
Please help