Cannot delete an album with missing track files

QNAP version 1.7 (build 667)

I ripped an album, then realised I had the wrong album artist and ripped it again. Going into Roon to check it had identified the album correctly, I realise I now had all the tracks duplicated under the same album - so deleted the erroneous 12 duplicate tracks (on the QNAP). But Roon still showed 24 listed under the album, despite rescanning and restarting Roon. So I deleted the album folder and files entirely (on the QNAP). But Roon still lists the album and, when I try to delete it in Roon, it can’t find any of the tracks so refuses to delete. I tried putting the album back on the QNAP (with the 12 correct tracks), but when I try to delete on Roon it still lists 24 tracks and says it can’t find any of them.

I behaves the same when trying with my PC and with my ipad so assume the problem is with the core rather than remote.

How do I get rid of this album and start again?

Have you tried settings > library > clean up library?
Does it show a number of deleted files to clean up? If so, do so.

If that doesn’t work straightaway, try moving your files off the NAS, rescan, clean up, then put them back and rescan again.

I did have deleted files to clean up, but having done so, the album is still there (with the no files on the NAS). So I restarted Roon, rescanned the album and clean up shows no files to delete. I cleaned up anyway and restarted Roon but the album still shows and when I try to delete it I get the same message that it cannot find the 24 tracks (and after that clean up still says 0 deleted files).

Does that mean you removed the files off your NAS, then did the rescan/clean etc. before adding them back?

If you pick a track and 3 dots edit > view file info, does the file path point to an invalid location?

That’s what I have done in the past.

I’m out of ideas; the professionals will be along in due course, although it is a weekend.

I’ve kept the files off my NAS. They were off for all of the clean up, rescan and restart processes.

View file info gives “No info - Track not in your library”

You can hide albums, not the ideal solution .

Yes, thanks, I’d thought of that as a last resort. But this is a bug, surely? And how do I get to play the correct replacement files?
In addition, Roon is no longer updating when I add a new album on the NAS. It’s been a couple of hours now and the new album still isn’t showing in recent activity. I guess there’s a connection?

When you select settings > storage > 3 dots > force rescan do you see the number of tracks imported steadily rise to the final number?

depends how many hours you have set rescan to.
options are 1,2,4,8,12 or 24 hours.
I have mine at 1 hour

Ok - update.

  1. I restarted my NAS again and the new albums were added and I could delete the faulty album in Roon - so my first problem is now sorted.
  2. Imported files always used to show up immediately in Roon after a refresh or change of view. In Storage - Settings I have “Watching for new files in real time”. But this still isn’t working - when I copy a new album onto the NAS it isn’t getting picked up by Roon.
  3. Force rescan does work.

So my basic problem now is that new files are not being picked up without a forced rescan.

Unfortunately, that’s a known problem with NASs. Roon can’t do anything about it.

Hi @Mark_Bowell,

Where are the media files stored and what is the Core in this case? Did automatic scanning work in the past and this is a new issue? Is the QNAP the Core and the files are on the QNAP itself?

As @BrianW mentioned, if you have another Core and the QNAP is just a storage device, this is expected behavior. If you are using locally attached storage and the QNAP is the Core, please do let me know.

The core is on the QNAP, the same as the music files. It used to update instantly and has changed recently.

1 Like

Ahh, then ignore my post above. Sorry.

1 Like

Hi @Mark_Bowell,

Thanks for confirming this is local storage, can you please let me know:

  1. What is the model of the QNAP?
  2. What is the size of your collection (how many tracks)?
  3. Can you please use these instructions to send me a log set from the QNAP?

My QNAP is a TS-253 Pro. I just downloaded another firmware update today ( but it hasn’t solved the problem.
Roon says I have 30289 tracks.
I have the log zip file and have sent you a message asking how best to get it to you.
Many thanks

1 Like

Hi @Mark_Bowell,

Thanks for those additional details!

Do you have Dropbox / Google Drive / ect?

Can you please upload the logs and share the folder to me via private message (click my name -> message)?

I already sent a message yesterday but have sent a second today.

Many thanks


1 Like

Log file uploaded.

1 Like

Thanks for the logs @Mark_Bowell, I have forwarded them to our QA team. We are aware of a few reports of this behavior and we’re looking into them, while our investigation is in progress, please use a force rescan when you add new content.