Can't Connect Remotes ASUS RT-AC3200

Remotes cannot connect when using my ASUS router, but will with Verizon Router. Remotes can see core, but keeps cycling trying and failing to connect. I tried turning off all firewalls, AI protection and turned on multicast routing per your doc.

If both routers are being used at the same time, the Asus router needs to be turned into WiFi access point mode (with DHCP disabled). - This is not applicable if you meant you use the Asus router to replace the Verizon router entirely (removed).

Right, the ASUS router replaces the Verizon router. Tested with the Verizon router just to prove it was a router problem and not a Core or Mac problem.

Both Bluesound and Sonos remotes work with ASUS, and the core works controlling and streaming to Sonos and Bluesound on the ASUS network. Just remotes, iPhones, iPads, a PC don’t work. Again, they can see the active Core but cycle trying to connect and failing.

@Martin_Brunswick - Thanks for contacting us regarding this issue, what kind of Core are you running, Windows/OSX or Linux?

If you are running Windows, please check to see Roon is listed as an exception iwn Windows Firewall:

I also found a similar thread where the firewall was set to ‘Public’ and that caused issues, I would check to make sure that this is not the same here:

If you are running OSX please check to see that Roon is listed as an exception using this guide:

Please let me know if that helps.


I’m beginning to become frustrated. As stated in earlier posts, I have tested with multiple routers (As stated above, with my Mac OSX Core) and remotes connect perfectly if I swap in the Verizon router. Thereby ruling out the problem being with the Mac or Core machine. (hence my frustration with the latest response) When using the ASUS router, even with all router firewall turned off and AI/Network Protection turned off and parental controls turned off. Again, as stated above, the remotes can see the core but cycle trying and failing to connect. I have no such problems connecting Sonos remotes to Sonos, or Bluesound remotes to blue sounds, or Apple remote app to Apple TVs, all on the same network.

In Asus router, enable Multicast Routing.

Multicast is turned on.

Hello @Martin_Brunswick,

Thanks fro confirming that for us. A few other suggestions here:

  • Do you have accept connections from Remote turned on for your Core?

  • Are you making any use of switches/range extenders/powerline adapters anywhere in your setup here?

  • Have you tried force exiting the Roon app and then opening again, is there any change if you try that?

  • Are you able to ping the Core from your Remote Device successfully? You can use an app similar to FING to give this a try.

  • How is your Core connected to the Asus Router? If you are connecting via WiFi is the behavior the same when using Ethernet?

  • Is the Asus router using the newest firmware? You can check this under Driver & Tools -> BIOS & Firmware on the Asus site

  • What is your IGMP Snooping and IGMP Proxying settings? Can you try to enable IGMP Proxying and then verify if the behavior is the same with IGMP Snooping turned off or turned on? You can use this manual as a guide for this test.

Please let me know if any of my suggestions help.


  • Accept Connections from remotes is turned on (and as evidenced by my ability to connect with other router)

  • The ASUS router is configured as THE ONLY access point and not an extender, but is ethernet connected to the Verizon router that has all wireless capabilities shut down. Everything is connected through the ASUS, all music devices SONOs, Bluesound, all computers. The Verizon is only there because somehow the TV needs it.

  • Fing can shows the MacBook Pro ONLY WHEN ROON IS RUNNING. When I shut Roon down, FING does not show that the Mac is on line. This is the same wired or wireless.

  • Per other sites, confirmed that newest firmware installed on ASUS router

*Per the manual, IGMP proxying is turned on. No change with IGMP snooping on or off.

—going to try bypassing the Verizon router completely as a test.

That fixed it… that point to the router jump but since I sort of need that for other systems, how might I solve this issue?

@Martin_Brunswick – Let’s take a step back here a second. You mentioned that with the Verizon router completely out of the equation everything works as expected? And that nothing is being connected to it via WiFi nor Ethernet?

It seems to me like something is being connect to it, either the remotes are connecting via WiFi to Verizon or the Core is connecting to Verizon or the Verizon router is causing multicast on your Asus router to go on the fritz. You mention that you are making use of the TV via the Verizon router, IPTV makes use of multicast to operate as well.

Since you have been connecting this setup as Verizon router -> Asus router -> Endpoints and it has not been working, is the behavior the same if you connect it as Asus -> Verizon router & Asus -> Endpoints? You mentioned that the WiFi for the Verizon router has been turned off, but have you also turned off the DHCP Addressing on the Verizon router? If the Verizon router is creating it’s own set of IP addresses through DHCP this could be the reason why you are unable to connect your remotes and I would leave the Asus router as the primary DHCP addresser and have the Verizon router in access point mode with DHCP turned off.

Please let me know your thoughts on my suggestions.