Can't connect to ROCK from Windows PC or Android

I have the same issue since the update. The installation ran smoothly. The Library update was a bit longer but I waited.
Neither my Windows PC nor my Android tablet was able to connect to the core (Rock/NUC). In the Rock Web frontend you can see that the Roonserver permanently reboots every 10 seconds. Rock itself runs stable .
Yesterday everything worked again after repeated reboots, today I tried everything including reinstalling the Rock and Roon software without success…
I uploaded the Logfiles to Google drive:

Hi @Jurgen_Konig,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

I’ve also passed the log files along to the team so they can take a look.


Hi @Jurgen_Konig,

The team has asked that I enable diagnostics on your account as well. I’ve done so now, so the next time you reboot your ROCK Core the diagnostics report should upload to our servers. Please reboot and let us know once you’ve done so.


here is my setup:
OS: ROCK Version 1.0 (build 183) stable
HW: NUC 7i5BNH, Crucial MX500 SSD 1TB for OS and Library
LAN, WIFI (for Roon Remote)
Mytek Brooklyn DAC+
PC (Roon, Version 1.7 (build 500)): Windows 7 64Bit i5 CPU (LAN)
Android-Tablet (Roon , Version 1.7 (build 500), Huawei MediaPad M5 (Wifi, same SSID as ROCK)
LAN/Wifi: connection good and stable
Yesterday as my last attempt I reset database and settings (lost some playlists)
I configured Roon and everything worked fine!
As it was late, I stopped Roon before the library scan was finished (30000 items) and shutdown my PC and the Rock/NUC.
Today I start Rock and Roon and have in the same problem as before the database-reset.
Best regards

I have to add my network configuration .
Router: Fritz!box 7490
The NUC is directly connected to the router via LAN.
PC and SMS-200 are connected to a TP-Link SG105E switch which is connected to the router, all via LAN. The tablet is connected to the router via Wifi.
However, I doubt it is network issue. My Network works fine including my Roon devices (before update).
Best regards

Hi @Jurgen_Konig,

Looking at the latest diagnostics report, things seem to have been working for a while – You also mentioned that things were working for a while. Are they working currently, or are you still seeing this?

Hi @Dylan,

that’s right. I restarted Roon via the web UI three hours ago, since then Roon is running permanently.
The library scan is finished meanwhile . Let’s see what happens tomorrow.
Best regards

Same situation today, it’s really annoying…

Hi @Dylan,
Roonserver runs again, after 2-3 hours. During this time I made several reboots, without immediate success. Now OS runs since about 90 Minutes, Roonserver since about 30 Minutes.
I hope I do not always have to wait an hour until I can hear my music…

Hi @Jurgen_Konig,

I’m glad to hear that things are up and running now. If you see this issue return please let us know!

Hi @Dylan,
I did not turn off my NUC overnight. When I started Roon on my PC tonight, Roon immediately connected to the Core and everything went steady for several hours.
Then I made a reboot and the old bug came up again:
Roonserver rebooted every 10-20 seconds; after about 40 minutes it ran stable again. After that, Roon could connect to the Core.

Hi @Dylan,
I just want to say that the last update (build 505) did not bring any improvement.

Hi @Jurgen_Konig,

I think the next step here is to enable some diagnostics on your account once more so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which you reboot, the time that you start back up, and the time that you’re able to finally connect. Then respond here with those times, and I’ll make sure we review the diagnostics related to that timestamp.

Try not shutting the nuc down and see if it makes any difference.

The issue:
When I boot up or reboot the NUC, the OS runs steady immediately. The Roonserver however, restarts first every 10-20 seconds. After 1-2 hours it runs stable and you can remotely connect to the Core. From then on, however, the connection keeps stable without interruptions.
This morning I started the NUC. According to system status, ROCK-OS was stable from 5:19 AM (GMT) RoonServer more than 2 hours later (exactly from 07:38:26 GMT).
I hope it helps.

Hi @Dylan,
I have just restarted the NUC.
ROCK OS has been running since 5:47 pm (GMT).

Thanks, @Jurgen_Konig.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi @Dylan,
the Core has been running continuously since yesterday.
Do I have to restart it, so that the diagnostics will transmitted?

Hi @Jurgen_Konig – Apologies for the delay. The diagnostics report was received and I’ll be meeting with the technical team soon to discuss their findings. Thanks!

Hi @Jurgen_Konig,

I spoke with the team about this. When you’re unable to connect something is causing Roon to go into a loop where it continually crashes. Unfortunately we can’t learn much while Roon is up and running correctly like it is now.

The next time you experience this issue where the remotes can’t connect please flag @support here and we will have the technical team run some advanced diagnostics at that time.