Can't mount shared disks on a Apple Airport Extreme [AFP Mount]

Hi Gentleman,

Can’t access shared folders on an Apple Airport Extreme. Folders are shared using SMB… Would you be so kind as to shed some light on the subject ?

Thank you so much.


Miguel Escada

Just to be clear, do you have a USB hard drive attached to the Airport Extreme that you’re trying to share the folders from?

Yes, I do…

Hi Miguel,

Could you provide some system details as per this post. That will help the support devs investigate.

Are you using a Mac and have recently upgraded to Sierra ? There is a known SMB issue with Sierra which is getting fixed in the next Roon bugfix release.

Sure thing :slight_smile:
there you go…

WD mybook 3T USB
_FYI the same HD worked connected to my MAC PRO (MACOSX 10.6.8) via Firewire and using SMB and accessed via Wi-Fi using the same Airport Extreme ver. 7.7.7

ROON version 1.2 (build 157) stable (64bit)

The core machine…

Mac OSX 10.11.6
Model Name: MacBook Pro
Model Identifier: MacBookPro6,2
Processor Name: Intel Core i7
Processor Speed: 2.66 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 4 GB

around 5000 tracks

Hope it helps, let me know if you would need some more info

This will fix it until the update.

Actually @stevev1, he’s running 10.11.6 which is El Capitan.

Cheers, Greg


_FYI the same HD worked connected to my MAC PRO (MACOSX 10.6.8) via Firewire and using SMB and accessed via Wi-Fi using the same Airport Extreme ver. 7.7.7

My MacBook Pro is always the core for ROON.

Is it possible that the AirPort Extreme basestation assigns a different share name for the connected USB disk?
Can you connect to it with the Finder? If so, you should be able to see the proper share name in a window after entering your credentials.

Or if there is just one share available and it is mounted automatically you can also see the name under the share icon:

Yes I can access it with the finder.

And again: the same HD / folder connected to other computer (Mac Pro running OS 10.6.8) its easily accessed with Roon

So I really don’t understand whats the problem :frowning:

Could you post the smb-line which you have added at the storage settings of Roon to add the AirPort extreme usb disk to the watched folder?

Sorry to take so long to reply…

I guess this is what you requested, thanks

/Volumes/Mescada 3T FW/MUSICA/Musica Joel

It looks to me as if you’ve mounted the drive using AFP.

Go to Finder > Go > Connect to Server > Browse and see if you can mount the drive as SMB.

You may want to unmount the current AFP drive first.

As dpstijp already wrote, it seems that you are trying to make it work by an afp-share.
Roon has a dedicated window to add a smb-share. You need to use this window.
You AirPort file sharing authentications needs to be set to use “User accounts”.

In Roon you need to add this share like

smb://IP.of.your.AirPort/Mescada 3T FW/MUSICA/Musica Joel
Username: The username your created in the Airport admin panel
Pass: The corresponding password

Yes !

Thank you so much to you all for the assistance :slight_smile:

I wish you a good day.

Best regards,

Miguel Escada