Chromecast Devices can no longer be enabled in Roon

Hi Hans.
I have a similar problem.
HiRes Sony SRS-X99 speakers stopped connecting in Cromecast mode. At first I just wrote to reconnect the device. After, as if it does not respond to the connect button. Moreover, Roon sees acoustics as Cromecast and Airplay. And how Airplay connects and plays fine. But what happened to cromecastom? And at the beginning of September everything worked fine. Maybe something has been updated? Checked the old version of google crome (didn’t help). In acoustics, the software was not updated (I have several of them with different PCs) and everywhere, there is one problem. Maybe someone will help with advice. Sorry for the bad english.

Hey @PVAS_Roonin,

Thanks so much for chiming in and sharing you’re experiencing a similar behavior with Roon as Hans.

Could you please use this post as a guide to share details about your setup?

Also, do you by any chance have any other Chromecast devices you could test with?

Hi Rebeka. I do not speak English, but I will try to describe the problem I faced.
Everything worked fine for me until about September 2021.
I use Roon v1.6 and acoustics Sony SRS-X99 in Cromecast mode, and HiRes NAS library in FLAC format up to 24b 192k. The WiFi signal goes through a 2.4 / 5 GHz dual band router. Everything was fine with me.
But something happened. I turn on the system on 10/03/2021 and there are no SRS-X99 zones. However, it is still on. After a while, he writes like “reconnect the device”, I disconnect it and it does not connect anymore. At the same time, Roon sees acoustics even in dual mode (two devices with the same IP). So it was before. Namely, one as an AirPlay device, the other as a Cromecast. At the same time, Airplay connects and plays as only 16 bits can. I don’t really like it. And how the Cromecast does not connect and does not write anything. If played as Airplay, then the sound will temporarily disappear when the Cromecast is connected.
What happened is not clear to me. I have more than one such systems (sets), and everywhere there is such a problem. Routers are different, the latest software in acoustics since 2017. All I can check is that Windows 7 has not been updated. During this time, only Skype, Crome were updated, but the latter I rolled back to version 93 (it did not help). Maybe have an idea what it could be. Where to dig?
Thank you in advance.

I decided to add.
Home Media Server program sees the device as three devices Airplay, Cromecast, UPNP. And on any of them it can play a music file.

Hi @PVAS_Roonin

this seems like my problem, i can connect my MA770 with bluetooth without a problem but chromecast doesn’t connect, let’s hope Rebekea can help us out. .

Hi Hans_Claerhoudt.
I gradually come to the following conclusion:
This problem may involve the choice of the time zone, in the time settings of windows. But I can’t check now.
Yesterday I checked it in the router, the time was accurate there, but the time zone was not correct. It is necessary to check in the acoustics itself. Maybe this is the case?

To my regret, setting the correct time zone, reinstalling Roon - the problem was not eliminated. I checked the broadcast mode in Google Crome - everything works: he sees the acoustics, the FLAC file plays.

When I have Chromecast discovery issues with Roon, which happens often with updates to Roon I have to reboot all network gear and Roon core machine and then they tend to come back. It’s annoying as all other apps see the Chromecasts and can send to them , but Roon is the only one that doesnt.

Hi Simon. Thanks for the answer. Of course, everything was overloaded with a complete shutdown, including PON. The result is negative. I will explore further

Hi Simon,

Same over here i already reboot everything even factory reset my MA770 without any change.

Hi @PVAS_Roonin

I’ve already had checked the time zone in my MAC, router, and MA770 and they where all the same.
In my case no result.

Hi Hans_Claerhoudt. I had different timezones but that didn’t solve the problem.

Sorry it didnt help. Will leave it to support.

Also not present on Naim streamers, it simply vanished the chromecast option in roon for my NDX2.

Hey @PVAS_Roonin,

Thanks for providing so much detail and for engaging with our community to find a solution. Before delving any deeper, I wanted to ask for clarification. You mentioned that:

All I can check is that Windows 7 has not been updated

Is your Roon Core running on a machine with Windows 7 as an operating system?

1 Like

Hi Rebeka. Quite right. Roon is running Windows 7 Professional SP1 on all my PCs. System updates were made in 2017. But Roon worked fine at least in August (early September) 2021. The system informs that from August to November 2021, Skype was updated 3 times, Google Crome 2 times, Dpopbox 1 time.
Perhaps that’s all. Perhaps Crome could replace the Cromecast driver in the system, without the possibility of rollback.

I’ve tried almost all of the options.
The last one remains, namely: Carry out the recovery of the system disk (there is a copy of 2017), in offline mode, reinstall Roon and evaluate the result. But I can only do it next week.

P.S the next update to Crome 94.0.4606.81 did not fix the problem.

Hello everyone, especially those who are in the subject.
I’ll tell you right away that the result is zero and the problem has not been resolved.
What I did: in offline mode, I restored the system disk with Windows 7 Prof SP1 as of 01.2017 (this is a working copy). Google crome version, Roon was not installed.
Updated the router software, set the correct region, time zone and time. Configured the WiFi network at 2.4 GHz and all network parameters, including the firewall. Launched the network, without Internet access. I checked that Google crome (cast) sees the SRS-X99 acoustics and plays the FLAC file on it. The blue LED on the acoustics turned on, the signal that is playing on the Cromecast. Launched and configured Roon and Roon server. When setting up audio, Roon saw, as it should be, both devices (Cromecast and Airplay). But then the result repeated the problem, namely Airplay connects and plays. Cromecast won’t connect (at all). Let me remind you offline mode, the software, except for the firmware of the router, is old. Everything worked with him!
It was the same with the previous router firmware. Then I got a little overwhelmed (slang). I ran clean Windows 10, completely updated it, then the last Crome and then Roon. The result is the same, i.e. none. Some kind of dead end. There is no idea what happened and with what?

Suddenly the idea came to me that if somewhere some license ended (for the built-in cromecast for example). I haven’t tried all of this with an old date. The Sony SRS-X99 manual indicates a service life of 5 years. (already just.)

Hello everybody.
So, conclusions: The problem, with a probability of 90%, in the Roon initialization procedure with devices with built-in Cromecast. Unfortunately Roon does not qualify the problem. Since the problem has appeared recently (end of August, September 2021), then the certificates in the device may have expired (this is an assumption). But this is a minor problem, since the founder of Cromecast (Google) does not notice it. Connects the device and plays music.
Contacting Roon support.
It is necessary to deal with this. If a device software update is required, then data is needed, what is wrong with it. in view of the certificate, the driver is different. If you can, do something in Roon (patch, driver, etc.), then I’m ready to test it on any version of Windows on three Sony SRS-X99s.
Thank you in advance.

Hi @PVAS_Roonin,

Thank you for your thorough investigations. I also have updated and reinstalled the program and drivers of my mac, router and MA770 without any improvement. My system has worked certainly until the 15th of september. I’m looking forward to the reply’s from Roon regarding your investigations.

Hey @PVAS_Roonin,

Thank you for keeping us posted every step of the way :pray:

I wish the answer to my last question (about Windows 7) wasn’t yes… this is because Roon does not support Windows 7. Windows 10 and up is what is necessary for Roon to run properly.

Would you be able to update your OS to something higher than Windows 7?

Hi Rebeka.
I wrote a couple of posts above that I installed Windows 10:

But that didn’t fix the problem.

Hi Hans_Claerhoudt and especially Rebeka from Roon Labs.
Of course, I found where the problem is, and it is in Roon. It’s strange that the technical support specialists don’t know about it.
The problem was created by Roon himself. And since September 21, it has blocked the work of devices with built-in Cromecast, which are not licensed: Roon ready.
More details here:

Of course, Roon didn’t take care of the users, which caused me a serious problem. I have been using the player for several years and have become attached to it. I considered him advanced and reliable. But the latter turned out to be fake. I can’t use it anymore, just because Sony didn’t get the Roon license. That is, Roon considered that he was the most important and coolest of all. At the same time, ordinary users suffered, and without warning. This greatly diminishes Roon’s credibility in my eyes. Personally, I don’t trust him anymore. Moreover, there are alternatives. Best regards, goodbye.