Clicking Add Next in the last few seconds of a playing track crashes roon

Weird one this, if clicking “add next” when the currently playing (Tidal) song is reaching the last few seconds Roon stops playing music and fails to load the next song (despite displaying the song title). All other functionality works (favouriting, browsing etc) but the song itself never plays and all of the play/pause and next/previous controls do nothing. Had this happen twice in the past few minutes with a restart of Roon after each instance fixing the issue. Any ideas?

Hi @MichaelN ----- Thank you for the report and sharing your feedback with us. Very appreciated!

Moving forward, I just tried to reproduce the error mentioned in your report and unfortunately was unable to (test conditions listed below).

My test:
Core = MacBook Air
Endpoint = B&W A7

Picked a TIDAL track that had a 2:58 RT and at the 2:52 mark I selected another TIDAL track and clicked “add next”. The first track completed and the song that was set as “next” played as expected.

If you are able to reliable reproduce this behavior when “add next” is selected I would definitely like to get your report over to our techs for evaluation. However, being as I was unable to reproduce, I would kindly like to ask you for the following information:

  • A brief but accurate description of your current setup using this link as guide.

  • In regard to the behavior you observed…

    • Did you notice the issue while using the application on your core machine or was this while using a remote device?

    • The song that was selected as “next”, was this another TIDAL track or local track?


Hi Eric, thanks for your quick reply and sorry for my slow one - The issue occured on both core and control and my setup is exclusively Tidal based. Assuming that it might have been a network speed issue I significantly upgraded my network this weekend (Cisco router, Ubiquiti pro wireless access point running 5GHz to two TP-Link 5GHz extenders that connect with ethernet cable to my core (Lenovo i7 based X230 with the intel chip) on one end and my BDP-1 on the other. I haven’t had the previous issue again yet since this upgrade although I am still running into the skipping tracks problem when upsampling to 192kHz/24Bit. “This Track is not currently available from Tidal”. Analysing the network traffic it seems this is a front load issue as the drop always occurs in the first few seconds of playback during the front end 30Mbit/sec load period as the track buffers but isn’t an issue thereafter. Removing the ethernet connected BDP-1 side wifi extender and simply connecting the bryston to the access point wirelessly with the bryston dongle (2.4 Ghz) appears to improve things in testing thus far - that is until the microwave comes on :joy: - first world problems!

Thanks for your help Eric and Happy New Year to you and the whole Roon team!!

As a quick example I just had a drop at 17seconds into a 4:24 song although it did pick up again a second later and continue playing.

Hi @MichaelN ---- Thank you for the updates and the well wishes in the New Year. Same to you and your loved ones!

Moving froward, I just want to make sure I understand where we currently “are” in our troubleshooting :innocent: As it stands (currently) the issue you are facing is the following:

“I haven’t had the previous issue again yet since this upgrade although I am still running into the skipping tracks problem when upsampling to 192kHz/24Bit. “This Track is not currently available from Tidal”.”

General Feedback:
When you notice this issue, you see the mentioned warning message in Roon and then the song picks back up eventually OR are you skipping to the next track, and playback is good again? Is this error message only generated when upsampling? The reason I ask is because we have an open investigation into this warning message as we have had others report a similar behavior to us.

Diagnostics/Log Gathering:
If you are able to reproduce this issue (i.e “this track is not currently available from TIDAL”), may I ask you to please provide the following information:

  • Reproduce the issue and note the following:

    • Note the time of day when the error was observed.
    • Note the song/album that was being played at the time of the error.


Hey Eric, just put the music on this morning and the problem is apparent immediately:

Here’s a history as requested. I just opened roon and started playback for the below experience:
9:49am Born to be Wild, Steppenwolf, Steppenwolf, “This Track is not currently available from Tidal” within first few seconds - automatically skips to next track in playlist
9:50am Lips of an Angel, Hinder, Extreme Behaviour “This Track is not currently available from Tidal”. skips to next track in playlist
Clicked the previous track button twice to return
9:51am Born to be Wild, Steppenwolf, Steppenworf, brief dropout in first 5-6 seconds then continued playback.
Changed track manually (Possibly, I forget)
9:51am Lips of an angel - Hinder, Extreme Behaviour: brief dropout at 8 seconds in, continued playback, - long dropout at 20 seconds into the song -> “This Track is not currently available from Tidal”. skips to next track
9:52am Rock you like a hurricane - scorpions, Love at First Sting - 5 secs skip to next track
Radioactive - Image dragons, Night Visions: 5 secs in “This Track is not currently available from Tidal”, skip to next track
Every breath you take - The Police, Every Breath You Take The Classics, 3 half-second dropouts before ten seconds then skip on longer dropout
~9:57am Forgettingly mininised roon to type you this message, and white screend on restore as usual. Good day so far :joy:

For some more insight to answer your questions:
When these dropouts occur if they are momentary (0.1 to ~1.5 seconds) Roon typically resumes playback from where it left off. If the dropout is longer than ~1.5 secs it almost always stays silent for around 5 seconds, comes up with the “This Track is not currently available from Tidal” error message and jumps to the next track.

  • When a song does get past the first few (15 to 20) seconds of playback and heavy network preload (as observable from my core Lenovo X230 machine), it almost always plays through to the end without any problems.
  • The likelyhood of the next song skipping within the first 0-15 seconds of playback is dramatically increased if the previous song dropped (so you tend to listen for half hour to an hour or perfect playback, followed by a string of 5-10 songs dropping and skipping to the next track after just no playback or just a few seconds of playback)
  • The issues DOES occur without upsampling (and did when playing Hinder - Lips of An Angel at 10:18am, but is typically much more rare than with upsampling. When I hit Ctrl+Alt+Delete and opened task manager after noticing the skip I noticed the CPU hit 100% despite it normally being around 20-30% with all my programs and Roon running. I have since listened to a few songs without problems. Re-enabling upsampling, the first song skipped but otherwise played ok for several tracks. The CPU didn’t spike above 50% when this new skip occured and has ranged from 15-46% since. The Roon figures show the procssor load at 23x at the start of the song, steadily reducing to between 11 and 13x as the song continues. A few songs have skipped in the past few minutes at roon processor load values of 19x 19x and 18.5x, Task manager didn’t display anything out of the ordinary for either CPU, Memory or disk load
  • I did at once think there may be a correlation with processor and RAM load as it does seem to happen more frequently when I am actively working on the machine than not but to be honest, the more the issue happens without asking anything of the processer I don’t think this is the main cause.
  • Originally I was pretty confident the network upgrade had significantly improved but not fully resolved the issue. Despite this mornings problems I still think this is the case. Before the upgrade dropouts were frequent without any upsampling, particularly on higher bitrate than CD quality albums (MQA). now they are mostly just frequent when upsampling. That said, I have the gut feeling the network isn’t the issue any longer.
  • Songs don’t always start playing, sometimes the skip occurs before any audio is heard.

My machine specs are:
Lenovo X230 Intel Core i7-3520M CPU @ 2.90 GHz (Currently with many programs open and Roon playing using 15-48% with a VERY occaisional 100% few second burst)
8GB Ram (which as I type this with a lot of programs running I’m currently using 6.1 - 6.4Gb)
Windows 10 X64
And the good old white-screening Intel HD Graphics 4000

Network-wise I have this problem when using the laptop’s (Core) wireless network card or ethernet card plugged in directly to a 5GHz ethernet range extender. If I get any free time, I am planning to do some more tests this weekend with the laptop ethernet port connected directly to the Cisco router to take another intermediate connection out of the signal path and see what happens.

Finally, the only thing that does seem fully replicatable is that every single time theres a dropout windows task manager reports the Ethernet Send speed has decreased below 5Mbs (even though the receive speed stays relatively static between 20 and 30Mbps during initial playback and 240kbps and 3mbps after preload. Some exaples of the send receive pairs at the point of dropout are shown below:
3Mb/s send / 26.4Mb/s receive
3.8Mb/s send / 256 kbp/s receive
4Mb/s send / 24Mbs receive
4.8Mbp/s send / 26Mb/s receive
3.1Mbp/s send / 27Mb/s receive
2.8Mb/s send / 27Mb/s receive
4.9Mb/s send / 24Mb/s receive
During standard plaback the send speed with upsampling hovers between and 8 and 11Mb’s. While my assumption was that this is just because there’s no music to send when playback is interupted rather than being of dianostic use, it is observable that the send speed does start to drop prior to the music stopping.

Hopefully all that techno bable helps you guys. I have another 6 days left to return the expensive network equipment if this is believed to be the issue so if it’s at least possible to confirm whether or not I should keep the current network setup at this point or take it back for a refund that would be highly appreciated.

I’ve also zipped all the Log files if there’s anything of use for you guys. Is there a way I can make these available privately to you guys rather than linking them publically on the forum?

Forgot to mention, typically, there isn’t really any pattern that I’ve noticed regarding time of day this occurs. Can be morning, day, evening or night.

Hi @MichaelN ---- Thank you for touching base with me and providing a very thorough/details report :thumbsup: The diligence and attention to detail are both very appreciated!

Moving forward, upon seeing your response I went ahead and enabled diagnostics on your account. What this action will do is the next time the application is active on your core machine a diagnostics report containing a fresh set of Roon logs will automatically be generated/uploaded directly to our servers. Once the report has been received I will touch base again to confirm that we have it and then pass it over to our tech team for analysis. Please do me a favor (if possible of course) and hold on to the logs you’ve saved from the test run just in case the team needs some additional information for their investigation.


Hi @Eric, Thanks for all your help! Working with computers this won’t supprise you in the slightest but of course for the entire day I had roon running with diagnostics enabled there wasn’t a single skip, not even a microsecond dropout - Typical :slight_smile: I even tried rapidly skipping and jumping tracks which normally sets it off but the software didn’t skip a beat. The sesion started with upsampling off, then I turned it back on with no additional issues.

The only thing I’m aware of changing since all the problems on Friday was I had to unplug and re-plug in the modem and router (hence rebooting it), and my computer automatically restarted itself after windows installed an update overnight. It’s hardly the first time the computer and network have been restarted - in the past the issue has come back sooner or later. That said, I’m not really sure whether to call my occurance of the issue resolved for now or if you wanted to keep digging on behalf of the wider community and/or if the issue returns.

Would you like a copy of the original logs from the errors on Friday seeing as I’m not expecting you to learn much from the diagnostics yesterday and today during perfect playback?

Hi @MichaelN ---- Thank you for the update and sharing these recent observations with me.

Moving forward, I can confirm that the diagnostics report did come in and I can see from the date(s) in the attached logs that we have the “runs” from when the issue had been occurring. As mentioned before please hold on to the logs you gathered just in case the team requires some additional information.

Furthermore, I also wanted to see how things have been holding up since you last post. Let me know.

Many thanks!