Core and audio output problems

New to Roon; please bare with me:
Just completed Trial, sad to say I now own it after 2 frustrating weeks. For the several days that it worked, I really enjoyed it and would love to get it to work. I am having 2 issues. My iMacPro (OS X 10.13.4) will not locate the RoonServer core (version 1.5 build 323 stored own its own SSD Samsung evo 860 ) (QNAP x64 TVS-1282T3 i7-7700 cpu 32GB RAM) which I have solved by loading Roon on the iMac, letting it search for the core, while I stop the the RoonServer core and restart it. Once I restart the server core the desktop finds it immediately. Same scenario occurs with MacBook Pro and iPad Pro. Painful, not ideal but it works. Rest of hardware in the chain: Cisco rv345 Router, NetGear XS728T 10Gb managed switch (jumbo packs 9000 vs 1500 makes no difference). Firewalls on or off makes no difference. Static IP addresses, have not tried anything with port forwarding. I have deleted and replaces the server core and desktop programs, rebooted everything in the chain several times, use SMB3 etc. That leads me to my second problem, once I was able to connect to the core everything worked well for a few days then the audio output stopped. I will do my best to explain. I am sitting here looking at the Roon GUI on a second monitor and everything looks fine. I push play on the first title in an album, it will stay on that title for a few seconds then jump to the next song, and so on until it reaches the end of the album with no audio output, regardless of whether the zone is an USB DAC, internal speakers, airplay etc. Same results on MacBook Pro. The music files are stored on the NAS under a different storage pool than the RoonServer (approx 5000 songs). Roon settings are pointed to the correct NAS storage pool, volume and files. Have reset several times. The music files themselves work on different players. I have tweaked every setting that I can think of on the NAS, computers, router, and switch. I hope I have explained things well. Sorry for putting 2 problems in one post but it cuts down on the hardware description redundancy. So let me end with HELP!

Hello @MD2020 — Thanks for the detailed report!

Sorry to hear about the troubles you’ve experienced.

I usually like to mention that we’ve tracked a number of issues to in the past to managed switches(examples: here, here, and here).

The simplest way to confirm whether the switch (or its settings) are contributing to these symptoms would be to temporarily test with the switch removed from your network. Whether things improve or not, the results of that test would be a great data point.

I would also recommend enabling flow control on the switch, as we have seen that settings resolve a number of issues for other users in the past.

May I also ask that you confirm the following:

  • Since you started experiencing this behavior, have you tried rebooting your networking hardware and remote devices?
  • Do you have any antivirus software that could be contributing to network connectivity issues?


Thanks for the reply. Turned on global flow control and no change in either of the problems. Have rebooted everything (rooter, switch, NAS) multiple times. No antiviral software. Only thing I have not tried is to take the managed switch out of the equation. I use the iMacPro for 3D brain tumor virtualization and store the output on the NAS while I listen to music. The 10gb switch is amazingly fast and speeds up my work flow, but will try bypassing that next to narrow down the playing field. Hope the switch is not the problem, may have to decide between music and work. Thanks!

Hello Roon,
The conundrum continues:

NetGear 10gb switch - removed
Qnap UPnP is disabled
Cisco router - disabled UPnP, IGMP and multicasting
- enabled flow control similar to screen shot recommended by Dylan
Rebooted everything - twice

Still can’t find RoonServer core on iMacPro without stopping and restarting core. No audio output on USB DAC or iMac internal speakers. Same situation with MBP.

@MD2020 Kent when the problem of finding the core is in play can you ping the core endpoint IP address at all?

This still sounds like some weird network issue.

Hello wisardofoz,

Yes. While waiting for the remote core to connect, I can ping the core IP address

Screen Shot 2018-05-20 at 11.11.48 PM

Screen Shot 2018-05-20 at 11.14.34 PM

Hello @MD2020 — Thanks for testing that out!

Is the Core machine (QNAP) and the remote device (Mac) connected via WiFi or do they have a wired connection?

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thank you,

@MD2020 I am going to just ask if the IP address of the core machine and the remote you are trying to connect with, on the same 192.168.1 x subnet - if not then this will be where the issue most likely lies.

No VLANs or anything like that?

First let me say thank you for helping me solve this issue. Much appreciated.

Everything is connected over ethernet with cat7a cable and on the same subnet. When I first started this thread my main computer and NAS where on a VLAN. The NAS has two 10 gb ports that were connected to the 10gb switch with link aggregation. Since then the switch has been removed from the equation and all connections are directly to the Cisco router (acting as DHCP/DNS server, wifi is via a netgear AC4000 set up as an access point only).

The NAS and main computer have static IP addresses. However, the MBP that gives the same results when connecting to the core, as well as, no audio output is on a dynamic address. I have tried Wifi and ethernet connections (MBP) with the same results. Note however, the MBP would connect to the core over ethernet and wifi for the few days that the system worked i.e. audio output. It still required the core shut down to connect but there was audio output.

The iPad was over wifi and did work for a couple of days as an endpoint. Now it will not connect to the core despite stopping or starting the core. As far as the reproducing the issue; I can do that any time, I just need to shut down Roon on the iMacPro or reboot the computer. Then to reconnect to the core I just need to stop and restart the core and it immediately connects. So…

Dylan the time stamp is 18:41(5-21-2018). I hope all my rambling above helps.


Just to confirm the core is running on the qnap and in the same Ip subnet as everything else. @crieke maybe Chris has some thoughts?

Correct. The core is on the QNAP (reset and re-downloaded without change) and same IPv4 subnet (192.168.1.x).

Thanks, @MD2020!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi @MD2020,

I just wanted to confirm that the diagnostics report has been successfully uploaded. I have passed them along to the technical team for analysis. Once I hear back from them I will be sure to update you with their findings in a timely manner. Thank you for your patience while we look into this for you.


Hey @MD2020, thanks for your patience as the technical team reviewed the diagnostics report. I’ve discussed with them, and I think we see what the root cause of what you’re seeing may be.

The NAS has two 10 gb ports that were connected to the 10gb switch with link aggregation

In looking at the report, as well as reviewing your current setup, we believe that it is the port aggregation that is causing your troubles. Roon does not support port aggregation, so I was hoping you could try testing this out with a single network card and seeing if the experience improves.

Thank you,

I am sorry to report, no such luck. I had already tried this without success. So with your advice, I went a few steps further. I didn’t just break the link aggregation, I completely removed the second cable from the NAS and have had the same response (stop Roon server then restart to make connection and then no audio output). The QNAP TVS1282T3 has two 10Gb ports on one NIC and four 1Gb ports on another. So I tried the a 1Gb port after disconnecting the 10Gb cable and had the same results. N.B. multiple reboots of the desktop, Roon iMac program, NAS and router after changes. Current setup is iMacPro > Cat7a ethernet > Cisco RV 345 router > one ethernet connection to 10Gb NAS port ( the netgear managed switch has been switched off, pardon the pun).

Any thoughts on the Cisco router. It has a lot of features, I am not a Cisco IT certified technician, it has very poor documentation and has required me to learn more about routers than I ever wanted to know. I have gone from page to page on the GUI, enabling and disabling settings followed by reboots without much luck. I know we have talked about VLANs earlier in the thread, but by default the Cisco router puts all 16 lan ports on an ‘untagged’ VLAN1, which correct me if I am wrong, is not technically a VLAN. I don’t have a second router handy to try. I bricked my linksys ltr224 dual wan router and have been to lazy to fix it( honest answer, I don’t really want to), but I could if you thought it worth it.
Anyway I’ll keep the faith, the solution is always around the corner.

Not sure if you have jumbo frames on too…that also causes problems potentially too

Every device in the path was switched to MTU 1500

Hey @MD2020, sorry to hear you’re still having difficulties here.

I have passed what you’ve said back over to the technical team for further analysis on what may be causing this behavior.

In the meantime, I’ve looked into the router you have bit, and I do see that it does have firewall settings that could be contributing to this. Have you tried disabling the firewall on the router?


Hey @MD2020 — I want to thank you for your patience as we have been investigating your report.

I’ve been discussing this issue with the technical team and these symptoms really point towards something going on in your environment. Obviously, we would expect this networking gear to perform great, but there’s always the chance that some piece of hardware isn’t working properly , or that something is misconfigured.

I don’t want to waste time here poring over the various options for your networking gear, but I think it’s important that we rule out either environmental factors or something related to the device your Core is running on.

Ideally, the easiest test here would be to connect the QNAP and the iMac to a simple DHCP router (using ethernet, and stock networking settings) and see if browsing and playback are stable. If they are, we can reasonably assume the issue is related to the wider network – something with the router, the cables involved, the switch, etc. If the issue persists with stock settings in place, we know the problem. lies elsewhere

I know you mentioned that you don’t have another router on hand, but I don’t want to waste more of your time here trying to guess at the various settings on that router. I can tell you that having a simple, consumer grade router is a really powerful troubleshooting tool when debugging networks like yours, and we’ve seen $50 dollar routers make the critical difference troubleshooting way more complex networks than yours.

If simplifying the network isn’t an option, you might also try running the Core on the Mac as a test, to see if that makes any difference – this would help us localize the problem to the NAS, which would also be a good data point.

In any event, let us know how you’re doing and we’ll do whatever we can to identify the issue here.