Core not supporting ARC sky router U.K [Solved: McAfee Firewall]

Roon Core Machine

Hello I have a U.K. sky router and get an error time out delay when connecting to arc. Is there a manual work around for sky router but unclear how to even access it to do that part.
Changing settings could affect other local systems access?
Help appreciated

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I have no specific IT knowledge, but had a similar issue with my router/modem (Plusnet). I needed to manually open a port to the Roon core. I describe how I did it here: ARC Port forwarding issue (ASUS router) - #11 by Red_R

I imagine your Sky modem/router will be similar.

I think SKY use net gear as a base for their routers. So you’ll be able to port forward if you do a Google search of your router.

Nope didn’t work . Thanks for suggestions

I followed sky advice for port forward but again it failed.

Thanks for suggestion but struggling to understand why Roon support can’t advise users direct. I can’t be the only sky subscriber and we all have problems

Please confirm the model of your sky router. I’m using Sky and have the SR203, and this worked using UPnP.

I actually tried using port forwarding from sky but after doing this just got an error saying I was not connected to internet when actually I was and all other apps working including Roon.

It’s the latest router . All are enabled

Model is SR203
All are enabled. I tried port forwarding also but that failed
What port number are you using.
Glad to know it worked using sky. Suggests to me I have a different problem

@Alister_Scott1, do you have any other networking equipment in your home that’s connected to the Sky router? It would be really helpful if you could describe what you have in more detail.

In addition, please navigate to the Sky router UPnP page and provide a screenshot, e.g., Thanks.

I have my Roon core a pc connected plus sky Q hub plus kef ls50 speakers. These are all connected via Ethernet cable via the chord bridge
Nothing else

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Apologies I also run another dell pc as an office computer which is connected to the router via Bluetooth and I use headphone socket to play Roon from that.

I would really value your insight as a sky user. There seems no reason why it isn’t working. I took off macafee to check that wasn’t to blame and have no other issues unless the fact my core is a dell dimension pc
Otherwise as Roon help just keeps ending me the same help video I might as well give up

I note that you haven’t completed the support template. It’d be really helpful if you did this, and describe your core, music location, and how everything is connected, e.g., Wi-Fi, Ethernet, and so on.

In addition, please confirm the PORT number in Settings > Roon ARC.

I’m sure we can resolve this.

My previous post did although not using template
I have ethernet wired connection from router to a bridge which then connects to my Roon core dell dimension pc .
I have kefls50 active speakers and sky hub connected also
The screenshot gave my Roon port 52000
I have 800 albums or so in my library but only 30 cds stored on my core.
I also run fideliser 8 pro on the dell to improve sound on core
I have another dell dimension pc which connects to my sky router via Bluetooth and I use Roon as a remote on that computer.

What is the “bridge”?

Sorry it’s a network switch Cambridge electronics