Covers not shown on iPads

Dear Roon team,

I am quite a newby on Roon and really enjoyed the features you provide.

But there has been an issue with the album covers disappearing on an irregular basis over the last weeks and this weekend this was an almost constant feature. This is very annoying and I tried already all options (restart app, restart iPads, restart Rock, clearing cache, …) addressed in previous posts. It happens on Quobuz albums and titles as well as my local ones.

It is just happening on my two iPads (iPad Pro 12.9 4. Gen and iPad Air 2), while on my iPhone X everything runs fine. All devices run on latest iOS and version of Roon Remote.

Could you please sort that one out as it seems to be around some time according to previous time. It‘s not creating fun in searching grey and black boxes.




I’ve moved your topic to the support section of the forum.
In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Here some details of the network:

  • Roon Core on NUC 8i7 with 128 GB internal storage running Rock and used for Roon library, LAN connected
  • local files on Synology NAS, LAN connected
  • Auralic Altair as streamer, WiFi connected through Ubiquiti AC Pro
  • Router Speedport Smart 3
  • Roon Remote on iPad Pro 12.9 4. Gen, iPad Air 2, iPhone X all with current iOS 14.2, all connected via 5GHz WiFi over same Access Point as Altair

Only iPads show the described behaviour.

Hope that‘s sufficient description of the setup.

Hi @Mirko_Hornung,

In Settings > Setup there is an option to adjust the memory available for images. Can you try increasing this and rebooting and let us know if that helps?

I tried that already on the last days. No difference, except that the cover of the actual album was showing afterwards.

This morning after a restart of Roon Core everything is there. I will give notification, when the feature will show again.

1 Like

Hi @Mirko_Hornung,

Thanks for letting us know that the reboot cleared up this issue! If you notice the issue re-occur please do let us know and we can take another look!


On the weekend the reboot (done every night) did not help. Today it worked so far. Will let you know if it shows up again.

Thanks so far and enjoy the holidays

1 Like

Sorry to say. But it is back again.

After starting the Roon Core this Morning it again blanks out the covers.

1 Like

Hi @Mirko_Hornung,

Which iPad did you take this screenshot on? What is the model?

I want to activate diagnostics mode and take a look at your Roon logs, can you please open the Roon app on the iPad you used for this screenshot and use the Roon app for a few minutes on it?

Happy new year to the Roon team.

Unfortunately the issue with not shown covers is back, since Wednesday so severe, that even restarts of all remotes and reboot of the core doesn’t help at all.

In between I thought to have a clue, that dark mode on the iPads caused the problems, but no! There has been no way to find a logic, why it shows up.

Hi @Mirko_Hornung,

Happy New Year to you as well!

Can you please confirm the previous question I asked?

I would like to activate diagnostics mode to see if I can gather some more information, can you please reproduce the issue, let me know the exact local time + date of occurrence and the iPad model used for the test?

Dera noris,

the picture was done on iPad Pro 12.9 4. Gen, with iPadOS 14.2

But the same picture did also occur on iPad Air 2 with current iPadOS 14.2 & after updating to 14.3.

I will send you date and time, when it will occur next time and also on which ipad.


1 Like

Hi @Mirko_Hornung,

Thank you for the additional information, if the issue occurs again please do let let me know the date, time and which iPad, thanks!

It’s back again:

Saturday, 16.01.21, 9:23 German Time

Both iPads at the same time.

Foto is taken from iPad Pro 12.9, 4. Gen., iPadOS 14.3

1 Like

Hi @Mirko_Hornung,

Thank you for providing that timestamp and screenshot details!

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Once this report has been received, I will discuss the findings with our QA team and get back to you, thanks in advance for your patience!

Dear Roon Team,

any update on the issue?

In the mean time I was able to identify, that the problem will always show up, once the Roon Remote on the iPad Pro 12.9 4. Gen, with iPadOS 14.3, is active. If only iPad Air 2 and iPhone are active it will not show.

Probably that helps to find the core problem.

Looking forward for a solution


Hi @Mirko_Hornung,

Apologies for the delays in getting back to you here, I just checked with the team on this one and I do have some further feedback for you, which I will list below:

  1. Do you have any VPNs on the affected Roon Remote? If so, can you please try to disable any VPNs?

  2. Can you please try to increase Roon Settings -> Setup -> Memory for photos artwork and see if this has any effect on the issue?

  3. Does the same issue occur on non-iOS remotes, for example can you try to install Roon on a PC, connect to ROCK and verify if the issue occurs there as well?

  4. When the issue occurs, are you able to open an image link in a web browser on the affected iPad? Here is a direct link to one of the images which I saw had issues in diagnostics:

Hi @noris,

regarding your questions:

  1. no VPN active
  2. Change of photo memory has no influence, currently at 1 GB!
  3. not tested yet
  4. I will try. How do I get the direct link of the images?



1 Like

Hi @noris,

Just now having lost all cover images again.

Link of your previous message is working to show the picture in the browser (4. Bullet).



1 Like