Crash. roon suddenly fails, mid-playback, to recognize bluesound devices

(Keith Ewing) #1

*Core Machine (Operating system/System info/Roon build number)

thinkpad

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

my information appears in a previous topic.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

again, bluesound vault2i, powernode2i, pulsemini2i, the vault and pulsemini are connected via ethernet, powernode is wifi.

Description Of Issue

Not the first time at all that this has happened, I thought my problem may have been solved by ethernetting the pulsemini. Nope. Music playing along fine for a couple days then crash! -music stops, roon can’t see any bluesound devices even after reboot of bluesound devices and reboot of internet modem and again rebooting bluesound devices. shared drive active. music plays to my speakers via BluOS from both vault2i library and Qobuz (via BluOs) so it appears roon is the culprit?

(Noris) #3

Hi @Keith_Ewing,

I have just reviewed the previous thread you had open with us (Crashes, crashes, crashes...!) and to me it looks like your network might be causing this issue.

We have often seen ISP provided routers (such as your AT&T one) cause issues with multicast. Roon uses multicast technology to communicate with devices on the network and if the router is not properly passing this traffic through, then similar symptoms can occur.

Have you tried using a standard consumer-grade router yet such as TP-Link/Netgear/Asus? If you have any of these routers around the house, can you try using this instead of the ATT UVerse router? If the ATT UVerse is a modem/router combo my suggestion here would be to use just the modem aspect of the combo unit and try a regular router connected to the Etherent out on the UVerse modem.

Also, how is your Thinkpad connected to the network here, if it is on WiFi is there any change if you connect it via Ethernet?

– Noris

(Keith Ewing) #4

Noris, thanks for researching my previous thread and for the diagnosis:

  1. I will research the multicast issue with ATT customer service and then, if they are not able to help (perhaps even by way of supplying a different router) I will pursue an alternative per your suggestion.
  2. My thinkpad, crazily, does not have an ethernet port - too slim of a configuration? - unless an adapter of some type exists that I’m not aware of, so I can’t try that - I most certainly would, argh! It makes me think I ought to just spring for a refurbished laptop with the port vs. considering indulging in, say, a Nucleus.
  3. Question: my thinkpad and bluesound vault2i share a drive (so as to be capable of casting my downloads to the vault and also editing its library) - could that shared situation also be adding to my roon-endpoint woes at all?
(Scott G) #5

You can get USB to Ethernet adapters
https://support.lenovo.com/us/en/solutions/pd029741
I’ve used them on MacBook Pros. Everything is getting too thin.

(Noris) #6

Hi @Keith_Ewing,

  1. Typically any ISP provided router will be sub-par to what you can find on the consumer market. If you do decide to get a new router, I would suggest getting it from a place you can easily return it, such as Amazon.

  2. If you really want to get serious and are not afraid to put some computer hardware together, I would highly suggest checking out Roon Optimized Core Kit (ROCK). It runs a custom Linux version made by our team and is similar to a Nucleus in that it’s sole purpose is to run Roon. You can also get the USB to Ethernet adapter as Scott suggests to see if that will help with the current situation but having a dedicated Core is always preferable if possible.

  3. No, this shouldn’t be an issue.

– Noris

(Keith Ewing) #7

Noris:

  1. I bought an ASUS AC3100 router ($150) and disabled the router portion of my AT&T unit.
  2. My signal appears to be all good, see image.
  3. But nary 24 hours passed and… crash!
  4. Of note, I could stream Qobuz via the BluOs app from Bluesound but Roon, again, wasn’t recognizing any devices, the tracks just silently skipping, same old story.
  5. I’ve contacted Bluesound as I suspect it’s communication between my wireless and ethernet devices - Bluetooth signal, whatever - that is somehow subject to trouble.
  6. That, and perhaps something to do with my wireless, non-dedicated laptop core.
  7. A difficult diagnosis with all the systems trying to cooperate but I’m determined to stick it out because I need the sound quality and access to all my music - it’s worth the hassle to reboot a few times, give or take, per week (sometimes per day) and work towards tweaking my system.
  8. Another note, my shared drive disconnects sometimes also during a crash. So, perhaps my multi-tasking laptop is doing nasty things to my system - with the router issue off the table I suppose it’s down to the core and whether or not Bluesound wireless is reliable and even whether Roon and Bluesound communicate flawlessly or not.
(Noris) #8

Hi @Keith_Ewing,

Thanks for trying the new router and sorry to hear that the issue is still the same.
I have a few follow-up suggestions:

  1. Sometimes ASUS routers need to explicit have a setting changed on them to function properly with Roon. I suspect that this may not be the main cause of the issues but it will be worthwhile just to check this. We recommend checking the “Enable Multicast Routing” box if you Asus router has such as setting (as mentioned in our Networking Best Practices). You can also check to see if IGMP Proying/Snooping has any impact here as they have affected various other routers in the past.

  2. Let’s try setting “Reserved IP” addresses for both your Core + Bluesound zone so that they do not change as often. IP addresses typically have 24 hour leases and may change. While this shouldn’t cause the behavior you’re seeing, giving these devices reserved IPs won’t hurt as long as you are careful to set them in the same IP address range (e.g 192.168.2.XXX). You can use these instructions from Asus for this step.

  3. Let’s start taking a look at the diagnostics from your Core when this issue occurs. Before I go ahead and enable this feature for your account, can I please ask you to reproduce this issue once more and note two timestamps here. The two timestamps should be the local time and date in your country of when the issue is not occurring and then when the issue presents itself. E.g. At 4:15PM on 5/14/19 the Bluesound zone was working as expected and then at 9:41PM on 5/14/19 the bluesound zone disappeared.

  4. Can you please manually send me a copy of the logs from your Bluesound device? You can get these logs by navigating to device’s IP Address in a web browser -> Diagnostics -> More -> Copy and paste the text into a text editor and save the info and send it as a shared Dropbox/Google Drive/Firefox Send link. It looks like the IP address for the Vault is 192.168.2.189 from your screenshot.

Hopefully one of my above suggestions (from step 1/2) will yield the proper results and if not we can take a closer look a the diagnostics (from step 3/4).

Thanks,
Noris

(Keith Ewing) #9

Thanks Noris:

  1. Multicast routing was indeed disabled in the Asus settings - I enabled it.
  2. I manually assigned the IP addresses for my Bluesound zone and core.
  3. Crash time stamp: At 7:34am on 5/15/19 the Bluesound zone was working as expected then at 7:36am on 5/15/19 the Bluesound zone disappeared (malfunctioned).
  4. Here is the link to my Bluesound Vault diagnostic logs: https://drive.google.com/open?id=1obSXpOYsTLnZ-NmpVTyMa8oftXRTUbtU
(Keith Ewing) #10

Noris, a crash this morning so here’s another time stamp: At 7:15 am on 5/16/19 music was playing then at 7:16-19 (I can’t recall exactly) the music stopped and the Bluesound zone disappeared. https://drive.google.com/open?id=1B7H6KRV5v86iUhBSKG-qwMLAC--wvCaj

(Noris) #11

Hi @Keith_Ewing,

Thanks for letting me know those timestamps. Now that I have this info, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

After these diagnostics are received, I will be creating a case for you with our QA team for review. I just want to confirm one other thing here, you mentioned that the Bluesound Vault disappeared, but have the other zones Bluesound zones remained visible? Did this issue only affected the Vault zone at the timestamp you mentioned or all of the Bluesound zones?

– Noris

(Keith Ewing) #12

Noris, thanks for all your help, it keeps my faith alive, so to say, in the potential of this system. When you say “zone” - my bluesound devices (all three of them) are so-called “grouped” within BluOs, their app i guess you’d call it. So that, for instance, when Bluesound support also requested diagnostic logs, they told me to un-group my group. If that matters to you.

(Noris) #13

Hi @Keith_Ewing,

Thanks for letting me know that. So just to clarify here – when the Bluesound zones were not grouped and all were showing up separately, at the 7:36AM and at the 7:16-19AM timestamp that you mentioned, did all of the bluesound endpoints disappear or was it just the Vault 2i? This will help us narrow down the issue further because if it’s just the Vault 2i displaying the disappearing behavior that would be a good data point to have.

– Noris

(Keith Ewing) #14

Noris, so sorry to create confusion and it’s because of my poorly worded email. Hopefully to clarify:

  1. I’ve never streamed with the Bluesound devices un-grouped; that is to say, Bluesound support told me to un-group merely to be capable of sending diagnostics through their BluOS (for each of the three individual devices) and I immediately re-grouped the devices for playback/streaming and ever after.
  2. Hence, my Bluesound zone always drops out from Roon as a group - and it’s icon-info likewise disappears within the settings interface and then reappears after successful reboot (see attached screen shot showing proper operation).
  3. Of note, also, my Powernode is IP 192.168.2.28, “FM Link - 88:83:5D:C1:4E:D0” and the Pulsemini is IP 192.168.2.57, “AC:35:EE:5A:70:07.”
  4. Again, sorry for the confusion and also I apologize if any of this is irrelevant to you. Otherwise, thanks so much.

(Noris) #15

Hi @Keith_Ewing,

Thanks for the additional info, it is appreciated! No worries on sharing too much info, even little things can be a key in troubleshooting issues some times such as zones being grouped.

It would be interesting to know if you are able to play to the zones un-grouped and if just one zone in particular is causing this issue and it is triggering this behavior for the rest of the zones.

If you want to take a look to see if this perhaps is part of the issue, it would be appreciated. Otherwise I will be sure to let you know once I hear back from QA regarding the Bluesound Logs + Core Diagnostics analysis and appreciate your patience until then.

Thanks,
Noris

(Noris) #16

Hi @Keith_Ewing,

The review is still pending by the team but I just wanted to request one other data point that may be of help here in addition to my previously mentioned test.

When this issue with the Bluesound devices occur and they are grouped, are you still able to play to them via Airplay?

Thanks,
Noris

(Keith Ewing) #17

Noris, you’ll likely be disappointed with the following:

  1. I tried the un-grouping and it was frustrating because (a) my pulsemini in the basement wouldn’t stream, not a huge deal, but (b) I couldn’t control Roon with my cell phone Roon app - don’t know why. Also not critical because I could use the laptop core to control Roon. But it all drove me crazy enough that I bailed after an hour or so and re-grouped the Bluesound devices. Whether it would have crashed at some point…? Sorry, it seems there’s only so much that I can endure with the diagnostic process, the gnashing of teeth and all that. If this is critical I will devote a day to it, albeit reluctantly, please advise.
  2. I was reading your email when I experienced a crash. Of note, the system had performed all day, running Roon Radio, if it matters, vs. my tracks - I walked in the door from work and music was playing. I switched to my library and within a couple hours, the crash. Even the Airplay option had disappeared. But I will say, regarding Airplay, that it has, in the past, indeed worked when the Roon enhanced option has required a reboot. (It didn’t take me long to figure out that Airplay is MP3 quality or otherwise not hi-res capable, ugh, and it’s only when I’m not home and my wife is forced to get the music playing again on her own that I come home and she’s got an Airplay signal and I reboot everything and get it back to Roon-enhanced).
  3. Again, if some tests I need to do are deal-breaker-critical, let me know and I’ll endure them.
(Keith Ewing) #18

Noris, I was re-reading the info within your link for the ROCK and the info below stood out, notably, for the NAS (my Vault) and, namely, the apparent “Susceptibility to to networking issues…” Am I doomed even with a dedicated core…? Meanwhile, I refuse to panic, despite the single biggest selling point for Roon in my particular case being the manner in which it unifies my music collection and allows me to shuffle it all.

(Noris) #19

Hi @Keith_Ewing,

Apologies for the delay here, I am still discussing your case with our hardware team regarding the diagnostics, but to answer your question:

No, I don’t believe you are doomed here. The article you mentioned notes that NAS storage is susceptible to networking issues, meaning that if the network is properly configured (and preferably everything is on Ethernet) then it should work as expected, but if there are network mis-configurations then devices that rely on the network might have issues (this includes Storage/Endpoints).

I think we should take a look at this aspect next and eliminate WiFi from the equation:

Can you let me know if you are able to give this a try? If things are stable with the WiFi out of the mix, we at least have a good data point and can move forward from there.

Thanks,
Noris

(Keith Ewing) #20

Thanks Noris. I went three days without a glitch until this evening when I suffered the same old devil of a drop out requiring reboot.

  1. I just connected my laptop/core via ethernet, time stamp approximately 10:15pm EST. It’s a pain in this old house but so be it I’m determined to figure this out.
  2. At the same time Bluesound wants me to forward diagnostic data from my players, again, we’ll see what they say.
  3. Finally, just FYI, I’m in touch with Qobuz support, too, because the last three days or so I can’t effectively stream anything at 24/192 - music starts and stops, eventually fails. Again, ONLY the 24/192 music and even when I’m on ethernet.

Thanks for the help.

(Keith Ewing) #21

Noris. Crash with core on ethernet today, 6pm-ish. BTW, pulsemini remote speaker is on wireless - because I can’t figure out how to get it to stream otherwise; I don’t know if anything in my group being on wireless is the problem. I probably ought to just disconnect the mini but diagnostics are killing me…