Creative SBZ Series ASIO : "Device Initialization Failed"


It worked perfectly until yesterday but now it failed. Could you help me ?
I’ve tried to reinstall driver etc…! Thank you



Thanks for contacting support, I’d be happy to take a look over the issue you are facing here. Can you please provide an overview of your system using this thread as a guide?

Furthermore, can you please confirm that you have tried restarting the Roon App and the issue still occurs? Are you able to see any of your zones under Menu -> Audio or are all of them missing? Are you able to play content on another device such as the system output? Please let me know when possible.


Hello @noris ,
Thank you for help.
I’m using a PC desktop with Windows 10 up to date.
Roon 1.5
I’ve a sound blaster zxr with latest driver.
It works with wasapi and all zone appears. Only ASIO zone is fail.
I’ve restarted roon many times.
It works perfectly during the free try and know that I’ve an annual membership the problem appears suddenly. I’m not trying to say there is a link between that but I want to solve this quickly :slight_smile:

Thank you


I apologize about the slight delay in getting back to you here. Can you please confirm if the ASIO driver for that sound card works outside of Roon? I did a bit of research and I have found several threads where people report the ASIO driver for the Sound Blaster ZXR do not work as expected, links here:

Their workaround to get the ASIO to work was to install ASIO4ALL but I cannot comment on how well that would work since I do not have one of those sound cards.

If the WASAPI driver is working for that card I would recommend remaining on WASAPI as ASIO4ALL is just a wrapper that “mimics” the driver into thinking that it is ASIO when it is really not and may cause problems down the line. I hope that helps but let me know if you have any other questions.