DAC displays incorrect sample rate at random [Singxer Driver Not Ready]

I have a similar issue with my setup.

The difference in my playback is when I force 512 DSD, even though the signal path displays it playing, my DAC displays incorrect sample rates at random, but music plays. My DAC is supposed to support native 512 DSD via I2S.
256 DSD plays as expected.

Hi @J_William_Truett ---- Thank you for the report and sharing your feedback with us.

Moving forward may I kindly ask you to please provide a brief but accurate description of your current setup as seen here and lastly, can you please verify for me if this is the DAC that you are currently using.


Roon Core 1.3 V223 Ubuntu 16.04 LTS 64bit Intel 2600K, 16GB RAM, Samsung 840 SSD 128GB
Roon Bridge V86 Rpi3 Ropieee V28 (Linux 4.9.28-1-SPCKFSH), Sandisk 16GB —> USB
Singxer SU-1 (Firmware v2.22) —> I2S
Gustard X20 Pro

Hi @J_William_Truett ---- Thank you for the follow up and taking the time to answer my questions. Both are very appreciated!

As far as I can tell we haven’t seen many reports involving the Gustard X20 Pro, but upon doing a quick search I found the following post on Head-Fi. Can you confirm which mode you are currently using with the DAC, automatic adaptation master clock technology or asynchronous master clock technology?

Lastly, during your troubleshooting of this behavior have you tried removing the Singxer SU-1 from the chain of communication and going directly from the RPi 3 via USB to the Gustard X20 Pro? What was the experience like?


I read through that thread and it seems no one knows what that selection actually does. It was on Auto, I switched it back and forth and it makes no difference. The DAC seems confused at to what signal it is receiving, but the music continues to play.

I did take the SU-1 out of the equation, but I use it for the I2S input to the X20 Pro. The USB input is only capable of 256 DSD Native, so it works as expected (no 512 DSD/no music).

At this point it just seems there is disconnect between the drivers, SU-1 and the X20. The firmware update for the SU-1 to allow 512 DSD Native is new and I thought it should just work. The only thing I haven’t tried is attaching the SU-1 to a Win10 machine, but the XMOS driver isn’t officially supported for the X20 and hard to find. I’ll try and find it and give it a try, but the Rpi3 is my preferred path.


Hi Eric,
Sorry to waste your time. Now Singxer says the driver that supports 512 DSD Native is not complete yet,

"Hi William

sorry for this problem.

our driver can not support DSD512 now.

we will update our driver,but it needs sometime.

thanks a lot.


You can close the case. Hopefully I can update with good news once they notify me the new driver is complete (again).


1 Like

@J_William_Truett — No worries :wink: Let me know how things turn out once the new driver is completed and if further assistance is needed…start a new thread, drop me a flag ("@support"), and I will be glad to lend a hand.