Devialet with CI and roon

Hello Devialet, roon experts and @support

I hope you can help because I struggle badly here…

A friend of mine has the following situation and we are not able to get roon to “talk” directly to Devialet with CI update:

Roon core is on a Lampizator SuperKomputer.
The Devialet with CI update is in another room, everything is “connected” via W-Lan.

The Devialet is NOT “visible” for roon directly, no matter what we tried :frowning_face:

But here comes the strange thing: If we run some Devialet app on a third (work-)Computer in a third room, (connected with W-Lan as well) , roon now “sees” the Devialet and can also feed the Devialet (but only in lesser Quality) :rage:

How can we get the third PC out of the equation and still have roon “see and play” to the Devialet (with CI update) losslessly? :thinking:

Any ideas and help are much appreciated :sunglasses:

Could you provide more specific details about the core computer and the network as noted here below…and W-Lan is that wired or wireless?

1 Like

Hi wizard

Thanks for chiming in.
The Core Computer is Linux based and has no problems to play to different endpoints e.g. two Auralic devices (Mini and Aries).
All is connected via wireless LAN but that can NOT be the problem because with the 3rd Computer in the equation it DOES work, despice of the increased traffic.

I have (successfully) set up dozens of different roon eco-systems with pretty much all of the possible endpoint options (Squeezebox, ropieee, sonos, NUC Bridge) but I just don’t get the damned Devialet CI to work directly (avoiding the 3rd PC) with roon :rage:

Let’s tag @support here then and see what the lads chime in with.

One point to note is that if it’s at all possible to exclude the wifi as a potential issue with running a long cable or a few ideally so that the core and endpoints are all on lan based wired connections this might be a good place to start.

1 Like

My friend has a VERY big house and the roon core and the Devialets are even on different stories.
So even as a matter to rule out the Wifi as culprit, it is not feasible to run a long Ethernet cable, unfortunately.

Then try moving either core or the endpoint.

Failing that I would suggest you paint a vivid picture of the full network connectivity as per the link I posted above - I am pretty certain without this and perhaps directly connecting the endpoint directly to see if that works, its not much to go on, unless there is some known issue with your endpoint in such a setup.

What exactly is the 3rd pc doing? Is it running a core too? Or bridge or remote? We really need a detailed topology of what is what to try to help offer some things to try.

1 Like

The roon part I can handle just fine, I need some Devialet experts here… :thinking:
No Devialet afficionados here able to help?

The third PC does NOT run anything roon related. It runs something Devialet related and therefore makes the Devialet visible for roon in the Wireless Network (but it can only be streamed at lossy).

Without that Devialet app running, the Devialet is NOT visible for roon at all.

Can it be PING’d from the terminal or command line as if its not being seen by a ping then roon will never see it. I am assuming this is connected via some sort of wifi bridge? Or does the Devialet have a Wifi setup. Are all the devices on the same subnet…ire where the first 3 numbers are all the same and the 4th is unique? is the subnet mask for all and are the DNS settings all correct too?

Have you contacted Devialet support?

1 Like

Can it be PING’d from the terminal or command line as if its not being seen by a ping then roon will never see it. I am assuming this is connected via some sort of wifi bridge? Or does the Devialet have a Wifi setup. [/quote]

The Devialet has it’s own wifi module and is visible on the 3rd PC but not by roon.

Are all the devices on the same subnet…ire where the first 3 numbers are all the same and the 4th is unique? is the subnet mask for all and are the DNS settings all correct too?[/quote]

They are all on the same Wifi Net and DO work independently via Wifi.

Have you contacted Devialet support? [/quote]

The Devialets belong to a friend of mine and they are in his second System.
If we can’t manage to stream directly from roon to the Devialet, we will hook up the Auralic Aries in between again like it worked before.
Thing is, my friend made a very expensive CI update on the Devialets to avoid airplay via the Aries and to directly run the Devialets from roon… :roll_eyes:

Thank you again wizard for your help :+1:

@support not sure why one of the Roon lads hasn’t chimed in yet but lets tag them again :stuck_out_tongue:

1 Like

That doesnt say if it can be pinged or not…if not then I would start trying to see why that is…maybe it doesn’t respond to any pings? Does it from PC #3?

1 Like


There has been a discussion on this point here Devialet: Transport: Device in Use.

In summary you need to ensure that the CI firmware update (factory Config) is done (without SD config card) - you will know if the firmware has been uploaded correctly by pinging the IP address in your PC. If the Devialet in your network (with the IP address) is showing a message stating “configuring”, then CI firmware has not been properly installed but may still appear in your network but Roon will not recognise it as an endpoint. You then need to reset the latest firmware (factory config) - once you see the screen (noted in the above discussion) on your PC/ Mac - then also reboot Roon server and you will should find it appearing as an endpoint in Roon (with the Devialet expert icon).

If you are using wifi you will need make sure you have the settings configured both in Roon Core and Devialet - with wifi I cannot emphasise enough that you have a robust router (and also if possible you should dedicate a channel just for audio that is separate to video and other devices). My preference is ethernet, I have used a switch box and rely on ethernet and so far have had no problems other than what is noted jn the above post and acknowledged by Devialet as bugs.

Good Luck and I hope you get it working!


Hi Rash

Thank you very much for your Input :+1:

My friend updated the Firmware via SD Card. How is one supposed to know, that the SD Card update won’t work? :roll_eyes:
How can the Devialets be updated without SD Card? Will my friend, the owner know how to do that?

We will give it a try. Your input could very well be it.

To be clear - use two SD Cards. One is for the firmware update (go through the steps as outlined in the Devialet beta release). After this is done see if you find the Devialet on your network by pinging the IP address. To be sure remove the Factory Config SD card and do another reset of the firmware. Then once you are confident that the firmware update is done (for example look for “spotify” as an output etc) - then insert your Config SD that you had before - it should work. If you have a sub woofer make sure that is switched to 2.1 from 2.0. Even though I had mine set at 2.1 in my Config SD card I had to use the Devialet remote to fix this issue.

In terms of dealing with static on H-Res files etc please refer to my earlier post for which I provided a link.

1 Like

Are you running the “Devialet AIR” on this third computer? I would recommend checking a following link and following instructions there. It is basically recommended to disable or uninstall the Devialet AIR when using the Roon’s built-in AIR driver. They cannot be used in the same time.

1 Like


There’s a full proof summary of how to install the software & config for Master & Companion on Deviaeltchat as per link below:

Installing Software & Config on Expert Amps

For the rest follow what Rash has said.



Depends - If Devialet Air and Roon Core are on the same say PC/ Mac I would agree with you. In my case I have the NUC/ Rock that only runs Roon - The Devialet AIR sits on a windows OS platform on another PC - they both work (sometimes, has happened on rare occasions you do get the transport in error message - but I switch off the Dev and it works) for different purposes and I do not have any problems having both programs running on my network.

I just suggested to check the Roon’s recommendation. It says specifically that:

I understood that the OP’s problem was that the Devialet wasn’t available in Roon. Sorry if I misunderstood the problem here.

Hello @Christoph,

When you say that the Devialet is not able to be seen by the Roon Core on the Lampizator SuperKomputer, is this through the Roon Devialet AIR implementation as well as the Devialet AirPlay input? Are you streaming to the device using the Devialet AIR app on the “3rd computer” which is causing the AirPlay input to show up in Roon on the Lampizator?

As a troubleshooting step, I would recommend you try running the Roon Core on the “3rd computer” with the Devialet AIR application totally disabled and see if Roon can see the Devialet device when the Core is running from that computer. If so, it may be indicative on a networking issue somewhere between the Lampizator and the Devialet.