Displays not showing on Chromecast

Roon Core Machine

Nucleus Plus

Networking Gear & Setup Details

Century Link fiber optic > their C4000 modern router > NucleusPlus > Trend unmanaged switch > Linn SelectDSM

Connected Audio Devices

Linn SelectDSM .

Number of Tracks in Library

Description of Issue

Yesterday I changed ISP’s to fiber optic. I know it has been discussed many times and after searching through posts here and in the community forum I still don’t have a fix to get it back to Google chromecast.

I can’t stream the meta to Chromecast. I’ve tried all of the usual suspects, rebooted Chromecast, rebooted Nucleus, rebooted modem router, etc… etc…

It is showing in Google home and I’m able to stream to the Chromecast from any other devices. The small t.v. icon doesn’t even show so Roon isn’t even recognize it.

Any help will be appreciated. All always worked fine up until the ISP change.

@Robert_Zinn, it seems you have approached the reboot question appropriately. Are you ableo to post two screenshots, one of the Settings → Audio from your Roon Core and another showing what devices are connected to your CenturyLink router in its admin or connected devices page?

Here you are, there are more connected devices, but I don’t think they are relevant. If you need anything else please let me know. As you can see the chrome cast ultra, the one in question, is visible and works on everything else for streaming on cell etc… I also rebooted the LINN SELEKT DSM.

Thanks Robert. The network connections and IP addresses look good (all on the same subnet). However, can you try connecting the Trend switch directly to the CenturyLink router and then connect the Nucleus and Linn to the switch so the switch sits between the router and any connected devices such as the Nucleus and Linn? It may not change anything but I’m wondering if that may be part of the issue you are experiencing.

Also, can you provide any more details on what you mean when you wrote

I have done exactly that with no change. I meant the chromecast is not there to stream the information to tv

I am stuck, going to tag @support for you. Other users may respond tomorrow also.

Thank you I appreciate the effort

1 Like

Please have a look:

Perhaps it will help to disable “WPA3 – Personal” and select “WPA2 – Personal” from the dropdown menu for Security Type.

Thanks for the suggestion
Gave it a try and unfortunately no change

Is it possible the modem router provided by century link doesn’t have multicast capabilities causing the issue? Is multicast required for Roon to pick up display? TIA

Perhaps if you try to enable UPnP it will work?
From the link above I sent you:

Had done this already

Nearly out of ideas now … if not already done so:

1.Try again to disable WPA3 (so only WPA2), and disable power-save on WMM.

  1. Disable Secure WiFi.
    Check if Secure WiFi is active by visiting this website: testsecurewifi.com (copy and paste or type this URL into a new browser window)
  1. Disable IPv6

If none of this helps, then I am sorry @Robert_Zinn

Thanks so much for the help. I think the WMM is disabled, I do have the WPA2 Personal, can’t seem to find WMM tab though, is it in utilities, I’ve seen it before but my brain is completely fried now. Just as an FYI I’m using the 5ghz on the chrome cast, same as my core, so the WMM is specifically for 2.4ghz if this matters. WMM was found and was disabled.
Went so far as to replace chromecast no such luck
I’m stumped, never had this much trouble changing ISP.

Hi Robert Zinn,
it is not your fault that the problem is so difficult to solve. This seems to be an annoying bug that’s been around for years. If you search the web, you will find dozens of frustrated centurylink customers who can’t get neither their Chromecasts nor smart IoT devices to work with this router. It is understandable that this is annoying to no end.
There aren’t many possible solutions.

  1. Get a capable router, put the CenturyLink router in bridge mode, and use your own router to configure your network.
  2. Give up the Chromecasts. However, be prepared that other devices of this type will also not work with your CT Link router.
  3. You have not yet exhausted all the options for setting up your new CT Link router. There are still a few things you can try. If it doesn’t work just get yourself a new router.

I will try to write something regarding point 3, systematically in a following post, but it will take a while because I have to get back to work.

1 Like

I just thought of what might be the easiest solution in this case.
If not, however, you can return it:

If possible use this Ethernet adapter to connect your Chromecast to your router or a switch. This will give you a direct, hardwired connection to the internet and hopefully bypass your home Wi-Fi network restrictions.


• Note: Chromecast and Chromecast with Google TV both support Ethernet, but don’t have an Ethernet port. Use the Ethernet adapter, sold separately.

1 Like

Unfortunately, @Robert_Zinn, this is the last thing I can contribute:

1. Disable secure wifi
Advanced Setup => Security => Cyber Security => dropdown menu => select “Disable Modem Security Until I Turn Back to On”.

2. Disable the Power Save mode on WMM (WiFi Multimedia).
Wireless Setup => left sidebar => 2.4 GHz Setting => 2.4 GHz Radio Setup => Scroll down to “Set the WMM state”
Choose the option called “Enabled” => not “Enabled with Power Save”.

3. Try jailing your Chromecasts on the 2.4GHz network by creating a 2.4Hz-only SSID

4. Try resetting the chromecasts and re-adding.

Reboot everything.

1 Like

Thank you very much for the suggestions

1 Like

I have done this with no success, however I now want to turn the cyber security back on and in the drop down the "Cyber Security is nowhere to be found to do so. Is there another tab to reactivate it?

Select ‘Advanced Setup’
Under ‘Security’ settings on the left-hand menu, you should have an option for ‘Port Forwarding’, ‘Firewall’ and also 'Security’ at the very bottom of the list.
It should also work if you enter security as the search term.
There must be a dropdown menu. You will have to try ‘dropdown’ to get it.

Here is the help manual:

Perhaps try a reboot?

1 Like