Fatal Error - Could not create required lock file - Help

I am unable to start Roon on my mac. I receive a Fatal Error - Could not create required lock file errror.

Help!!

1 Like

The way it is posted here, the commands may not be clear. So here it is in a clearer format:

Open Terminal.app on your mac
Type the following commands and hit enter after each command:

  • cd /tmp
  • sudo chown $(whoami) /tmp
    You may be asked to enter your Mac password after that last command.

This worked for me (on a MacBook running MacOS Catalina 10.15.7).

Thank guys! It resolved my Roon problem as well as another issue. Not sure what I did, but it is much appreciated. Have a great weekend!

Maybe it works for you, but I’d be careful with those commands.

At least on macOS 12.3, the /tmp folder is a symlink to /private/tmp, which in turn is owned by root:wheel. That is for all intents and purposes correct owner and group. In turn, /private/tmp is writable by everyone. So normally, you should be able to create files in there.

If you can’t create any file in that folder, that means the permissions are not correct, and not the owner. By now changing the owner, everyone else may no longer be able to create files in there, which just means you solved one error by introducing another…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.