First part of track not played when using RAAT

Core Machine (Operating system/System info/Roon build number)

Intel NUC
ROCK Version 1.7 (build 555)
ROON version 1.7 (build 555)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ubiquity EdgeRouterX, Netgear GS switches
NUC connected via Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Devialet Expert 220 Pro (latest firmware)
Ethernet streaming

Description Of Issue

When skipping tracks the first part of the track is not played. Often only a fraction of a second but for tracks that immediately start it is very annoying.

1 Issue occurs regardless of Tidal or NAS use.
2 Issue does only occur when using the RAAT interface, not when using AIR
3 I do not use DSP
4 Configuring a sync delay regardless of length does not have an influence on the issue

I’ve reported on this a year ago. In the end I back then I preferred AIR + DSP upconvert to DSD over the sound quality of RAAT. Yesterday I though I’d try RAAT again but without DSP. Great sound only to discover the very annoying issue is still there.

Does someone have a hint or can this be tracked towards resolving?

Hi @Devialet220User,

Can you please share a screenshot of your Signal Path when playing to the Expert via RAAT? Do you have any Crossfade turned on? Does the issue only occur on certain types of tracks (a certain sample rate / MQA only / DSD / ect.)?

Hi Noris,

Thank you for picking this up.

I don’t have crossfade turned on. I tried it as a possible solution direction but to no avail. The issue occurs both with Tidal as well as files stored on the NAS.

e.g. Michael Jackson - Starting something missed out on the first drum as it starts immediately and therefor very noticeable. This is a track I have on my NAS but again it also goes for Tidal based tracks.

1 Like

I’ve been living with this since V1.7. Support can’t recreate it.

Incredibly annoying.

Good luck.

Hi @Devialet220User,

Thanks for the additional info.

This is certainly a strange aspect. Does this occur on any other zones or just the Devialet? You can use the “System Output” on any PC controllers or the internal speakers on iOS/Android remotes or the HDMI output of the NUC to confirm.

Hope my case can function as a test case and solve it for other too than

I’d love to test it but it only occurs when using RAAT and I don’t have any other Roon Ready devices in house so can’t test it. Any other ideas?

Works fine on my laptop but also works fine on my Devialet when not using RAAT.

If you skip a track using RAAT it misses the beginning. If you pause it and then push back so the track starts at the beginning again and then press play it plays the beginning. Don’t know if this is relevant information.

Hi @Devialet220User,

Thanks for letting me know that the laptop zone is unaffected.
Is there any change in behavior with the new build by chance?

If the issue is still the same - could you please try queuing up a playlist of tracks of the same sample/bit-rate and let me know if that still triggers it?

If it does - please also note the exact local time + date you experience it and the track which it occurred on for diagnostics purposes. Thanks!

The laptop zone is unaffected because it does not support RAAT.
Issue is the same with the latest build.
Tested it today June 18, 08:17

Michael Jackson - Wanna be starting something. It misses the first drum repeatedly (but not always). Hope this helps.

Hi @Devialet220User,

Thanks for the timestamp.

Just to re-confirm my question from the previous message, if you add this same track a few times to your queue and press the “next” button (so that the sample/bit rate does not change between tracks), do you still hear the same issue?

Well this is becoming interesting.

With RAAT:
I can play a whole album and skip through the tracks with the issue of missing the beginning.
When I add a single track multiple times I cannot skip. When I do you see it timing out and eventually it removes all the instances from the queue and reports “An audio file fail to load”

With Devialet AIR:
I do not have the missing beginnings and I can add a same track multimple times and skip through it

Tested this around 20:18 local time June 18

EDIT: Tested with two different local stored albums (FLAC)

Hi @Devialet220User,

Thank you for providing that info, that is certainly interesting. I can’t seem to locate any Cores registered to the email you have under @Devialet220User, are you using Roon with another email address? If so can you please send me the email you’re using via a private message (click my name -> message)?

I’ve send you a PM with my e-mail by which Roon is used. How can I change my forum e-mail address to match that of the Roon Core?

@Devialet220User - I started a PM with you regarding the email address aspect, see:

Any update possibly?

Maybe an update from my side; tracks begin correct in a playlist/queue when you let the previous track finish by itself. When you skip tracks, the beginning of the track is not played.

Hello @Devialet220User,

Thanks for the additional information. We have the Devialet in the QA lab now and are working to reproduce this issue. We’ll let you know what we find.


Thank you. Hopefully it can be reproduced.

May I ask if there is an update? Can the issue be reproduced?

Hello @Devialet220User,

We have reproduced the issue in the QA lab and are preparing to bring the issue to the Devialet development team.