Green line display artifacts in 1.8 [Intel Bug, Update Your Drivers]

Core Machine (Operating system/System info/Roon build number)

Roon rock

Description Of Issue

Android and roon rock is working fine after 1.8update. However, Roon on my WIN10 notebook is not displaying normally. Problem persist after I reinstall it on my notebook.

1 Like

Hi @LEE_HEYMAN - Can you give some additional details about the notebook? What GPU does it use? Do you have any UI overlays running like MSI Afterburner?

same issue here


i have a windows 10

Same issue here.

Roon 1.8 will not properly display on my portable computer. Works on my desktop and my three ios devices. After update, I did an uninstall and did a reinstall to same results. Use Roon ROCK Core. For computer with display problem below is system and display info. Graphics is Intel ® UHD Graphics 620

Reboot and reinstall does not help.

System Info:

OS Name Microsoft Windows 10 Home

Version 10.0.19041 Build 19041

Other OS Description Not Available

OS Manufacturer Microsoft Corporation

System Name LAPTOP-I4BFTVNL

System Manufacturer HP

System Model HP Laptop 15-da0xxx

System Type x64-based PC

System SKU 3FR23AV

Processor Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz, 2001 Mhz, 4 Core(s), 8 Logical Processor(s)

BIOS Version/Date Insyde F.07, 11/21/2018

SMBIOS Version 3.0

Embedded Controller Version 80.31

BIOS Mode UEFI

BaseBoard Manufacturer HP

BaseBoard Product 84A6

BaseBoard Version 80.31

Platform Role Mobile

Secure Boot State On

PCR7 Configuration Elevation Required to View

Windows Directory C:\WINDOWS

System Directory C:\WINDOWS\system32

Boot Device \Device\HarddiskVolume3

Locale United States

Hardware Abstraction Layer Version = "10.0.19041.488"

User Name LAPTOP-I4BFTVNL\justb

Time Zone Pacific Standard Time

Installed Physical Memory (RAM) 8.00 GB

Total Physical Memory 7.92 GB

Available Physical Memory 3.64 GB

Total Virtual Memory 12.7 GB

Available Virtual Memory 8.19 GB

Page File Space 4.75 GB

Page File C:\pagefile.sys

Kernel DMA Protection Off

Virtualization-based security Not enabled

Device Encryption Support Elevation Required to View

Hyper-V - VM Monitor Mode Extensions Yes

Hyper-V - Second Level Address Translation Extensions Yes

Hyper-V - Virtualization Enabled in Firmware No

Hyper-V - Data Execution Protection Yes

**Graphics Info:**

Name Intel(R) UHD Graphics 620

PNP Device ID PCI\VEN_8086&DEV_5917&SUBSYS_84A6103C&REV_07\3&11583659&2&10

Adapter Type Intel(R) UHD Graphics Family, Intel Corporation compatible

Adapter Description Intel(R) UHD Graphics 620

Adapter RAM 1.00 GB (1,073,741,824 bytes)

Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_608213d4152b8215\igdumdim64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_608213d4152b8215\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_608213d4152b8215\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_608213d4152b8215\igd12umd64.dll

Driver Version 27.20.100.8337

INF File oem125.inf (iKBLD_w10_DS section)

Color Planes Not Available

Color Table Entries 4294967296

Resolution 1366 x 768 x 59 hertz

Bits/Pixel 32

Memory Address 0xB0000000-0xB0FFFFFF

Memory Address 0xA0000000-0xAFFFFFFF

I/O Port 0x00004000-0x0000403F

IRQ Channel IRQ 4294967282

Driver C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\IGDLH64.INF_AMD64_608213D4152B8215\IGDKMD64.SYS (27.20.100.8337, 25.54 MB (26,784,016 bytes), 8/10/2020 8:48 AM)

graphic card is intel hd 520

I am not able to upload photo now. The Forum Server seems busy.

My notebook model is DELL latitude 3410.
GPU: Intel® UHD Graphics
No, I don’t use any UI overlay.

well intel graphics is the same material, the probable culprit

1 Like

i reinstalled it, this is what appears

sorry it’s in french

Nom du système d’exploitation Microsoft Windows 10 Professionnel
Version 10.0.19041 Numéro 19041
Autre description du système d’exploitation Non disponible
Fabricant du système d’exploitation Microsoft Corporation
Ordinateur CABOCHON
Fabricant LENOVO
Modèle 20K5S0M900
Type PC Ă  base de x64
Référence (SKU) du système LENOVO_MT_20K5_BU_Think_FM_ThinkPad X270 W10DG
Processeur Intel® Core™ i5-6200U CPU @ 2.30GHz, 2400 MHz, 2 cœur(s), 4 processeur(s) logique(s)
Version du BIOS/Date LENOVO R0IET60W (1.38 ), 19/12/2019
Version SMBIOS 3.0
Version du contrôleur embarqué 1.17
Mode BIOS UEFI
Fabricant de la carte de base LENOVO
Produit de la carte de base 20K5S0M900
Version de la carte de base SDK0J40697 WIN
RĂ´le de la plateforme Mobile
État du démarrage sécurisé Activé
Configuration de PCR 7 Élévation requise à afficher
RĂ©pertoire Windows C:\WINDOWS
Répertoire système C:\WINDOWS\system32
Périphérique de démarrage \Device\HarddiskVolume1
Option régionale France
Couche d’abstraction matérielle Version = “10.0.19041.488”
Utilisateur CABOCHON\Cabochon
Fuseaux horaires Paris, Madrid
Mémoire physique (RAM) installée 8,00 Go
MĂ©moire physique totale 7,86 Go
MĂ©moire physique disponible 0,98 Go
MĂ©moire virtuelle totale 14,6 Go
MĂ©moire virtuelle disponible 5,37 Go
Espace pour le fichier d’échange 6,70 Go
Fichier d’échange C:\pagefile.sys
Protection DMA du noyau Désactivé
Sécurité basée sur la virtualisation Désactivé
Prise en charge du chiffrement d’appareil%s Élévation requise à afficher
Hyper-V - Extensions du mode de moniteur des ordinateurs virtuels Oui
Hyper-V - Extensions de la conversion des adresses de second niveau Oui
Hyper-V - Virtualisation activée dans le microprogramme Non
Hyper-V - Protection de l’exécution des données Oui

Hello All,

Thank you for the reports, we are looking into this.
To the users impacted by this, can we please request the following information from you?

  1. Can you please confirm you have the latest Intel driver installed?
  1. Can you please open Windows Start menu and type in “System Information”. Then, share a screenshot of System Summary and Components → Display?

  2. Can you please access your Roon logs from the affected device by using these instructions and upload a set to Dropbox / Google Drive / etc. and post a link?

Thank you!

1 Like
Nom Intel® HD Graphics 520
ID de périphérique Plug-and-Play PCI\VEN_8086&DEV_1916&SUBSYS_506217AA&REV_07\3&11583659&0&10
Type de carte Intel® HD Graphics Family, compatible Intel Corporation
Description de la carte Intel® HD Graphics 520
MĂ©moire vive sur la carte 1,00 Go (1 073 741 824 octets)
Pilotes installés C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_c47dd5f0a9e85fff\igdumdim64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_c47dd5f0a9e85fff\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_c47dd5f0a9e85fff\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_c47dd5f0a9e85fff\igd12umd64.dll
Version du pilote 27.20.100.8281
Fichier INF oem47.inf (section iSKLD_w10_DS)
Plans de couleurs Non disponible
Entrées de table des couleurs 4294967296
RĂ©solution 1920 x 1080 x 60 hertz
Bits/pixel 32
Adresse mémoire 0xE0000000-0xE0FFFFFF
Adresse mémoire 0xD0000000-0xDFFFFFFF
Port d’E/S 0x0000FEC0-0x0000FEFF
Canal IRQ IRQ 4294967287
Pilote C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\IGDLH64.INF_AMD64_C47DD5F0A9E85FFF\IGDKMD64.SYS (27.20.100.8281, 25,40 Mo (26 634 976 octets), 04/11/2020 02:51)
1 Like

here are my logs

EDIT : I also tried on 32bits, same ugly screen

1 Like

Logs here: https://drive.google.com/file/d/1uLExvb1bNwYsFFo9MSA8qJPFCJ3un951/view?usp=sharing

Requested screenshot.

1 Like

logs
https://drive.google.com/file/d/1uV4YIRHwZsnlXKO9WYqCU6NRix98_rql/view?usp=sharing

1 Like

Same here on Win10(64) computer running Roon 1.8 (fuzzy image, see below). Roon server is running on separate machine (ROCK, latest ). No problem on iphone app.

requested info:

Roon logs from ROCK machine:

1 Like

What if you try using the 32 bit version. Previously, the 32 bit version worked when the 64 bit version had graphic issues on Intel 4th Gen chips.

I have so much love for Roon Labs. Thanks for working on this issue.

1 Like

Hello All,

Thank you for the screenshots and log info! For those affected by the issue - can you please confirm if you have the latest Intel Display drivers installed from your manufacturer or via the Intel Update Tool?

If running this tool resolves the issue, please let us know!

I have weird green lines appearing on the screen, unplayable… I have this issue only with roon, and only since the update

2 Likes

I updated the display driver on my windows 10 machine and now problem solved!

Here is the solution that worked for me. It does appear that you must have the absolutely latest version of the Intel graphics driver to get the latest version of Roon to display correctly, as least that was my experience. Specifically, Device Manager and Windows Update all reported that my PC had the latest version, as did Driver Easy. But that “latest” version is not the absolutely most recent version of the Intel graphics driver that was posted by Intel in late January – only about two weeks ago.

Some additional specific instructions that might help. The Intel driver support assistant link that Roon supplied above failed – the driver update failed. I then downloaded the driver manually from the link below. When I ran that driver update, it also failed and reported that I already had that version of the Intel graphics driver installed. But when I checked the graphics driver version number by comparing what the web site reports and what device manager says, it was clear that I did not have the latest driver installed. So I deleted the Intel driver that I downloaded. I downloaded again. Ran the update again. That time it worked, and now Roon is fine.

So if you are having this problem, download the latest Intel driver from the below link. You might have to download more than once and run it more than once. Again the Intel assistant tool failed in my case. So download the Intel driver manually and install manually.

One other tip – if you use Device Manger and ask it to update driver, that will NOT work and it will report that the most recent version is installed. I also use a program called “Driver Easy” and it also incorrectly reported that the most recent driver is installed – when it was not. So do not go by Device Manger and any other program.

Download the Intel driver manually; run the install several times as may be necessary; and with a little luck Roon will work OK.

I would also report that only the latest version of Roon had this problem. All other software worked fine with the previous Intel graphics driver – and that was a very recent version. So the latest 64 bit version of Roon appears to not be very flexible or tolerant of various windows Intel graphics drivers. The new version of Roon fails with a very recent version of the Intel graphics driver as reported both within Windows update; within Device Manager; and by Driver Easy. All of those reported that I already had the most recent graphics driver. But that “recent” version resulted in the same graphics problem reported above.

Only the absolute latest version of the Intel driver worked with the new version of Roon, at least on my PC.

Roon might look into this a bit more, as very recent Intel graphics drivers are failing – specifically the most recent graphics drivers as reported within Device Manager; Windows Update and Driver Easy.

With that said, hopefully those Roon users having this problem can solve it by downloading the Intel driver from the below line. Again, run it more than once as may be necessary.

One other tip: do not bother to download the 32 bit version of Roon. It will have the same graphics problem, at least that was my experience. I also downloaded the 64 bit version of Roon and reinstalled that. Same graphics problem reported above. The only solution that worked was to download the absolutely latest version of the Intel driver that was posted only about two weeks ago.

Warning – based on one report below, the latest Intel driver can cause more problems that it solves on some PCs. So your mileage may vary.

1 Like