Green line display artifacts in 1.8 [Intel Bug, Update Your Drivers]

Am I the only person this is happening to? Tried restarting / reinstalling. No dice.

Prescribed fix resolved the issue. Thank you.

Nope. Me, too.

Plus, ASUS says driver is up to date and Intel’s driver makes the system unbootable.

Thanks Adam. When I install, I get a message that unable to install driver as need custom driver for computer. I have HP. Went to HP’s website and installed their latest driver. Still no joy. Likely will need to wait for Roon Labs to come up with a solution that works with my display’s driver.

Driver Failed to Load (2)

Update. When in doubt follow directions. Followed the directions here on deleting and updating driver. Error Message Appears When Installing Intel Graphics Driver... Afterward, I was able to install latest graphics Windows 10 DCH driver and can now see Roon 1.8 in all its glory.

Thanks again Adam!

I entirely agree that the latest version of Roon is very finicky and not tolerant with regards to working with recent graphics drivers. As I reported, on my PC Roon failed with a very recent Intel driver – Device Manager, Windows Update and Driver Easy all said I had the most recent driver. And that resulted in the video corruption reported above. Only the Intel version from two weeks ago worked. But your computer won’t let you install it, and there is another report above that it made one PC unbootable.

My suggestion to the Roon development team is to test a new version on at least 20 different PCs of different manufacturers and ages. But maybe they did that and still didn’t detect the problem.

Adam. Again much thanks!!

I had to uninstall and delete my existing graphic drivers and then I was able to install the Windows 10 DCH Driver. I am now able to see and run Roon 1.8.

1 Like

This issue is caused by a bug in Intel’s GPU drivers that causes graphical corruption with applications that utilize 30-bit (“deep color”) frame buffers. We encountered this bug during the development of Roon 1.8, but it has been fixed in Intel’s driver releases since July or August of last year.

To update to the latest GPU drivers, use the Intel® Driver & Support Assistant.

If you cannot (or do not wish to) update your GPU drivers, you can disable 30-bit color on Windows by adding the -nodeepcolor argument to the application shortcuts that you use to launch Roon. You can access this setting by right-clicking (or shift+right-click on pinned task bar items) on the shortcut, selecting “Properties”, and adding the flag to the end of the “Target” field, like this:

There will be a very subtle drop in visual quality and the decrease in performance will probably not be noticeable unless you’re using a 4k display or have multiple monitors.

8 Likes

Thanks, It works after I manually update the Intel UHD driver.

After I managed to install the most recent Intel driver (see my previous post), I noticed that letters were dropped in some Playlist titles. So “Jazz Playlist” would be shown as “Jazz laylist” to offer an example. This only occurred on my monitor connected to my PC. The display was correct on iPads, so this was clearly related to the graphics card and driver on the PC.

Oddly, I only noticed this problem on the names of some Playlists.

I then added “-nodeepcolor” as recommended. That eliminated the artifact of losing letters.

I didn’t notice any difference in color depth or the display.

I usually have this happen when the Intel driver gets in a bad state, usually from some application using too much video memory. When this happens to me, the PC never seems to fully recover (the GPU starts behaving strangely in all applications). I’ve never been able to really resolve the issue without restarting the affected computer.

A post was split to a new topic: Roon App Crashing after fixing green screen

Has roon offer a repair yet?

My laptop is an HP. Had the same problem with green screen. Intel says manufacturer will not allow you to download and change any Intel version of HP graphic drivers. I went onto HP website, inputted my computer info and was able to download their latest update (7/2020) for the graphic driver. That fixed my problem.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.