Having issues since the last couple of Roon updates

Roon Core Machine

I am running the Roon Core on a Nucleus Plus

Networking Gear & Setup Details

My Nucleus Plus is connected to a TP-Link internet switch and then to an Eero networking wifi system.

Connected Audio Devices

I play music through a DCS Rossini DAC/Streamer that is also connected to the LAN via the TP-Link switch.

Number of Tracks in Library

416,832 tracks; 30921 albums

Description of Issue

I have been having innumerable problems with Roon for the last two updates. Things worked fine in version 1.8-- and that point I ran Roon on my Zapitti NAS. Once version 2 came out, that became nonfunctional. I moved my Core to a Mac desktop: that worked somewhat, but still was highly glitchy even when I added additional memory. In desperation, I invested in a Roon Nucleus Plus, which I hoped would solve my problems or nonconnectivity, and sluggish or no playback.

Since the last update, however, even my Nucleus Plus is balking-- scarcely bringing anything up and scarcely playing. For the last two weeks I’ve had the arc circling in the upper right of my iPad screem claiming “Adding music to library” but stuck at 547 tracks out of 18417 (or so it says).

i do have an extraordinarily large music collection (which Roon reads off of both a Zappitt NAS and a Synology NAS), but my previous setup (an Aurender) and my current DCS Rossini Mosaic system handles this just fine. Advice? I hope that the size of my collection is not making Roon wholly unusable-- I
bought a lifetime membership, and then a Nucleus Plus, just so this wouldn’t happen.

Scott Klein

It has been nearly a week since I posted this with no reply-- which is also a week without music. I would hope to hear from someone at Roon soon.

Not really a permanent solution but perhaps running 1.8 will at least you up and running for now?

I’ve now tried several additional things, none of which have solved my problems. I followed instructions I found online for stopping the Roon Core, creating a new data base, restarting and doing a restore. I also tried moving my Nucleus Plus into another room and connecting it directly to my modem/router instead of to a switch and then into my Eero system. Each attempt has either not solved the issues, or has created new ones.

Given all of this, and some of the error messages I have seen along the way, I suspect my Nucleus Plus is having trouble connecting to your servers. But I’m not a computer tech-- I’m a music lover who thought that the Nucleus Plus would be a latchkey solution.

I could really use some systems advice!

It has now been two full weeks since I posted my problem, and I have still not heard from anyone at Roon. I understand that there are probably a large number of Support posts to handle after an update, but this level of technical support is disappointing, given particularly that I’m trying to get a new Nucleus Plus up and running and have a lifetime membership to Roon. Is there any way of learning how long the current help queue might be? I’ve been forced to go back to a UPnP Minimserver setup in order to listen to any music.

@Scott_Klein let’s try and tag @support.

Hey @Scott_Klein,

Thank you for your continued patience while we work through each thread! I understand your frustration when each new instance of Roon seems to cause you more issues.

While we take a closer look at things, could you please break down more information around how your library is setup and connected to your core?

If you only connect one of your watched folders, and only import a small portion of your library, do you still have issues?

I would continue to bypass any network gear while we continue to troubleshoot. A direct hardwired connection to your router is best!

If you could share a screenshot if the webUI of your Nucleus as well, that would be helpful. :pray:

1 Like

May thanks for this reply. I tried disabling the Music folders that Roon reads from my Zappiti NAS, leaving only the folders from the Synology NAS, but it doesn’t seem to make much difference. I can try tomorrow moving the Nucleus back to the router from the Eero system. Here are two screen shots of an error message I get, and the snapshot of the Roon setup screen.

1 Like

1 Like

I’ve now tried to restrict Roon to only read the music I’ve imported into the Nucleus itself— about 600 albums— and now it’s functional. I still have a red triangle at the top telling me that metadata update has been paused, however, because Roon can’t reach the servers. This is the first functionality for music playing I’ve had since my issues began.

1 Like

Hey @Scott_Klein,

Thank you for the update! Lets get your database refreshed before moving forward:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database

Let me know if you still run into issues getting your folders setup. If so, I’d like to investigate potential advanced security settings on your router.

Which model router are you using here? Can you confirm Roon has proper exceptions for connecting to our server? What DNS are you currently using?


I include a photo of the bottom of my router. I had created a new Roon database previously using these instructions from online and that didn’t help, so I doubt it’s the problem (but I could do it again if you think I should).

As for “the proper exceptions for Roon to connect to the servers” I would need instructions on how to discover that (I am a music lover, not a tech guy). I also don’t know what you mean by “what DNS” I am using. Is that the IP address for the whole LAN system? For the Nucleus itself?

PS. Roon still continues to operate when I disable the files on both of my NASes and use only what’s on the Nucleus interanl storage. As soon as I add in even one of the folder on a NAS, Roon freezes up again (or runs painfully slowly-- such as playing a track or two and then spinning for minutes before playing the next track.)


DNS (domain name system) servers are usually set in your ISP router and often default to their servers. Sometimes these are slow and unreliable, even though they are essential in networking.

It’s often beneficial to change to fast public DNS provided by, for example, Google, Cloudflare and Quad 9.

You can check by logging into your router. On your router it’s on the Network WAN Connection page.

Change the servers to and respectively.

1 Like

This shouldn’t really be advise for fixing something that worked fine before updating, and now, from the screen shot above, appears to be stuck importing. I feel sorry for the op - 2 weeks waiting for help, and he gets „change your dns“. Renaming the “RoonServer” folder will probably work, but at what cost? I hope he doesn’t have lots of time invested in edits. Perhaps I’m just being grumpy, lol.

1 Like

A progress report: I reset my Motorola modem/router to factory defaults and changed the DNS settings as Martin suggested above-- thanks, Martin! This helped somewhat: the Nucleus can now operate Roon normally with the music I had transferred to its internal storage, and I started then adding watched folders one by one from my Zappitti NAS. This continued to work up to a point: but when I asked Roon to watch the largest of the folders (containing around 150,000 tracks) it jammed again-- everything works extremely slowly if at all, and when a chosen album comes up on the Roon remote screen the “play now” button doesn’t function at all (yet if I highlight the first track and press the “play from here” button it does, even if sometimes with a long lag time).

On the other hand, I’m no longer getting the error message that my connection to the server cannot be verified. Perhaps this large number of files will take some time to process, and is currently using a good deal of the Nucleus processing power. As it happens, I need to be out of town for several days. I will let Roon run in my absence and see what i find when I return in a week.

1 Like

Do you have Audio Analysis Turned OFF? If not, try turning it off and seeing if the slow behavior clears up.

I have now returned after being out of town and letting Roon run for several days, hoping that would resolve my problems with playback from my large collection. It hasn’t. That is: under “Storage” it says that all of the music folders I have asked Roon to watch are “Connected” and “Watching for new files in real time.” But in practice when I try to play music from the main page on my iPad I still get the Roon logo pulsing for ages, and a constantly spinning “Adding Music to Library” signal that appears to be stuck. If a selected album finally comes up-- which it sometimes does-- it can take minutes: and if it plays it is as likely as not to play a track (or two or three) and then it stalls, taking up to several minutes for the next track to come up. It’s infuriating. And as I’ve mentioned before, this worked fine under Roon 1.8, but not since.

So: I did change to DNS setting on my Motorola router to apparently a faster setting (as Martin had suggested above), but I’m still having significant trouble. I had tried moving my Nucleus from being connected to an Eero system to another room to connect directly to the router-- but that didn’t solve anything. The one thing I haven’t tried is connecting the Nucleus directly to my two NASes by USB cables. But I would prefer that the system work as I currently have it connected to Eero, if possible: this mode of connection did not stand in the way of my other past systems (MinimServer or Roon 1.8) accessing the music data efficiently.

What are the next troubleshooting steps? Help, please!

Oh, yes; and I have turned off both “Background audio analysis” and “On-demand audio analysis” to no apparent effect.

Hey @Scott_Klein,

Thanks for the update, and I’m sorry to hear your still struggling with your Nucleus. We just released a new update that may help, if you could please update your core and remotes to build 1234, and let me know if you’re able to get your storage locations back up and functioning properly.

If you’re still running into issues, a good next step would be a full re-install of the Roon OS from the webUI. Make sure you have a recent backup just in case.

I’ll be monitoring for your reply. :+1: