HDMI Input on Denon SR8015 from NUC Not Showing in Roon

Hi, can anyone help?

I have a ROCK comprised of:

Intel NUC 10 Performance Kit, BXNUC10I7FNHN, Frost Canyon, i7-10710U, DDR4 SO-DIMM, M.2/2.5", Wi-Fi 6/BT, Barebone

500GB WD Blue 3D, 2.5" SSD, SATA III - 6Gb/s, 3D NAND, Read 560MB/s, Write 530MB/s, 95k/84k IOPS

250GB Samsung 970 EVO Plus, M.2 (2280) PCIe 3.0 (x4), NVMe SSD, MLC V-NAND, 3500MB/s Read,2300MB/s Write, 250k/550k IOPS

16GB (1x16GB) Corsair DDR4 SO-DIMM Vengeance, PC4-21300 (2666), Non-ECC Unbuffered, CAS

Roon OS is on the M.2 drive.

I can get audio fine via the on board USB to my Zen DAC Signature V2.

However, there is no HDMI audio option in the Roon app for my Denon SR8015 connected to the NUC directly via HDMI. I only see the Airplay option available for it?

I can see BIOS etc on the screen visually via the NUC HDMI though.

Does anyone know how to get the HDMI audio route working?

Many thanks in advance!

Just to mention that the NUC unit came with a Windows BIOS version FNCML357.0052.

As I recall you will not see the HDMI to Receiver identified. You should see HDA Intel PCH HDMI 0 - 4. listed under connected to core. Enable HDMI 0 then name it what you want. In the device setup you should find a listing for your Denon to identify it as Roon Tested.

Hi there - many thanks for the response. The problem is that there is no such Intel HDA device listed. Only devices listed are the connected USB DAC and airplay.

Is there an option in the BIOS to enable/disable HDMI?

Hi, there doesn’t appear to be. Only options are enable CEC over HDMI which I have and HDA which I have.

Hmm - this is odd, and you are the second person to report this in the past week (same NUC model); see:

I’ve taken the liberty to move your post across to the Support category of the forum, where it will be seen and responded to, by a member of the Support team.

For completeness sake, can you also give details of your network hardware and configuration? Thanks.

1 Like

Hi there, many thanks for looking at this. Network configuration is as follows:

NUC is directly connected to a TP-Link TL-SG108S, 8 Port Gigabit Ethernet Network Switch via ethernet cable (Ugreen Cat 8). Ethernet switch is connected to router via Cat 6 cables.

I have no issues with networking of the NUC.

Nuc10i7 with 32gb ram Rock m.2 drive and 2tb sata internal music storage. Was using for Plex/handbrake/RemoteDesktop/MakeMKV
Network switches are unmanaged or smart unmanaged switches . GS110EMX, GS108PEv3, USW-Flex-Mini and network provider router. Plus a single access point, but currently controlling through hard wire connection.
I may have something wrong in my bios settings? just not sure what. I checked to see that the audio stack was on. It is. I’ll get pictures of bios Tuesday.
I plugged Rock into another monitor. it also did not show option for HDMI output.
I am still not sure if did the ffmpeg correctly. I extracted it twice and then added it to Rock, but that did not work. I only extracted the ffmpeg once and added it and this said it is working correctly.

Is there a broadcast port number that maybe blocked. Is there any keyboard commands I can type into rock to see if HDMI has audio out option. In case it’s not read over network.
Could I somehow be broadcasting over the same port as my Plex server?
I enabled the HDMI controls in BIOS and still not audio output option

Hi, are Roon support able to solve this?

They haven’t responded in this thread as yet - it may not have reached the top of their queue of issues to deal with. It’s also the weekend now, and they keep business hours. However, just in case it has fallen through their net, I’ll flag them again with this: @support

Hey @millarda1971,

Sorry we’re only replying today - we just got back to work after the weekend :nerd_face:

Could you please grab a set of logs, using these instructions, and uploading them on our drive?

Please, let us know once you had a chance to do that, so our team can take a closer look right away.

Hi Rebeka, many thanks, I’ve done that now.

Hi, any news from the logs?

Hello @millarda1971 ,

It is strange that no HDMI options are appearing. Can you please try to see if a RAATServer reset helps with this situation?

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in the RoonOS Web Interface
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the RoonServer in the WebUI to generate a new RAATServer

Let us know if this procedure changes the behaior, thank you.

Hi, the procedure suggested does not change the behaviour. I still have the same issue.

If you plug the hdmi into your TV do you see any output ? You should get a small amount of text indicating rock is running.

Hi, yes, I get the text, as usual. Just no HDMI audio output, only Airplay.

Hello @millarda1971 ,

Thanks for giving this a try. We are looking into this issue, but it appears that this issue may be due to Missing Intel HD Audio support, there was a similar report here:

We are looking to confirm this with our team, but any NUC10 model that ends with N may be impacted by these missing Intel audio drivers.