Help! At my wits end with trying to get Roon ARC to connect and have run out of things to try

Roon Core Machine

Using a Zappiti NAS SE as my core connected via ethernet.

Networking Gear & Setup Details

Router is a Netgear Orbi RBR50 mesh system, no VPN on the router. ISP is Altafiber (terrible technical support). Modem (supplied by Altafiber) is a Nokia fiber optic modem and I have no access to its settings.

Connected Audio Devices

Number of Tracks in Library


Description of Issue

I have tried everything I can think of but can’t get ARC to connect. I don’t get any error messages, it just won’t connect. The Roon Remote app on my iPad shows that my core has been confirmed to be securely accessible by ARC. When I pull up the ARC app on my iPhone, it always shows “core last seen X amount of minutes or hours ago,” so it can obviously see the core, but then when I click on the connect button, it just spins and spins and never connects. I’ve tried the ARC app on 3 different iPhones with the same results every time. I’ve never gotten any error messages on either the ARC app or in Roon Remote saying that something isn’t configured correctly, it just won’t connect.

In my router I have created a static IP for the core and have configured port forwarding to match what’s assigned in the Roon Remote app. I have tried using the default 55000 port, other ports, and also tried adding a range of ports as suggested by someone else on this forum who was having problems with an Orbi router, but that didn’t work either. Internal and external port ranges are identical. Protocol is TCP. The router is in router mode, not AP mode. UPnP is turned on in the router. According to my ISP they do not use CG-NAT, so I’ve ruled that out as a potential problem.

My core is a Zappiti NAS and I do not have access to any of its settings (everything has to be configured in the NAS remotely by Zappiti). I’ve seen some people say that they’ve set both their core and core address in the router to a static address, but I’m only able to do that in the router. I have no access to be able to change anything in the core itself and Zappiti refused to try setting the NAS to a static IP address due to the possibility of them ultimately being locked out of it if something ever changed with my router/setup.

I’m currently trying to find out if my fiber optic modem (provided by Altafiber) is set to bridge mode. I have no access to its settings either and between the language barrier with their overseas tech support call reps and their general overall lack of any real technical knowledge, I have yet to be able to get an answer on the “is the modem in bridge mode” thing.

Any ideas? I’m fresh out at this point. Thanks.

John, I’d suggest first trying it without outside access, as you can use your LAN to access the Core. In Settings / Roon ARC, set your port to 0. Then with your phone on the same internal LAN wifi, try running ARC. This should work regardless of your ISP and their fiber modem. Let us know if that doesn’t work.

As soon as I set the port to 0 in settings/Roon ARC, the status changed to “not ready” and it says “Roon ARC was unable to securely access your Roon core.”

Can you set your isp modem to do port forwarding. That fixed it for me with a similar configuration using an Orbi as the router and AT&T modem.

As far as I know, I have no access to the modem’s settings. It’s a Nokia fiber optic modem that belongs to/was provided by my ISP.

I thought setting it to 0 effectively disables ARC externally…could be wrong but recall that was a setting.

Given the message in Settings > Roon ARC, and thar ARC does connect, I’d suggest port forwarding is setup correctly.

Accordingly, I’d look for other issues. For example, does your NAS go to sleep, does it meet minimum specification for core etc.? You appear to have reserved an IP, so that’s not the problem.

Can you use ARC in the home on Wi-Fi before trying 4G? What happens? Is the NAS active?

sounds like its time to use the NAS as JUST a storage device and try another PC/MAC as a core and see if that works just to prove you have a NAS issue.

I think that’s correct - the following from the OP is quite strange and probably is leading to the problem - the Zappiti does not seem to be designed for much/any control by the user

That’s right. My thought was to first see if you can get it working internally. Eliminate suspects, collect info.

OK, so that’s a problem. I run Core on my NAS, and when I set the port to 0, the ARC app on my phone will still connect and work, when that phone is on my local network.

So, as Martin and Mehul pointed out, it sounds like maybe the NAS is the issue. Perhaps it has a firewall turned on?

As far as I know, the NAS doesn’t go to sleep. I have the new SE version of the Zappiti NAS which does meet the specs for a core and Zappiti markets it as such. The same thing happens with Roon ARC when attempting to connect at home over wifi, it just spins and spins when you hit the connect button.

When I pull up the ARC app on my phone, it always shows the core’s name (ZAPPITINAS) and “last seen X amount of time ago,” but the time last seen varies. Sometimes it’s 3 minutes, sometimes 15 minutes, sometimes 3 hours, etc. Evidently it does see the core at certain points/times, just not when I’m trying to connect.

At this point I’m leaning towards something needing to be configured differently in the core/NAS as the problem. Unfortunately there’s nothing I can do about that as I’m locked out of being able to change anything with it. Since ARC is a brand new product, I’m hoping that it’s just a matter of Zappiti realizing that they need to make a settings change in everyone’s NAS units to allow the app to remotely access it and that will fix the problem.

In the meantime I will try wizardofoz’s suggestion and see if temporarily using my PC as the core confirms that the Zappiti NAS is the culprit.

Yes, it sounds like the NAS is the likely culprit for whatever reason. I’m going to have to get with my dealer and see if he can light a fire under Zappiti to figure this out and change whatever needs to be changed in the NAS or come up with a workaround. I contacted them myself (and their support team is generally very responsive, so I give them credit for that), but they weren’t much help with this issue and refused to try setting my NAS to a static IP, even on a temporary basis just for diagnostic purposes.

In your router, you should be able to reserve the current ip address of your nas and have it always be assigned by dhcp. That’s pretty much the same as a static ip. Doesn’t sound like that’s your problem, but worth a try to at least work around the static ip concern.

IP address reservation in the router has already been done with no success.

Please note that Zappiti are now working with Roon on this matter.

1 Like

Excellent. Hopefully it ends up being a simple fix.

Hi @Skillet,

Here is what I found on Zappiti’s website. Unfortunately, it doesn’t appear to be an easy fix and requires some tweaking to make it work.


Thanks, but installing the regular Roon app on a Zappiti media player is not what I’m trying to accomplish. I have a Zappiti NAS (separate from their media players) that I use as my Roon core. I have no problem connecting to it with the Roon Remote app on my iPad, but I cannot connect to it with the new Roon ARC app on my iPhone. I don’t get any configuration/settings errors and the ARC app seems to see the core (at least sometimes), but it will never connect to it.

Hi @Skillet,

The Roon Core implementation on the Zappiti is not something that is supported by Roon. Their implementation provides non-standard naming conventions and architecture that can prevent ARC from working.